Jump to content
micharockt

Bei Anmeldung Länderauswahl nicht möglich - Land ist ungültig

Recommended Posts

Hallo,

 

nach update von 1.5.3.1 auf 1.6.1.3 ist eine Anmeldung im Shop nicht mehr möglich - ich habe Stunden zugebracht die Lokalisierungen, Zonen, Länder, Sprachen, Versanddienste zu checken - ohne Erfolg.

Es ist ein Schweizer Shop
Länder - Schweiz, Deutschland etc. - Aktiviert

Zonen : 1. Eu und 2. Out of EU - Aktiviert
Schweiz ist Out of EU
Versanddienst deckt beide Zonen ab - zudem ist das FO nicht auf Länder mit Versanddienst beschränkt.

Einzig beim Iso Paket bin ich den empfohlenen Einstellungen nicht gefolgt. Mein Shop benutzt das ISo Paket Deutschland mit Land Schweiz. Dadurch entsteht das Länder- und Sprachkürzel DE - aber selbst das Land Deutschland kann man im FO nicht auswählen. Das Kürzel DH möchte ich aus google technischen Gründen nicht wählen.

 

Länder werden beim Anmeldeprozess auch angezeigt - nach Auswahl und speichern erfolgt Fehlermeldung.

Kennt jemand das Problem?
Es ist dringend, da mein Provider die php Version geändert hat - 1.5.1.3 ist meinen Kunden nicht mehr zumutbar - allerdings sollte die Anmeldung schon möglich sein,-)

Share this post


Link to post
Share on other sites

So besonders dringend scheint's dem TE ja dann doch nicht zu sein ...

 

Gibt es bei der Auswahl sowohl von Deutschland als auch der Schweiz eine Fehlermeldung? Ist der Text der Fehlermeldung ein Betriebsgeheimnis?

 

Wie wurde das mit dem Ländermischmasch genau eingestellt? Wurde mal eine "normale" Einstellung getestet?

Share this post


Link to post
Share on other sites

Entschuldigt bitte die lange Antwortzeit - ich habe Alles gelöscht und nochmal ein update gefahren - es lag wohl an einem nicht aktualisieren 1 click Modul. Nach dem Update ließ sich Alles wieder einstellen - Sorry und Danke.

Share this post


Link to post
Share on other sites

Das hat erst funktioniert und dann hast du Einstellungen geändert und jetzt tritt das Problem auf?

Habe mir das gerade mal angeschaut, deine Länderliste sieht ungewohnt aus, hast du da etwas geändert oder läuft da ein Fremdmodul? Die Kanaren sind doppelt vorhanden, außerdem wie die Balearen mit Klammern (wer weiß, vielleicht machen die Ärger).

Share this post


Link to post
Share on other sites

Die Kanaren stehen tatsächlich doppelt in deiner Liste (d. h. zwei Einträge namens "Kanaren"), das ist so sicherlich nicht beabsichtigt.

PHP 7.3, da sind Probleme wohl nicht unwahrscheinlich.

Damit du beim Fehler 500 eine Fehlermeldung erhältst, aktiviere Error Reporting.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More