Jump to content
dingedong

Beim Artikelimport Neu/Update werden Kategorien willkürlich erstellt

Recommended Posts

Guten Tag liebe Community,

 

seit kurzem ist es so wenn ich Artikel importiere oder zum Beispiel den Lagerbestand aktualisieren möchte, das automatisch ganz willkürlich Kategorien erstellt werden. 

 

Das einzige erkennbare Muster ist, das die Kategorien immer als Unterkategorie der Startseite erstellt werden. Ansonsten sehen die Kategorien nämlich wie folgende Beispiele zeigen aus:

 

ID: 7475   > Name: 824

ID: 7476   > Name: 1419

 

 

Also die ID immer fortlaufend, der Name der Kategorie ist immer eine Zahl. Oftmals kommen die Zahlen sogar doppelt vor. 

 

 

Der Fehler passiert auch Unabhängig davon ob ich die Prestashop Importfunktion verwende oder ein Modul. 

 

 

Ich hoffe hier kann jemand helfen. Denn der Lagerbestand wird täglich mehrmals aktualisiert und dabei werden dann jedes mal mehrere 100 Kategorien erstellt.

 

 

Liebe Grüße

 

Dennis

 

 

P.S: Prestashop Version 1.7.1.1

Edited by dingedong (see edit history)

Share this post


Link to post
Share on other sites

Es betrifft aber nur den Import? Hast du in der Importdatei etwas verändert? Läßt sich der Zeitpunkt, seitdem der Fehler auftritt, irgendwie zuordnen, evtl. auch einem Prestashop-Update?

Share this post


Link to post
Share on other sites

Genau, es betrifft nur den Import von neuen Artikeln bzw. aktualisieren der vorhandenen Artikel. 

 

Mit Prestashop 1.6 hatte ich das definitiv nicht. Als ich mit 1.7 angefangen hatte, war das auch noch nicht so. Ich bin mir nicht genau sicher aber ich glaube das fing an nachdem ich das Modul Cron-CSV-Import installiert habe. 

 

Um zu testen ob es daran lag hatte ich das Modul allerdings auch wieder zurückgesetzt und deinstalliert. Mit dem normalen Import passiert der Fehler allerdings auch, außerdem bekomme ich da regelmäßig eine Fehlermeldung die dann so lautet: 

 

errors ocurred

   - error

 

 

Also ziemlich eigenartig.

 

Die Prestashop 1.7 habe ich bisher noch nicht geupdatet.

Share this post


Link to post
Share on other sites

Von Prestashop 1.7.x raten hier ja nach wie vor fast alle ab, es gibt von vornherein viele Bugs, von denen mit Updates manche gefixt wurden, aber auch wieder neue dazukamen, vielleicht ist das bei dir auch der Fall. Praktische Erfahrungen mit 1.7 gibt es von den Foristen bisher nur recht wenige.

 

Du könntest auf jeden Fall auf eine neuere Version updaten, vielleicht erst einmal eine spätere 1.7.1.x-Verision. 1.7.2 ist gerade erst herausgekommen, da würde ich vielleicht erst einmal die ersten Reaktionen abwarten.

 

Ansonsten würde ich eine Importdatei mit nur einer oder wenigen Zeilen erstellen und testen, was passiert, vielleicht läßt sich das Problem so einkreisen.

Share this post


Link to post
Share on other sites

Liest sich für mich so, wie wenn es einen Versatz in den Kolonnen des CSV gegeben hat. Sind obige IDs bzw. Namen irgendwo im CSV vorhanden?

Share this post


Link to post
Share on other sites

Guten Morgen 

 

erstmal danke das ihr euch Zeit genommen habt. 

 

Das Problem ist vorerst gelöst. Ich habe auf die neuste Version von Prestashop geupdatet und bisher läuft alles 1A. 

 

 

Woran es nun letztendlich gelegen hat, kann ich nicht genau sagen. Auch wenn ich eine CSV Datei mit nur 2-3 Artikeln hochgeladen habe und ich zu 100% sagen kann das die Datei in Ordnung war, trat der Fehler auf. 

 

Naja zumindest für mich ist der Fehler nun mehr oder weniger behoben. 

 

 

Vielen Dank nochmal

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More