Jump to content

Recommended Posts

Hi there,

I am trying to install PrestaShop 1.7 for the first time. Unfortunately it is not an easy task.

 

I already solved two problems by myself (cache error due to max_execution_time and HTTP 500 error).

 

Now, the current problem:

 

1: HTTP 200 - parsererror - 

Warning: require_once(/home/users/kh_32787/www/app/cache/dev/namespaced_class_stub.php): failed to open stream: No such file or directory in /home/users/kh_32787/www/classes/PrestaShopAutoload.php on line 159
 
Fatal error: require_once(): Failed opening required '/home/users/kh_32787/www/app/cache/dev/namespaced_class_stub.php' (include_path='/home/users/kh_32787/www/vendor/pear/pear_exception:/home/users/kh_32787/www/vendor/pear/console_getopt:/home/users/kh_32787/www/vendor/pear/pear-core-minimal/src:/home/users/kh_32787/www/vendor/pear/archive_tar:.:/usr/share/php:/usr/share/pear') in /home/users/kh_32787/www/classes/PrestaShopAutoload.php on line 159

 

Can someone please help?

 

a.) maybe wrong code or wrong allocation where the file should be? 

 

b.) I am not quite sure how I should adapt the code on line 159 in the file "PrestaShopAutoload.php"

Line 159 currently holds the text: require_once(self::getNamespacedStubFileIndex());

 

Thank you very much in advance.

 

Best,

Victoria

 

Screenshot of error: https://cl.ly/2B3U2c2M2z0Y

Edited by Tschüssy Klamotten (see edit history)

Share this post


Link to post
Share on other sites

Tried installing 1.7.72.

Same error here....amazing no one has an answer. Seems like lots of people have same problem.

Share this post


Link to post
Share on other sites

I think I found the problem...and the solution.
It is in php file for website. 
In the php Configure Command section it must have '--enable-intl'  in it or the installation will fail; get this error.
Tried it on two different web hosts - One with and one with out '--enable-intl'  in php.

One that did not have '--enable-intl'  in php got this error. (godaddy)
One that did have '--enable-intl'  in php worked; not problems. (inmotion)
 

  • Like 1

Share this post


Link to post
Share on other sites

@ArtistToonz: 

1. Which php file are you talking about / where is it?

2. Where exactly did you place '--enable-intl' within the php file?

Thank you very much! Cheers, Victoria

  • Like 1

Share this post


Link to post
Share on other sites

Hi Victoria, I think he was refering to the php configuration file. Some webhoster allow to have a local configuration by putting a php.ini file on your webserver. intl is an php extension that is required by prestahop - if this is missing you should have gotten an warning message in some of the earlier installation steps. Not sure if this would solve your issue but maybe it's worth a try. As your errors are also referring to a cache directory I recommend to start the installation from the beginning in clean directory

Edited by JBW (see edit history)

Share this post


Link to post
Share on other sites

I believe it has something to do with the browser you use to install Prestashop. I kept getting an error when using Chrome to install. Once I tried using Internet Explorer it installed fine. 

Share this post


Link to post
Share on other sites

Anyone having this issue, check your php version and make sure it is compatible with your Prestashop version. Possibly also try to make a clean installation of php. This fixed it for me.

Share this post


Link to post
Share on other sites
On 11/3/2019 at 6:21 PM, sysproo said:

same issue here, i tried with firefox and it works like charm

it works

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More