Jump to content

MwSt Warenkorb und bei Kasse


Go to solution Solved by rictools,

Recommended Posts

Hallo Leute,

 

dieses EU Modul funktioniert so weit recht gut. Allerdings zeigt es mir im Warenkorb und bei der Kasse keine Extra Auflistung der MwSt an. In der Hilfedatei (PDF) die bei diesem Modul mit dabei ist, wird es allerdings angezeigt. Nur suche ich diesen Button vergebens.

 

Kann mir da mal jemand bisschen auf die Sprünge helfen?

 

Installiert ist die aktuellste Version von PrestaShop, ebenso vom EU Modul.

Theme ist das Standard Theme.

 

LG

Frank

post-508739-0-49523900-1463068390_thumb.jpg

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • Solution

Hallo Leute,

 

dieses EU Modul funktioniert so weit recht gut. Allerdings zeigt es mir im Warenkorb und bei der Kasse keine Extra Auflistung der MwSt an. In der Hilfedatei (PDF) die bei diesem Modul mit dabei ist, wird es allerdings angezeigt. Nur suche ich diesen Button vergebens.

 

Kann mir da mal jemand bisschen auf die Sprünge helfen?

 

Installiert ist die aktuellste Version von PrestaShop, ebenso vom EU Modul.

Theme ist das Standard Theme.

 

LG

Frank

 

Manchmal wundere ich mich etwas, daß einfachste Fragen hier nicht beantwortet werden (bedeutet das so viel wie RTFM?). Die Einstellung hat mit dem Europäische-Rechtssicherheit-Modul nichts zu tun, sie findet sich unter Lokalisierung -> Steuersätze -> MwSt. im Warenkorb anzeigen.

  • Like 1

Share this post


Link to post
Share on other sites

Manchmal wundere ich mich etwas, daß einfachste Fragen hier nicht beantwortet werden (bedeutet das so viel wie RTFM?). Die Einstellung hat mit dem Europäische-Rechtssicherheit-Modul nichts zu tun, sie findet sich unter Lokalisierung -> Steuersätze -> MwSt. im Warenkorb anzeigen.

 

Oh Gott, das war wirklich erschreckend einfach! Vielen dank an dieser Stelle! Verwirrend das eben genau diese Funktion auch im EU Modul steht.

Edited by modulstyle (see edit history)

Share this post


Link to post
Share on other sites

Oh Gott, das war wirklich erschreckend einfach! Vielen dank an dieser Stelle! Verwirrend das eben genau diese Funktion auch im EU Modul steht.

 

Da gibt es eine Einstellung "Anzeige MwSt.", gemeint ist hier aber der Zusatz "inkl. MwSt." etc. auf den Produktseiten.

Share this post


Link to post
Share on other sites
  • 5 months later...

Ich hab da ein kleines Problemchen... MwSt. im Warenkorb habe ich aktiv. Aber lege ich Produkte in den Korb erscheint in der Zeile MwSt 0,00 Euro.
Es steht bei den Produkten inkl. MwSt. Auch bei der Gesamtsumme. Aber keine Aufschlüsselung der Steuer. Das hätte ich nur gerne... 0,00 Euro MwSt. ist falsch...

Share this post


Link to post
Share on other sites

Ich hab da ein kleines Problemchen... MwSt. im Warenkorb habe ich aktiv. Aber lege ich Produkte in den Korb erscheint in der Zeile MwSt 0,00 Euro.

Es steht bei den Produkten inkl. MwSt. Auch bei der Gesamtsumme. Aber keine Aufschlüsselung der Steuer. Das hätte ich nur gerne... 0,00 Euro MwSt. ist falsch...

Wenn das schon immer so ist, könnte es an einer Konfigurationseinstellung liegen im Modul Europäische Rechtssicherheit oder bei den Ländereinstellungen. Wird denn irgendwo ein Mehrwertsteuerbetrag angezeigt (also nicht der Text "inkl. MwSt.") oder nirgends? Zähle mal auf, wo du Einstellungen zur MwSt. wie gemacht hast.

Share this post


Link to post
Share on other sites

Wenn das schon immer so ist, könnte es an einer Konfigurationseinstellung liegen im Modul Europäische Rechtssicherheit oder bei den Ländereinstellungen. Wird denn irgendwo ein Mehrwertsteuerbetrag angezeigt (also nicht der Text "inkl. MwSt.") oder nirgends? Zähle mal auf, wo du Einstellungen zur MwSt. wie gemacht hast.

 

Nun, ich war zwei Jahre Kleinunternehmen. Jetzt muss ich umstellen. Darum kann ich nicht sagen, ob das immer so war...

 

Einstellungen im BO vorgenommen:

 

- Länder - Deutschland - MwSt. anzeigen

- Kundengruppen - inkl. MwSt.

- Lokalisierung - Steuersätze "MwSt aktivieren" und "im Warenkorb anzeigen"

- Lokalisierung - Steuerregeln "DE Standard 19%"

- Module - Europäische Rechtssicherheit - Tax 'inc./excl.' label auf JA

- Katalog - Artikel - Jeden Artikel muss ich noch einzeln der Steuer  zuordnen. Das dauert leider nur etwas, weil es über 300 Artikel sind und Prestashop derzeit Änderungen erst nach dem 4. oder 5. mal speichern annimmt. 

Habe aber eben festgestellt, dass Nettopreis auch bei Bruttopreis angezeigt wird. Bin jetzt grad etwas verwirrt...

Achso, und auf der Rechnung steht bei den Preisen (o. MwSt). 

Ein MwSt Betrag wird nirgends aufgeführt...

Gott, ist das alles so kompliziert...

Edited by Dampfer-Hardware (see edit history)

Share this post


Link to post
Share on other sites

Nun, ich war zwei Jahre Kleinunternehmen. Jetzt muss ich umstellen. Darum kann ich nicht sagen, ob das immer so war...

 

Einstellungen im BO vorgenommen:

 

- Länder - Deutschland - MwSt. anzeigen

- Kundengruppen - inkl. MwSt.

- Lokalisierung - Steuersätze "MwSt aktivieren" und "im Warenkorb anzeigen"

- Lokalisierung - Steuerregeln "DE Standard 19%"

- Module - Europäische Rechtssicherheit - Tax 'inc./excl.' label auf JA

- Katalog - Artikel - Jeden Artikel muss ich noch einzeln der Steuer  zuordnen. Das dauert leider nur etwas, weil es über 300 Artikel sind und Prestashop derzeit Änderungen erst nach dem 4. oder 5. mal speichern annimmt. 

Habe aber eben festgestellt, dass Nettopreis auch bei Bruttopreis angezeigt wird. Bin jetzt grad etwas verwirrt...

Achso, und auf der Rechnung steht bei den Preisen (o. MwSt). 

Ein MwSt Betrag wird nirgends aufgeführt...

Gott, ist das alles so kompliziert...

Schau mal hier:

 

https://www.prestashop.com/forums/topic/185401-free-script-prestools-suite-mass-edit-order-edit-and-much-more/

 

Ist kostenlos und die globale Änderung dauert maximal ein paar Minuten!

 

Wenn Speichern mal funktioniert und mal nicht, könnte das ein Zeitproblem sein, d. h. die max_execution_time ist zu gering (in der php.ini konfigurieren oder - bei zu starker Beschränkung durch den Hoster) besseres Hostingpaket wählen.

 

Hast du nach den Änderungen mal alle Caches (Prestashop und Browser) gelöscht?

Share this post


Link to post
Share on other sites

Schau mal hier:

 

https://www.prestashop.com/forums/topic/185401-free-script-prestools-suite-mass-edit-order-edit-and-much-more/

 

Ist kostenlos und die globale Änderung dauert maximal ein paar Minuten!

 

Wenn Speichern mal funktioniert und mal nicht, könnte das ein Zeitproblem sein, d. h. die max_execution_time ist zu gering (in der php.ini konfigurieren oder - bei zu starker Beschränkung durch den Hoster) besseres Hostingpaket wählen.

 

Hast du nach den Änderungen mal alle Caches (Prestashop und Browser) gelöscht?

 

Super, Danke :)

Hab ich direkt hochgeladen und suche das Modul nun vergebens... Sorry :( 

 

Danke für die Geduld...

 

Ja, Cache Shop und Browser lösche ich täglich.

 

 

Share this post


Link to post
Share on other sites

Hab ich direkt hochgeladen und suche das Modul nun vergebens

Das ist kein normales Modul, lies einfach die Anleitung!

 

Die Einstellungen scheinen sonst - vorausgesetzt du hast auch immer den grünen Aktiv-Haken gesetzt, schau noch mal nach - OK zu sein. Wurde damals vielleicht etwas in den Dateien verändert oder nutzt du ein Modul für die Kleinunternehmerregelung? Evtl. auch mal alle externen Module und Overrides deaktivieren (Erweiterte Einst. -> Leistung -> Debug).

Share this post


Link to post
Share on other sites

Das ist kein normales Modul, lies einfach die Anleitung!

 

Die Einstellungen scheinen sonst - vorausgesetzt du hast auch immer den grünen Aktiv-Haken gesetzt, schau noch mal nach - OK zu sein. Wurde damals vielleicht etwas in den Dateien verändert oder nutzt du ein Modul für die Kleinunternehmerregelung? Evtl. auch mal alle externen Module und Overrides deaktivieren (Erweiterte Einst. -> Leistung -> Debug).

 

Nein, kein Modul für Kleinunternehmer. Ich hatte lediglich, was Steuern betraf, alles deaktiviert und den Rechtstext bezüglich der Anwendung der Kleinunternehmerregelung manuell auf die Rechnungen gesetzt und im Bestellvorgang anzeigen lassen.

 

Aktuell hab ich alles für die Steuer aktiviert, denk ich mal.

Mich fuchst es nur, dass im Warenkorb, auf der Rechnung und Bestellbestätigung der Kunde bei MwSt. 0,00 Euro angezeigt bekommt.

Liegt es daran, dass bei jedem Artikel, trotz Einstellung der Steuer, bei Netto und Brutto der gleiche Preist steht? Gebe ich netto ein, erscheint der Betrag bei brutto ebenso und umgekehrt  :unsure:

Edited by Dampfer-Hardware (see edit history)

Share this post


Link to post
Share on other sites

Okay... Habs gefunden..
Ich muss die Preise alle erst entfernen. Speichern. Dann Steuer einstellen. Speichern. Dann den Preis eingeben und zack wird richtig gerechnet.

Da werd ich ein Weilchen beschäftigt sein. 

 

Edit: Jetzt geht es plötzlich ohne Preise entfernen. Wenigstens was...
Steuersumme wird nun auch angezeigt im Warenkorb. 

Jetzt suche ich mir erstmal einen Spzezialisten, der mal nachschaut wegen dem Problem, dass Änderungen erst nach dem x-ten mal angenommen werden.

Danke nochmal und einen schönes WE.

Edited by Dampfer-Hardware (see edit history)

Share this post


Link to post
Share on other sites

Auch - sofern notwendig - Reduzieren aller Nettopreise um einen Prozentsatz sollte mit der Prestools-Suite funktionieren.

 

Was die Speicher-Problematik betrifft, hast du mal verschiedene Browser probiert? Was für ein Hosting verwendest du?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More