Jump to content

[Résolu] Plus de transporteurs payants proposés - PS 1.6.1


Recommended Posts

Bonjour, 

 

Encore un énième post sur la gestion des transporteurs me direz-vous, oui, mais... pas que ! 

 

J'ai un PS 1.5.4.1 qui tourne en prod, je souhaite le mettre à jour d'ici peu, j'ai donc créé une pâle copie de ce site de prod en local (wamp) pour upgrade vers 1.6.1.0.

J'ai donc tout bien backupé et importé, j'ai upgradé mon thème par la même occas. Tout roule, sauf.... la gestion des transporteurs alors qu'elle est configurée exactement de la même façon que sur mon site de prod, la garce !.

  • En prod (1.5.4.1) --> ca fonctionne nickel,
  • En local (pâle copie passée en 1.6.1)  : NON

 

A noter : j'ai pas fait la "bourrine", j'ai d'abord installé un 1.5.4.1 en local pour y importé ma BDD de prod et ai ensuite upgradé PS vers un PS version mineure puis autre upgrade vers dernière version stable Ps 1.6.1, histoire que l'upgrade des tables se fasse tout en douceur.....

 

Malgré tout, le système n'a de cesse de me proposer le transporteur par défaut (le gratuit) peu importe les zones et les coûts affectés à chaque transporteur.

En fait, dans [Localisation / Pays] : mon pays [France] a comme zone "Tournées locales".
En prod il sait bien basculer vers une autre zone et donc un autre transporteur si le code postal ne correspond pas à ceux tolérés par cette zone.
Tandis qu'en 1.6 là... il reste bloqué sur cette zone définie ici, dans [Localisation / Pays/ France] . Si je la change, il prend en compte le changement mais ne me propose toujours que les tarifs de cette zone et ne fait pas la bascule en fonction des codes postaux.

 

Côté configuration BO, je me base sur :

  1. un pays : la France
  2. plusieurs zones 
  • DOM TOM
  • Corse
  • Tournées locales
  • Hors tournées (dont le transporteur diffère en fonction du code postal de l'adresse de livraison --> module utilisé : zipcodezone)
  • Europe 4 pays

3. 3 transporteurs :

  • France gratuit (limité à zone "Tournées locales")
  • France payant (limité à zone "Hors Tournées")
  • Europe payant (limité à zone "Europe 4 pays")

 

C'est non sans m'être arraché les cheveux avant que je me tourne vers vous car j'ai la sensation que c'est plutôt un genre de classe qui surcharge ma configuration quoique je fasse côté BO. 

Mais comme c'est quelques chose que je maîtrise pas.... j'ai besoin de vous ! 

Des idées pour moi svp ? 

 

A titre d'infos : 

  • Je n'utilise pas la gestion avancée des stocks
  • Mes produits n'ont pas de transporteurs associés dans leur fiches produits
  • j'ai lu et relu la documentation d'aide PS
  • J'ai déjà désactivé / Réactivé et même supprimé et recréé mes codes postaux / zones / transporteurs... sans sucés. 
  • j'ai bien vu le changement entre 1.5.4.1 et 1.6 pour les tranches de prix : j'ai vérifié, mes prix selon tranches de prix sont bien configurés dans chaque transporteur (et non plus en rubrique "Tranche de prix" comme c'est le cas en 1.5)

Je sais que ce sujet a été traité des centaines de fois, mais je n'ai vraiment pas trouvé réponse à mon problème dans tout ce que j'ai pu lire. 

Ma conf est bonne (à priori), c'est simplement cette zone sélectionné au niveau du pays qui me ruine tout ! 

Si je la repasse à "Europe" ou que sais-je... il ne me trouve plus de transporteurs du tout.

 

Peut-être alors est-ce le module zipcodezone qui n'est pas compatible avec PS 1.6.1, mais comment en être sûre avant d'investir par exemple dans PostalDeliv de Ebewé qui fait exactement la même chose... :/ 

...........LOST..............

 

Merci par avance

Edited by Lilhouh (see edit history)

Share this post


Link to post
Share on other sites

La demande est en cours... j'attends sa réponse.
Il y a plusieurs mois de cela, il m'avait dit qu'une migration vers 1.6 ne devrait poser aucun problème.

 

Je ne suis donc pas certaine que cela vienne de ce module, et espère par ce post, qu'entre temps mon souci pourrait susciter auprès de vous, communauté PS, d'autres interrogations et/ou points de vigilance auxquels je n'aurais pas pensé.

 

merci

Share this post


Link to post
Share on other sites

Alors l'option Désactiver toutes les surcharges était à OUI.

Je l'ai passé à NON (pour la réactiver)

 

J'ai réinstallé mon module, pas d'améliorations (il me propose même un transport gratuit pour des zones non couvertes / départements non autorisés)

 

EDIT : hum.. oui, y'a pas.... pas de changements. Il n'a vraiment que faire des zones par codes postaux que je lui indique et ne se fie qu'à la zone associée à mon pays France.

Edited by Lilhouh (see edit history)

Share this post


Link to post
Share on other sites

Bon bah comme expliqué à Emmanuel M., le développeur, son module (zipcodezone) est effectivement compatible 1.6.1.

Mais c'est la gestion, la configuration de tout le système de transporteurs qui bug à souhait. 

Un upgrade de mon site n'a pas suffit à garder les paramètres tels qu'ils fonctionnaient en 1.5.4.1.

Plus rien ne fonctionnait en 1.6.1.

 

J'ai finalement réussi à faire fonctionner l'ensemble sur ma version de test en fin de semaine dernière (en local sous wamp). Comment ? J'en ai strictement aucune idée... 
A faire, défaire, activer, désactiver, installer, désinstaller, réinstaller, refaire encore la même chose à chaque fois pourtant.... à un moment donné ...ça fonctionne.
Je ne comprends absolument par pourquoi, et cela m'agace fortement d'ailleurs. Mais .. bon point : ça marche.
 
J'étais convaincue que je me retrouverai confrontée au même souci lorsque je basculerai mon site de prod... et j'avais raison.
J'ai upgradé mon site de prod hier... je suis restée bloquée plus de 2 heures sur la gestion des transporteurs... et je ne sais toujours pas pourquoi.. au bout d'un moment ça marche ! 
Un truc de dingue.
 
Une chose est sûre votre module est compatible 1.6.1, je confirme... mais non sans mal :) Je ne sais pas s'il est un ordre spécifique pour orchestrer tout le système. Mais c'est la sensation que cela me donnait. 
Un import de la bdd pur et simple ne fonctionne pas (malgré vidage de cache, désactivation des surcharges, ...)
Un upgrade via le module Prestashop... pareil... y'a un truc qui lui convient pas, qu'il ne reconnait pas. 
 
J'ai du écraser et refaire toutes mes zones + mes transporteurs + changer la zone par défaut dans Localisation / Pays (plusieurs fois)
Si sur ma 1.5.4.1, je ne donnais pas spécialement de taille de colis ou de poids max (parce que le prix livraison dépend pour moi du prix de la commande et pas du poids ou de la dim), j'ai l'impression que cela est indispensable sur la 1.6.1... 
Simple illusion ? peut-être.
 
Enfin bref, c'est pas la première fois que je me bats avec cette gestion de transporteurs... et ce ne sera surement pas la dernière j'imagine... incompréhensible pour moi, trop fragile aussi. 
 
Merci pour votre intérêt. 

Share this post


Link to post
Share on other sites

Bonjour @ Tous,

 

Version 1.6.0.14

 

depuis peu, même problème de transporteur.

 

Le problème s'est posé depuis les 2 derniers articles créés,

J'ai suivi les infos sur ce sujet, et constaté qu'il y avait un lien avec "l'entrepôt" qui doit absoljument être coché, si non "pas de transporteur disponible".

J'ai donc coché l'entrepôt.

Mais seulement le transporteur gratuit disponible et aucun transporteur payant lié au payset au poids.

Le problème ne se pose qu'avec les derniers articles créés et tout autre nouveau, mais pas avec les anciens articles, SAUF s'ils sont associés dans la panier avec un nouvel article !!

J'ai bien associé le poids, mais pas les dimensions des nouveaux articles, dimensions que je n'ai jamais utilisées.

 

J'avais déjà eu un problème semblable par rapport à un client des Pays-Bas, car l'ortographe Pays Bas avait été encodé sans le -, et je ne me souvizens plus comment j'avais résolu le problème, mais ici, c'est différent, c'est sur des articles que se pose le problème.

 

Je  bute sur ce noeud depuis 2 jours et pas trouvé de solution, donc je compte sur vous pour m'illuminer ;o)

 

Cordialement,

 

Rudy

Edited by belalternative (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More