Jump to content
Merakapda

Friendly url not showing images Prestashop 1.6

Recommended Posts

I was using prestashop 1.5 and everything was ok.

Now I have upgraded to prestashop 1.6 a few months ago.

And I came to know that my SEO has gone down because the friendly urls are not working.

 

When I enable Friendly URL No images are shown in my site. www.merakapda.com 

 

Please reply and thanks in advanced.

 

Share this post


Link to post
Share on other sites

Hi!

 

Have you tried to force compilation and emptied the cache?

 

Regards

 

MacRoy

Share this post


Link to post
Share on other sites

I have tried that too and its not working.

 

Tell me you ip so that I can add you as my website is in maintenance mode.

Share this post


Link to post
Share on other sites

I was facing the same problem a while ago, seems like there was some problem with the .htaccess configuration file. So what I did was:

 

1. Deleted the .htaccess file.

2. Disabled & Enabled Friendly URL.

 

*Problem Solved* 

 

Let me know if this works for you.

Edited by ac3gam3r (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

I was facing the same problem a while ago, seems like there was some problem with the .htaccess configuration file. So what I did was:

 

1. Deleted the .htaccess file.

2. Disabled & Enabled Friendly URL.

 

*Problem Solved* 

 

Let me know if this works for you.

 

This didn't helped I backed up the file then deleted it. and the new .htaccess generated and All I see that my website is showing Blank.

Share this post


Link to post
Share on other sites

Hi,

 

I've have the same issue on a fresh Prestashop install.

I need a working solution urgently from developers.

I see on forum that it's a returning issue.

Any chance to fix it ASAP??

Share this post


Link to post
Share on other sites

I have the same issue, I run prestashop on nginx, how can I fix it?

Share this post


Link to post
Share on other sites

same issue here my site is teknostream.com

 

please help

Heyy your friendly url is working.

how you enabled them?

Share this post


Link to post
Share on other sites

Heyy your friendly url is working.

how you enabled them?

 

i think i have another prestashop web which friendly url is working from the beginning  (i just try switch on/off it)

then i copy paste and edit .htaccess file from my other web which it friendly url is working

 

here is the .htaccess file  http://pastebin.com/rQGmVWes

backup original file before copy paste

 

btw im using 1.6.0.14 version

 

sory for my english grammar

Edited by danidant (see edit history)

Share this post


Link to post
Share on other sites

i think i have another prestashop web which friendly url is working from the beginning  (i just try switch on/off it)

then i copy paste and edit .htaccess file from my other web which it friendly url is working

 

here is the .htaccess file  http://pastebin.com/rQGmVWes

backup original file before copy paste

 

btw im using 1.6.0.14 version

 

sory for my english grammar

This didn't help me. :(

Share this post


Link to post
Share on other sites

I have the same issue, I run prestashop on nginx, how can I fix it?

 

Try disable the nginx first, and check if Prestashop's friendly url working without nginx or not.

 

I had issue with nginx config which caused not proper working of friendly url.

Now with a righ nginx config the issue is gone.

Share this post


Link to post
Share on other sites

I was facing the same problem a while ago, seems like there was some problem with the .htaccess configuration file. So what I did was:

 

1. Deleted the .htaccess file.

2. Disabled & Enabled Friendly URL.

 

*Problem Solved* 

 

Let me know if this works for you.

Excellent! It's work also for me after days of research. Thank you very much :) :) :)

  • Like 1

Share this post


Link to post
Share on other sites

I freshly installed Prestashop 1.6.1.0 I've uploaded all product images in the "img" file without knowing that prestashop works different in handling images. I'm using product csv feeds to upload products in which the "Image URLs (x,y,z...)" has the following image url: http://www.mydomainname.com/img/xxxxxxx.jpg By researching the web I found out that product.tpl file need some modification in order to avoid the Friendly URL mode. I still wantFriendly URL mode to be enabled and not deleting the .htaccess file as suggested. I basically want all products to been linked with the images in the "img" file. Any suggestion how to modify the product.tpl file?

Share this post


Link to post
Share on other sites

I spent almost 5 hours. When I enabled friendly urls, my images didn't appear. I migrated from my live domain to localhost actually. The localhost version didn't show images.

 

- I did this .htaccess file deletion

- I reset all file and folder permissions

- I enabled mod_rewrite under apache

- Reindexed

- Created thumbnails

- Removed cache

- I set AllowOverride All under /etc/apache/sites-available/default.conf

Finally now I discovered I had to set AllowOverride All also under apache.conf file or depending on your system, it can be httpd.conf file

 

Since my presta shop was under folder called "myshopsite", I created a new entry in this file /etc/apache2/apache2.conf

as 

<Directory /var/www/html/myshopsite>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted
</Directory>

 

and finally

sudo apache2ctl restart

 

Voila!!!!

Edited by luya (see edit history)
  • Thanks 1

Share this post


Link to post
Share on other sites

I installed Presta Shop yesterday for the very first time and I am having this image issue.

 

Fine if I turn off friendly URLs but no image if Friendly URLs are on.  I have messed around with some of the settings mentioned here but noting seems to 'fix' the issue with friendly URLs on.

 

Is this a bug or is there a configuration item I may have missed

Share this post


Link to post
Share on other sites

I installed Presta Shop yesterday for the very first time and I am having this image issue.

 

Fine if I turn off friendly URLs but no image if Friendly URLs are on.  I have messed around with some of the settings mentioned here but noting seems to 'fix' the issue with friendly URLs on.

 

Is this a bug or is there a configuration item I may have missed

Make sure that mod_rewrite on your linux server is installed (ask your provider). Ir you are using Windows servers, so there is no mod_rewrite, in this case you should either contact your provider and rewrite .htaccess to web.config file, which is the one IIS servers can read and understand.

Share this post


Link to post
Share on other sites

OKay - not a PHP expert or anything and not really sure if this is unique to Bluehost but think I fixed this.  

 

I deleted the htaccess file and then forced the site to regenerate it by turning pretty urls off and then on 

 

Maybe this will help someone on Bluehost who is doing a new install/

  • Like 1

Share this post


Link to post
Share on other sites

OKay - not a PHP expert or anything and not really sure if this is unique to Bluehost but think I fixed this.  

 

I deleted the htaccess file and then forced the site to regenerate it by turning pretty urls off and then on 

 

Maybe this will help someone on Bluehost who is doing a new install/

Well this solution was already posted to this topic before mine, so I supposed you still made use of them and your problem still persist....

Please if you add your problem to an existent topic, please read carefully all threads added to this topic.

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

OKay - not a PHP expert or anything and not really sure if this is unique to Bluehost but think I fixed this.  

 

I deleted the htaccess file and then forced the site to regenerate it by turning pretty urls off and then on 

 

Maybe this will help someone on Bluehost who is doing a new install/

 

Thank You, this fixed it for me as well.

 

v1.6.1.3

Share this post


Link to post
Share on other sites

What worked for me was changing permissions to 755 on the folders.  One important thing is to do this in the hosting control panel and not in filezilla!!

Share this post


Link to post
Share on other sites

hope this thread is not close, im facing the same issue and deleting the htaccess and turning off / on the friendly url do not work for me. htacess also do not get renegerate, anyone got a solution for this ?

Share this post


Link to post
Share on other sites

hope this thread is not close, im facing the same issue and deleting the htaccess and turning off / on the friendly url do not work for me. htacess also do not get renegerate, anyone got a solution for this ?

 

it's possible that your apache server does not have mod_rewrite enabled.  Learn more here

 

There are  several different methods to see if mod_rewrite is enabled you can find via search.  You can also contact your hosting company.  Let us know what you find out.

 

happy prestashopping

Share this post


Link to post
Share on other sites
Posted (edited)

PS 

For me worked remowing:

location ~* \.(js|jpg|jpeg|gif|png|css|tgz|gz|rar|bz2|doc|pdf|ppt|tar|wav|bmp|rtf|swf|ico|flv|txt|woff|woff2|svg)$ {
    etag on;
    if_modified_since exact;
    add_header Pragma "public";
    add_header Cache-Control "max-age=31536000, public";
}

 

in "Apache & nginx Settings" in option "Additional nginx directives"

Edited by goldies (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More