Jump to content
jopabe

Fatura não mostra produtos nem quantidades

Recommended Posts

As minhas faturas e documentos de entrega deixaram de apresentar discriminação.

 

O carrinho de compras que deu origem à encomenda está correcto, com todos os produtos, mas na encomenda mostra 0 (zero) produtos, apesar de estar validada e ter o total certo.

 

Quem me ajuda? Obrigado

Share this post


Link to post
Share on other sites

Verifique se o processo checkout abaca em uma página branca. Faca vc. mesmo ordens teste. Ative o modo debug para isto: http://www.prestashop.com/forums/topic/282165-ativar-modo-debug/

 

A fatura é gerada tomando com base a encomenda. Se o processo check-out está com problema entao a encomenda fica vazia, mostrando somente valores, mas nada de produtos.

Share this post


Link to post
Share on other sites

Activei o modo debug, conforme instruido, mas agora, ao tentar fazer o login, obtenho o seguinte screen:

 

 

[PrestaShopDatabaseException]

Unknown column 'w.default' in 'field list'
 

            SELECT w.`id_wishlist`, w.`name`, w.`token`, w.`date_add`, w.`date_upd`, w.`counter`, w.`default`
            FROM `ps_wishlist` w
            WHERE `id_customer` = 9
            AND id_shop = 1
            ORDER BY w.`name` ASC

at line 635 in file classes/db/Db.php

 

629.             WebserviceRequest::getInstance()->setError(500, '
 '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);
630.         }
631.         else if (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS'))
632.         {
633.             if ($sql)
634.                 throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');
635.             throw new PrestaShopDatabaseException($this->getMsgError());
636.         }
637.     }
638.
639.     /**

Share this post


Link to post
Share on other sites

O seu módulo wishlist está atual ? Qual a versao em uso ? Versao atual é: 1.1.5 e teve um upgrade alguns dias atrás se nao me engano.

 

Atualize o módulo e desinstale/instale novamente. O erro diz que falta ou nao está sendo reconhecida a coluna "default" na tabela ps_wishlist. Pode até ser que a tabela esteja defeituosa. Vc. desinstalando e instalando o módulo, ela vai se recuperar novamente.

Edited by selectshop.at (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

RESOLVIDO!

 

Fiz como disse, apesar de já ter a ultima versão do módulo, mas desInstalei e instalei novamente, e ficou a funciunar.

 

Agora, devo desactivar novamente o modo debug?

 

MUITO OBRIGADO pela ajuda preciosa!

Share this post


Link to post
Share on other sites

Nao, ainda tem erros quando tenta processar uma encomenda ? Faca uma encomenda teste. Verifique primeiro na encomenda que nao contém produtos, qual a modo de pagamento e tente fazer uma encomenda teste com o mesmo modo de pagamento. Veja se gera erros ou uma página branca ao gerar o pedido.

Share this post


Link to post
Share on other sites

Já fiz encomendas de teste, com todas as modalidades de pagamento, e todas correram bem.

Inclusivamente, voltei à encomenda que gerou este meu pedido de ajuda (24 produtos) e executei um "re-encomendar" - tudo correu ás mil maravilhas, com todos os items perfeitamente visíveis em todos os documentos.

Share this post


Link to post
Share on other sites

Isto depois que consertou o banco de dados, ou antes ? Pois nao acredito que o whishlist tenha influencia. Este seu pedido sem produtos, pode ser que foi manipulado posteriormente, pois se encomendas teste agora funcionam ou entao o problema se resolveu, ou entao este pedido ficou entruncado.

Share this post


Link to post
Share on other sites

Apenas fiz o que me sugeriu... desinstalei e reinstalei o modulo, e ficou tudo a funcionar bem!

 

Acha que foi coincidencia? Será algo que tenha a ver com o host?

 

De qualquer forma, vou manter a vigilância 

 

Mais uma ves, obrigado, e pode crer que contarei consigo para futuros eventos (espero que não seja necessário, mas...)

Share this post


Link to post
Share on other sites

Pode ser, mas vc. desinstalando um módulo o banco de dados recebe um impulso. Se ficou alguma coisa entruncada entao pode ser que consertou. A tabela wishlist nao necessariamente tem algo a ver  com as encomendas, mas pode ser que outros indexes também foram consertados com o processo. Técnica é técnica e ás vezes existem problemas que vem do nada e também se consertam do nada, somente dando um impulso em outro lugar...

  • Like 1

Share this post


Link to post
Share on other sites

Bom dia selectshop.at,

 

Eu esteve olhando o foro em ingles e espanhol, e tem muita gente com esse mesmo problema. 

 

Voce fala ingles? ou espanhol? Tem jeito de participar nesses posts? 

 

 
 

Cualquer coisa me avisa.

 

Muito obrigada

 

Maggie

Share this post


Link to post
Share on other sites

Olá Meggie,

 

Sim, Espanhol, Inglês, um pouco de Francês. Até Alemao eu falo fluentemente e foi na secao do fórum alemao que dei os meus primeiros passos (13000 tópicos e quase 1000 likes). Após uma intriga muito feia para cima de minha pessoa de um usuários do Fórum Alemao o Xavier simplesmente para ter paz acabou me bloqueando para escrever lá (o fórum que mais me serve porcausa da localizacao = Áustria). Após os Community Managers me terem bloqueado no fórum nativo eu me afastei do resto do fórum concentrando os meus servicos voluntários somente para os meus compatriotas Brasileiros.

 

Eu sei que tenho um excelente know-how do Prestashop e posso ser de multi-uso devido aos idiomas também em outros fóruns, mas depois do acontecido - que ainda me faz ficar muito furiosa com ambos Community Managers - eu nao vou retomar os servicos para ajudar em outros fóruns. Já pedi um monte de vezes para abrirem  novamente a minha conta para poder escrever no Fórum Alemao (aonde estao os meus clientes), mas nem resposta recebo. Sinto muito, mas resolver problemas, simplesmente ignorando, nao é uma forma de discussao construtiva. Também eu tenho os meus princípios e paciência esgotada algum dia.

 

Quando eu tinha pedido para deletar a minha conta de moderadora "cd2500" eu tinha dito ao Xavier que ele está perdendo um dos seus melhores cavalos no estábulo.... Mas a decisao foi de ambos Community Managers de me deixar ir, em vez de intervenir e afastar o causador/intrigante. Neste ponto eu é que nao vou dar para trás, nao depois de tudo o que aconteceu. Sinto muito.

 

Sei que também o Vitor (Nadie) se afastou do fórum Espanhol, mas na verdade o problema nao é meu se ambos Community Managers nao sabem/conseguem segurar os seus melhores cavalos. Que aliás é um problema do Prestashop em geral vindo já lá de cima... Muitas pessoas muito boas com excelente know-how abandonaram Prestashop e nada se fez para mantê-los. Com esta política eu nao quero.

E sinceramente, que se dao por feliz que pelo menos aqui no fórum Brasileiro continuo presente. ;)  Poderia pegar todo esse meu know-how e virar em servicos exclusivamente pagos...

 

Abcs,

 

Conny

Edited by selectshop.at (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites
Para todas as pessoas que ainda tem problemas com a fatura que nao mostra os produtos ou as quantidades:

 

Nossos programadores acharam a mesma solucao para varios casos: a desinstalacao do modulo Ebay. Se voces ainda tiver perguntas sobre Ebay ou Paypal, podem contactar o pessoal de ajuda deles no email: support@202-ecommerce.com

 

Muito obrigada pela ajuda de todos os colaboradores para resolver isto!

 

Maggie

Share this post


Link to post
Share on other sites

Pois é eu nao acho que o problema venha do módulo ebay  ou paypal. Tenho ambos os módulos rodando e as faturas/pedidos estao sem problemas. No caso do jojabe foi um problema do módulo wishlist, que parou de funcionar corretamente e aparentemente bloqueou o banco de dados. ;)

 

E sinceramente qual vendedor vai parar de usar o Paypal e ebay de repente ? Deveria se debugar ambos os módulos se nao funcionam. Mas para mim funcionam e eu uso as últimas versoes de ambos e PS 1.6.0.9.

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More