Jump to content - Can't import csv products, page goes blank after seconds

Recommended Posts



so after some problems with the csv import of, which was ending with internal server error after 120 seconds, where I tryed by changing php.ini:

max_execution_time = 300

max_memory_limit = 512M

and various attemps with random values,

every time the http 500 error, with

"Script timed out before returning headers: index.php, referer: ...."

inside the logs


Then Igave the login info, the file and instructions to my hosting support, and everything went fine from their side.


Yesterday I saw the new release, so went with a fresh install. tryed to import the csv and page blank after few seconds with external links of images to import, or 60 seconds without them. all this for less than 150 products


I don't know what else to try, I tryed from another pc and same problem, also the debugging mode from define.inc.php doesn't work :(

I even thought might be a modem/provider problem...




PS: this is a modified thead for a problem with installing addons which misteriously fixed itself

Edited by nicusor (see edit history)
Link to comment
Share on other sites

last night, since I didn't knew where to throw my head, I tried to clone the shop on xampp and the problem was occuring after 5 minutes of waiting and only 45-60 products imported. so I set the max_execution_time higher than 300 but the problem persisted.


also since it was on the localhost and avira antivir was deactivated manually, this would remove the theory of provider/router/antivirus. I wouldn't blame the windows xp and 8 integrated firewall...



anyway, this morning I separated the csv with 10 products per upload....It workied, only 7-15 seconds to finish. so statistically with 150 products it would take about 3 minutes...


now when I'm trying to save some changes I have blank pages, sometimes it discards changes and random link_rewrite errors, something like it's required at least for my language :ph34r:

Link to comment
Share on other sites

already done, but where to look for? neither firebug error console or apache (error) log are useful.


the only thing I see are some

POST /admin/index.php?controller=AdminProducts&token=1234&id_product=31

POST /admin/ajax.php?rand=1234

in the apache log




<!DOCTYPE html>
<html class="js" lang="it">
<body class="ps_back-office page-sidebar adminproducts">

on the firebug html console





I discovered that by going back after the first blank page (on save or save&stay), it shows those errors


3 errori

  1. Il campo link_rewrite è richiesto almeno in Italiano (Italian)
  2. Il prodotto deve essere in almeno una categoria.
  3. Questo prodotto deve essere in almeno una categoria di default.


something like:
1. This link_rewrite field is required at least in italian

2. Products must be in at least one category.

3. This product must be in the default category.


which seems to be

or a problem of multilanguage installs, but I have downloaded the italian and installed only the italian package

or a copy-paste problem, but the only thing I did was importing the csv :mellow:

Edited by nicusor (see edit history)
  • Like 1
Link to comment
Share on other sites



I (re)installed for something like fourth time the 1608, this time using internet explorer 11 just to exclude any firefox 30 and addons issue.


my php.ini was

[PHP] engine = On
date.timezone = Europe/Rome
magic_quotes_gpc = Off
memory_limit = 512M
max_execution_time = 300 (now raised to 600 just for fun)
max_input_vars = 10000
upload_max_filesize = 32M

max_input_time is already by default -1, so no need to modify)

made my import, same blank page after about 120 seconds, no more blank page when saving modifications of a product, but at least now there is an

[Mon Jun 30 15:01:38 2014] [error] [client MyIp] Script timed out before returning headers: index.php, referer: https://www.domain.it/adminfolder/index.php?controller=AdminImport&token=1234567890sdfga281

in the apache error log

Link to comment
Share on other sites

  • 2 weeks later...

Hi Friends




Facing problem with product csv import after 8 - 10 seconds of upload with 10 products each time shows http 500 error . Getting the following errors when setting _PS_dev_mode = true in define.inc.php.



1) Strict Standards: Declaration of Dispatcher::loadRoutes() should be compatible with that of DispatcherCore::loadRoutes() in /home2/myserver/public_html/override/classes/Dispatcher.php on line 16

1) Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 71 bytes) in /home2/myserver/public_html/tools/htmlpurifier/HTMLPurifier.standalone.php on line 15136



Even though after increasing the limits in php.ini to following values


max_execution_time = 1000

max_memory_limit = 512M

max_input_vars = 8000

upload_max_filesize = 15M

max_input_time= -1,

suhosin.post.max_vars = 8000;
suhosin.request.max_vars = 8000;
post_max_size = 15M


Checked through phpinfo log and all the values are updated accordingly on the server. regenerated a new .htaccess file but still the problem persist.




Link to comment
Share on other sites

Same here.

On 1606 import work fine, but on 1608 seems it has memory leak. I have huge import csv's with 1000 products each with attributes.

Server have 4gb ram, and all ram is used by import script after some time, and of course apache's died (if php memory limit is disabled).

If i split csv's to a ~100 products - import ends good (but i also see memory leak)

Link to comment
Share on other sites

  • 2 weeks later...

#same here , I get :



Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 72 bytes) in /public/tools/htmlpurifier/HTMLPurifier.standalone.php on line 15136

with OPC

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20756 bytes) in /public/classes/cache/CacheApc.php on line 50

can anyone help here




Edited by LockeAG (see edit history)
Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...
  • 1 month later...

Hi patron


When we download csv file for products and category. Its very difficult to understand for a normal average to understand default example csv excel which comes with semi Colan and comma.


Than need to cut and copy one one attribute in and excel file which needs to be saved as CSV file.


When importing change ; to , and than import.As simple one column CSV upload don't works with ;


Why this is a lengthy process and not easy as people run away when products needs to uploaded.Also after doing all this hard work uploading 200 products take 30 min time even using vps server.


Is this the right way or we are missing things.


I have seen videos of nemo for 1.5 but in that video the download excel

File has every elements in one one column.


Is this a bug in 1.6 as simple example file comes in semi colan.Wht is the purpose of using semi Colan default file for


Pls put a light as it creates a hell for adding different products and categories for individual different stores with multi store active.


You make a good point,   I would personally look for 3rd party solution where you can mange your products on your desktop that then interfaces with the prestashop, store commander for example (there may be other solutions).


or a good prestashop mass updater module...


these may be good solutions given how complex a csv managed shop could be.

Link to comment
Share on other sites

  • 4 weeks later...

can anyone tell me how to work this program Ajax csv product import

I been trying for over 5 days now and what ever i do i cant get it to do anthing  if anyone has a video to show step by step i would be grateful I don't no if I am saving the csv file right I am currently so confused if anyone can help I would be grateful.




Link to comment
Share on other sites

  • Create New...