Jump to content

Attribut de couleur


Recommended Posts

Je rencontre un problème que je n'avais pas remarqué, alors je ne sais pas réellement d'ou cela vient.

 

J'ai je pense un attribut couleur noir qui est visible sur les fiches de mes produits ( presque toutes)

Je n'ai pourtant pas créer d'attribut couleur dans les déclinaisons de mes produits ( je n'en utilise pas)

 

On pourrait  croire que ça ma généré des carrés noir (attribut de couleur) sur toutes mes fiches... :wacko:

 

Une image pour décrire le problème :

 

433743AttributCouleur.png

 

Je montre un endroit ou il y a qu'une fois l'attribut couleur noir pour constater que c'est pas forcement de partout mais tout de même sur la majorité des fiches...

 

Je constate aussi que sur la page d’accueil dans les produits phares le carré noir n’apparaît pas puisque j'ai le même produit que je montre dans l'exemple de l'image ...

 

Quelqu'un rencontre le même problème ? 

Avez vous une idée une piste pour résoudre ce soucis ??

Edited by lokiiy (see edit history)

Share this post


Link to post
Share on other sites

  • 2 weeks later...
COLOR PICK LIST
 
Le soucis d'affichage venant de cette ligne de code ci dessous 
 
<div class="color-list-container"><ul class="color_to_pick_list clearfix"></ul> </div>
 
J'ai donc supprimé dans: product_list.css ligne 16 (le code css ci-dessous) mais je ne pense pas que
cela soit la solution…. 
ul.product_list .color-list-container {
margin-bottom: 12px; }
ul.product_list .color-list-container ul li {
display: inline-block;
border: 1px solid #d6d4d4; }
ul.product_list .color-list-container ul li a {
display: block;
width: 23px;
height: 23px;
margin: 1px; }

Il existe cependant deux autres fichiers dans lesquels .color-list-container apparait

Fichier : global.js et product_list.scss….
 
Je ne voie pas d'erreur et je ne sais pas comment et pourquoi ca ma généré les petits carrés noir
alors que je n'ai choisi aucune option de couleur dans les attributs et groupes...
 
Enfin ....comme cela pourrait me servir de choisir quand même les attributs couleurs .... je laisse le post non résolu si des fois quelqu'un a une idée ou la solution ...  B)

Share this post


Link to post
Share on other sites

  • 1 month later...

Bonjour,

 

J'ai un souci similaire en 1.6.0.6 sur le thème par défaut.

Je travail en local (mamp) pour une mise à jour d'une ancienne version (1.4.8)

 

Sur les pages catégories, un petit carré noir apparaît sur les produits ne possédant pas de déclinaisons de couleurs...

Ce carré est également présent devant les autres carrés de déclinaisons de couleurs, même si le noir n'existe pas.

En revanche, quand j'ai une déclinaison noir sur un produit, tout est normal...

 

Je ne comprends pas la logique d'apparition de ce carré... Et je m'étonne que ce problème ne soit pas plus souvent mentionné sur le forum...

 

bug.tiff

 

 

Edited by aimeelafee (see edit history)

Share this post


Link to post
Share on other sites

Haaa quelqu'un qui a quand même rencontré le même problème que moi ....

 

Reste a trouver et comprendre pourquoi ... Et d'ou cela peut venir....

 

Moi j'ai supprimé la CSS mais il serait intéressant de connaitre la réel origine du soucis !! 

Share this post


Link to post
Share on other sites

D'après ce que j'observe en examinant ce fameux carré noir, il apparait lorsque le produit présente 2 attributs complémentaires (exemple taille + couleur). Le lien associé à ce carré renvoit systématiquement vers la déclinaison produit déclarée par défaut.

 

Sa présence n'a donc rien à voir avec la couleur, bien qu'il y soit associé en Front office.

 

ex.

lien en cliquant sur le carré noir : /index.php?id_product=384&controller=product#/pointure-24/couleur_principale-jaune_or

lien en cliquant sur le carré jaune parmi les couleurs proposées : idem

lien en cliquant sur "détail" : /store/index.php?id_product=384&controller=product <----- renvoyant sur la déclinaison par défaut.

 

Cela fait donc trois liens cliquables pour arriver sur la même page pour le client. A mon sens, ça fait au moins un de trop !!!

 

Et je n'ai malheureusement pas les compétences pour aller plus loin et tenter des expériences dans le coeur du système. #snif

 

Quelqu'un a-t-il une idée ?

 

PS. Pour nous donner plus de chance d'avoir une réponse, il faudrait peut être renommer le titre du Topic du coup ???

Share this post


Link to post
Share on other sites

Je me demande s'il ne faut pas agir plutôt sur le product-list-colors.tpl quelque part ici...

<ul class="color_to_pick_list clearfix">
{foreach from=$colors_list item='color'}
<li>
<a
href="{$link->getProductLink($color.id_product, null, null, null, null, null, $color.id_product_attribute)|escape:'html':'UTF-8'}"
id="color_{$color.id_product_attribute|intval}"
class="color_pick"
style="background: {$color.color};">
</a>
</li>
{/foreach}
</ul>

Share this post


Link to post
Share on other sites

Ont peut refaire un topic avec un autre titre pour voir si d'autres personnes ont le même problème avec ce fameux :

 

PETIT CARRE NOIR  ;)

 

Faudra penser à mettre le lien du nouveau topic ici !! 

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More