Jump to content

Recommended Posts

Hi all, I'm struggling with the CMS block/pages and wondered if anyone had found a work around to the following problem.

 

I want to have an item in my top horizontal menu that is a drop down of various pages, such as about us, terms and conditions, etc. These all appear in the CMS block and can be added to the top horizontal menu individually, but I want them to operate as a drop down below a heading of "information" (or something similar).

 

I can add the CMS category to the top horizontal menu and get the drop down effect, but the item in the top horizontal menu is the CMS category, which is set to "Home" and in a menu bar that really indicates how to get back to your homepage.

 

I can't see a way in the CMS block to add other categories, only pages or blocks under the Home category, nor how I can edit the Home category to give it a more suitable name.

 

Any advice? Thanks

Share this post


Link to post
Share on other sites

there is no way to edit the main CMS category name under the preferences > CMS tab in back office.

for now, the only thing to edit it is to change the database entries:

nESuE40.png

 

this is ps_cms_category_lang table.

  • Like 3

Share this post


Link to post
Share on other sites

I guess I'm just gonna have to do it manually in the CMS and remove my existing links in the top nav and re-adding it one by one.

Edited by hoatbui (see edit history)

Share this post


Link to post
Share on other sites

So you don't want to change the "home" name in the database? If you will change it there, everything will work as you expect.

 

Anyway, your method will show men items like this:

cms 1 | cms 2 | cms 3 | cms 3|

 

You want like this:

 

HOME (or change this for any other name you want in the database)

  1. cms 1
  2. cms 2
  3. cms 3
  4. cms 4

I understood you well?

Share this post


Link to post
Share on other sites

Excuse me for my lack of extensive coding knowledge; although I have worked with back-end coding with CSS/PHP before for troubleshooting which was a complete nightmare.

 

If all of the categories are linked to the root domain of (home), would I simply just remove home from the "name" column? Then that category would be separated?

Share this post


Link to post
Share on other sites

no, i mean that you there you are able to change the "home" name.

if you want to add separate items to the menu, you can do it under the menu configuration tab.

 

take a look:

7vs4vdc.png

 

1) select subcategories of the CMS > home in the left box

2) click on add

 

1) select home item in the right box

2) click on remove

Share this post


Link to post
Share on other sites

Hi Vekia, thanks for all of your help. I think the original problem bob and I were trying to fix was simply trying to remove the subcategories under home. I figured the simplest way to do that was just to remove the existing 'home' tab and creating a new menu top link and linking to the home page.

Share this post


Link to post
Share on other sites

thanks for information and your solution

im convinced that your message above will be really helpful for other merchants here

anyway, if you will have any additional question related to this case - feel free to continue discussion here

 

best regards

Share this post


Link to post
Share on other sites

Hi Vekia, thanks for all of your help. I think the original problem bob and I were trying to fix was simply trying to remove the subcategories under home.

 

No, my issue was that I wanted to change the name of the category from "home" to something more meaningful on a menu bar and Vekia, has shown me how to do this with his solution.

 

Thanks Vekia

Share this post


Link to post
Share on other sites

thanks for information and your solution

im convinced that your message above will be really helpful for other merchants here

anyway, if you will have any additional question related to this case - feel free to continue discussion here

 

best regards

Vekia,

You seem to know how the pages are supposed to work, I cannot get my site working to have the catalog shop up.

I have set up about 4 categories and 4 sub categories. I do not know how to make my homepage connect to the catalog, I tried with the CMS pages, but look at my sitemap and tell me what I did wrong if you can?

 

http://tradeyourdiamond.com/ps/sitemap

 

 

 

thank you,

Steven

Share this post


Link to post
Share on other sites

Vekia,

You seem to know how the pages are supposed to work, I cannot get my site working to have the catalog shop up....

(...)

 

i don't understand what you exactly expect. You want to run store under the catalog mode? If so, you must have to know that if you will use "catalog mode" then noone will be able to order products (your store will be a "catalog" not e-store).

 

if you want to display products on homepage - just turn on module "homefeatured" - it allows to display featured products on homepage.

Share this post


Link to post
Share on other sites

Steven, as with another thread you posted in (http://www.prestashop.com/forums/topic/266027-how-to-edit-front-page-content), my feeling is that the importing of products, categories and images to your shop has gone wrong somewhere.

 

One of your products is called 'HT66'. From its description and your sitemap, I'm guessing it's intended to belong to the subcategory 'White Gold' within the category 'Hearts'.

 

Can you go to Catalog/Products, and select the Edit (pencil) icon for product 'HT66', then in the next screen select Associations from the left hand menu. If one of the resulting categories - should be 'Hearts' - has (1 selected) next to it, click on the + to expand it. Then do a screen print and post the results here.

 

Can you also upload a print of the screen you get when you go to Catalog/Categories.

 

Finally, can you locate the image that is associated with HT66 and provide the pathname for the folder where it is stored.

 

Hopefully all this info will help towards resolving your issue.

 

Thanks, Dave

Share this post


Link to post
Share on other sites

i don't understand what you exactly expect. You want to run store under the catalog mode? If so, you must have to know that if you will use "catalog mode" then noone will be able to order products (your store will be a "catalog" not e-store).

 

if you want to display products on homepage - just turn on module "homefeatured" - it allows to display featured products on homepage.

 

Well I think you just found the reason I am not able to do what I want. I didn't realize catalog mode is not the same as an online store. How do I switch to a store instead of catalog?

I knew that catalog mode is not the same as selling, in the "products- general" settings I have catalog mode "OFF" so I do not know where else this setting is affecting my site.

 

Thanks much,

Steven

Edited by sssteven (see edit history)

Share this post


Link to post
Share on other sites

go to the preferences > products tab in your back office and switch this setting to OFF:

xKw432a.png

Share this post


Link to post
Share on other sites

Steven, as with another thread you posted in (http://www.prestasho...nt-page-content), my feeling is that the importing of products, categories and images to your shop has gone wrong somewhere.

 

One of your products is called 'HT66'. From its description and your sitemap, I'm guessing it's intended to belong to the subcategory 'White Gold' within the category 'Hearts'.

 

Can you go to Catalog/Products, and select the Edit (pencil) icon for product 'HT66', then in the next screen select Associations from the left hand menu. If one of the resulting categories - should be 'Hearts' - has (1 selected) next to it, click on the + to expand it. Then do a screen print and post the results here.

 

Can you also upload a print of the screen you get when you go to Catalog/Categories.

 

Finally, can you locate the image that is associated with HT66 and provide the pathname for the folder where it is stored.

 

Hopefully all this info will help towards resolving your issue.

 

Thanks, Dave

 

Thank you for your help. It appears the categories part of this program has some issues. If you look at the sitemap it makes no sense, and none of the products show up where they are posted also.

Here is the path of the picture:

 

http://tradeyourdiamond.com/ps/32-large_default/ht66.jpg

 

as for the screen shot how do I get that to you? I do not see a way to attach a file, or put a picture in the post.

 

Thank you for your help.

Steven

Share this post


Link to post
Share on other sites

go to the preferences > products tab in your back office and switch this setting to OFF:

xKw432a.png

 

This setting is on off, and has always been. I did read some of the manuel and knew to do this.

Do you think there is an issue with my program since it still thinks its in catalog mode but it isn't?

 

Thank you,

Steven

Share this post


Link to post
Share on other sites

Thank you for your help. It appears the categories part of this program has some issues. If you look at the sitemap it makes no sense, and none of the products show up where they are posted also.

Here is the path of the picture:

 

http://tradeyourdiam...efault/ht66.jpg

 

as for the screen shot how do I get that to you? I do not see a way to attach a file, or put a picture in the post.

 

Thank you for your help.

Steven

 

Hi Steven,

 

To add a screenshot to a post, click the 'More Reply Options' button . Below the content entry panel is a 'Choose Files ...' button. Click that, navigate to your screenshot, click Open. When the file has uploaded, click 'Add to Post'.

 

As for the image path, it looks like the image associated with HT66 is image number 32. If you use your FTP client or the cpanel file manager on your host, is there a folder /ps/img/p/3/2/ present? If so, please can you tell me what files are in that folder.

 

I notice that the New Products block on your site has numeric values where I would expect to see the short description (see screenshot). Are those numeric values meant to be quantities or prices or something? I suspect even more strongly that the CSV import didn't work properly.

post-578343-0-76818400-1376607466_thumb.png

 

Thank you, Dave

Share this post


Link to post
Share on other sites

Hi Steven,

 

To add a screenshot to a post, click the 'More Reply Options' button . Below the content entry panel is a 'Choose Files ...' button. Click that, navigate to your screenshot, click Open. When the file has uploaded, click 'Add to Post'.

 

As for the image path, it looks like the image associated with HT66 is image number 32. If you use your FTP client or the cpanel file manager on your host, is there a folder /ps/img/p/3/2/ present? If so, please can you tell me what files are in that folder.

 

I notice that the New Products block on your site has numeric values where I would expect to see the short description (see screenshot). Are those numeric values meant to be quantities or prices or something? I suspect even more strongly that the CSV import didn't work properly.

post-578343-0-76818400-1376607466_thumb.png

 

Thank you, Dave

Hi Steven,

 

To add a screenshot to a post, click the 'More Reply Options' button . Below the content entry panel is a 'Choose Files ...' button. Click that, navigate to your screenshot, click Open. When the file has uploaded, click 'Add to Post'.

 

As for the image path, it looks like the image associated with HT66 is image number 32. If you use your FTP client or the cpanel file manager on your host, is there a folder /ps/img/p/3/2/ present? If so, please can you tell me what files are in that folder.

 

I notice that the New Products block on your site has numeric values where I would expect to see the short description (see screenshot). Are those numeric values meant to be quantities or prices or something? I suspect even more strongly that the CSV import didn't work properly.

post-578343-0-76818400-1376607466_thumb.png

 

Thank you, Dave

 

Thank you for your reply, here is the screen shot. As for numbers you see, that was the carat weight of the diamond, I just used that column to get that info up with the listings. The import seemed to work fine getting my inventory in, I have to make better columns, but I was just testing to make sure I can upload inventory otherwise it didn't make sense to use the program. I have a lot of items to list which I cannot do one at a time.

I will get back to you on the file names you are looking for, but here is the screen shot.

Thank you for all your help.

 

Steven

post-656086-0-38958800-1376680239_thumb.jpg

Share this post


Link to post
Share on other sites

Here is a picture of the ftp to show you the files that are uploaded.

 

If you need any more information to help I will get it asap.

 

Thank you,

Steven

post-656086-0-65142800-1376685219_thumb.jpg

Share this post


Link to post
Share on other sites

there is no way to edit the main CMS category name under the preferences > CMS tab in back office.

for now, the only thing to edit it is to change the database entries:

nESuE40.png

 

this is ps_cms_category_lang table.

Hi,

 

I edited that, but doesn't change title on front page. At back office chagement is visible.

Share this post


Link to post
Share on other sites

Hi,

 

I edited that, but doesn't change title on front page. At back office chagement is visible.

 

it's a bit outdated post, you can change main category name here:

Z1lticm.png

soorry for the confusion :)

  • Like 1

Share this post


Link to post
Share on other sites

there is no way to edit the main CMS category name under the preferences > CMS tab in back office.

for now, the only thing to edit it is to change the database entries:

nESuE40.png

 

this is ps_cms_category_lang table.

That was amazing help I was struggle for three days, and voila. Thank you, Vekia.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More