Jump to content
Sign in to follow this  
Buzzinessman

Upgrade 1.2.1 impossible, c'est la fête !

Recommended Posts

Hello,

N'essayez pas de mettre à jour vers prestashop 1.2.1 ! vous risqueriez de péter votre site !

L'installeur ne sait pas travailler, et tant que cela ne sera pas la cas mieux vaut éviter les updates des boutiques. surtout vu l'absence du support sur le forum, c'est la seule chose que je peux vous conseiller.

Visiblement en chipotant, j'ai réussi à lancer les updates côté mysql.
mais la création de "tables" bug totalement, & on se retrouve avec une boutique inutilisable & bloquée.

Table '****_shop.ps_pack' doesn't exist

SELECT COUNT(*) as items FROM ps_pack where id_product_pack = 532


J'ai fouillé dans le fichier d'installation, rien ne parle de cette table.
J'ai fouillé le wiki & le forum, rien ne parle de cette table.

surement à t'elle été ajoutée entre 2 mises à jour, & celles-ci n'est plus prise en compte depuis.

Share this post


Link to post
Share on other sites
CREATE TABLE `ps_pack` (
 `id_product_pack` int(10) unsigned NOT NULL,
 `id_product_item` int(10) unsigned NOT NULL,
 `quantity` int(10) unsigned NOT NULL DEFAULT 1,
 PRIMARY KEY  (`id_product_pack`,`id_product_item`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8;



bon voila, le code pour la création de la table.
(trouvé dans les .Sql d'installation & non d'update.

-> changez le préfixe en fonction du votre, j'ai laissé "ps_" par défaut.

Je ne garantis pas que cela fixe tout les bugs, mais cela permet déjà de récuperer sa homepage le temps que l'équipe de prestashop se bouge les fesses. ( 3 jours que l'update est en ligne, toujours aucun support... )

Share this post


Link to post
Share on other sites

Pour ma part, les problèmes suivant surgissent :

# Tous les produits sont "inaccessibles", erreur de droits... YEAHHH
# Les images sont inexistantes alors que le dossier /img/ n'as pas bougé pendant l'upload.
# Le bloc catégorie à disparu
# les stats de l'admin (CA/commandes) n'existent plus (PAIX A LEUR AME)
-> seule les inscriptions & pages vues sont up to date...
# case "Fuseau horraire" dans l'admin, pas de texte... (enfin un bug mineur, ouf)
# impossible de mettre descaractères "/.!@-_=*" etc... dans un mot de passe BO.
# Activation du module "page not found" impossible.

able 'ps_pagenotfound' already exists

CREATE TABLE `ps_pagenotfound` (
id_pagenotfound INTEGER UNSIGNED NOT NULL AUTO_INCREMENT,
request_uri VARCHAR(256) NOT NULL,
http_referer VARCHAR(256) NOT NULL,
date_add DATETIME NOT NULL,
PRIMARY KEY(id_pagenotfound),
INDEX (`date_add`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8;

Share this post


Link to post
Share on other sites

Je n'arrète pas d'allonger la liste,

je pense qu'il est urgent que la team prestashop vire cette 1.2.1 du téléchargement, sinon il va y avoir des pleurs en masse.

Share this post


Link to post
Share on other sites

Amen

j'ai l'impression qu'il a été lancé un peu trop vite cet upgrade.

moi je bouge plus de mon 1.1.0.5 tant que je n'ai pas au moins une personne qui affirme avoir reussi son upgrade

Share this post


Link to post
Share on other sites

Concernant l'accès aux produits
il semblerait que mes groupes aient étés perdus dans l'upgrade...

et donc vu qu'il n'y a aucuns groupes, ceux-ci sont visibles pour PERSONNE.
je vais vérifier en recréant un groupe & en donnant les accès.

( ce qui expliquerait la perte du module "catégories" pour tout le monde, puisqu'aucun accès ! )

(enfin, je dis "semblerait", mais si je ne m'abuse il y'à toujours un groupe défaut créer avec prestashop.
celui-ci n'ayant pas été supprimé par nos soins, cela ne peut venir que de l'upgrade )

si tel est le cas, j'essayerai de vous fournir une requête SQL pour recréer ce groupe & le rajouter par défaut à toutes les catégories.

Share this post


Link to post
Share on other sites

Et bien c'est merveilleux,
il est impossible de créer un groupe de clients, ou un groupe d'accès.

je ne vois rien dans l'admin qui permette de le faire :(

edit : ça se passait anciennement dans "Clients / Groupes", ( je viens de check sur une autre boutique ), mais dans la 1.2.1 il n'y a plus cette option.

Edit : donc voila, je ne peux officielement plus avancé !
désolé pour tout ceux qui attendent de mes news,
mais je crois que vous pouvez attendre une réaction de prestashop

& avez déjà grandement intéret à remettre vos backups en places !

Share this post


Link to post
Share on other sites

Olé, ne cliquez pas sur un fournisseur, le message vous ferait peur !

Unknown column 'meta_title' in 'field list'

SELECT `meta_title`, `meta_description`, `meta_keywords`
FROM `ps_manufacturer_lang`
WHERE id_lang = 2 AND id_manufacturer = 10


Ma journée est plombée, merci prestashop !

Share this post


Link to post
Share on other sites

Censuré [Edit par Patric]

3 eme mise à jour de prestashop,
3 eme mise à jour qui se passe avec pleins de soucis.

Bref, prestashop c'est bien, tant qu'il faut pas mettre à jour.

Je sent que je vais une fois de plus installer une version "neuve" de celui-ci, et importer mes tables clients/produits par la suite. ça prendra moins temps & ça coutera moins d'argent à mon client.

Sauf que la question en ce moment avec le client c'est plus : "restons nous chez prestashop ? Qu'est-ce qui nous garantis que la prochaine update ne sera pas rebelote ?

Share this post


Link to post
Share on other sites

Je trouve très désagréable le ton que tu emploies... Y'a d'autres façons de dire les choses...

Share this post


Link to post
Share on other sites

Excuse moi de passer 5heures à débugger votre truc ! ( alors que j'ai d'autres dossiers urgents en cours )
Excuse moi d'être archi énervé car j'ai une boutique en rade & donc pleins de clients pas content. (qui me tue ma journée)
Excuse moi de m'impatienter car 3 jours après la sortie de l'update SILENCE RADIO DE LA TEAM PRESTASHOP (excepté pour dire que on à un ton hautins qui ne nous reviens pas...)

Excuse moi de m'énerver, car c'est le 3eme update, & la 3eme série de problèmes d'affilé !

Avec tout ça, après ta moralité, une explication sur le problème ? ( si au mois j'étais le seul à rencontrer celui-ci... )

Share this post


Link to post
Share on other sites
Excuse moi d‘être archi énervé car j’ai une boutique en rade & donc pleins de clients pas content. (qui me tue ma journée)


En même temps faut être un bon débile pour faire ses maj sur son serveur de prod... Je supporte pas les gens avec un ton pareil, impossible de m'en empêcher...

GL dude

Share this post


Link to post
Share on other sites

Bonjour,

Tu parles d'une mise à jour de quelle version à quelle version ?
Tu parles des groupes qui ne fonctionnent plus, c'est donc au moins une version 1.2.0.x vers 1.2.1.
S'agissait-il alors d'une version SVN ou d'une release ?

Tout ce qui ne fonctionne pas est dans le fichier d'update de la 1.2.0.2, donc mon diagnostic c'est que tu as installé une version SVN 1.2.0.2 non finalisée et que tu as tenté une mise à jour depuis cette version batarde. Ce qui n'a en effet aucune chance de fonctionner.


Par ailleurs, en effet nous ne sommes pas une hotline gratuite, mais saches que tu as toute notre attention. Autant que pour les 24 999 autres membres de la communauté...

Share this post


Link to post
Share on other sites

Hello,

1. j'ai fait une mise à jour 1.1.0.5 vers 1.2.1
Je n'ai rien téléchargé depuis le SVN, mais bien depuis le lien "download" en direct sur le site principal de prestashop.com

2. Je ne suis pas le seul à rencontrer tout ces problèmes... et tu es le premier à réagir ;) je n'ai pas parlé de hotline gratuite, mais du fait qu'il y'à visiblement de grosses erreurs pour les mises à jour.


Mon procédé de mise à jour :

1. comme indiqué dans le wiki, j'ai sauvegardé ma base de donnée, & mon ftp.
2. j'ai déplacé mon ancien prestashop dans le dossier /old/ du serveur.
3. j'ai resauvegardé une deuxième fois la base de donnée.
4. j'ai uploadé la nouvelle installation fraichement téléchargée
5. je me suis rendu dans le dossier /install/
6. il à reconnu ma version, m'a informé d'un update nécéssaire.
7. j'ai refait les chmods comme demandé,
8. j'ai confirmé ma volonté de mettre à jour, base de donnée sauvegardé.
9. la il m'a demandé de donner les droits à mon fichier settings, ce que je fait.
-> sur le coup il m'a dit que j'étais déjà à jour, mais n'avait rien remis à jour niveau sql.
-> errreurs sur le FO, pas été voir sur le BO au moment même.
10.je remet la version à 1.1.05 dans le settings & relance le processus de mise à jour.
11. la il met dit que tout s'est bien déroulé & me propose de voir l'historique
12. je clic pour voir l'historique sql, tout à l'aire en règle
13. je vais sur la boutique, toujours les mêmes erreurs.
14. je viens sur le forum : oh joie, tout le monde à le même problème que moi. (du moins ceux qui n'ont pas de problèmes ne se manifeste pas).
15. j'essaye d'importer les différents fichiers .sql appelés dans les fichiers d'install via myadmin, en remplacant PREFIX par mon préfix, (ps_).
16. toujours le même message d'erreur
17. je fouille les fichiers "install" pour trouver la table en question (voir ci dessus), j'importe
18. ça marche (cool, mais c'est pas finis)
19. Après la suite de mes opérations est ci-dessus, découvertes de nouveaux bugs, chippotages mais aucune solution.

Share this post


Link to post
Share on other sites

heu moi je trouvais pas son ton très désobligeant mais plutôt humouristique!
en fait chacun son point de vu !!

Mais je le comprend aussi ,j'ai fait de même, profitant du mois d'aout plus calme pour faire ma mise à jour!

D'abord de la version 11.. à la 1208 ou tout c'est bien passer et ensuite voilà que PS met une semaine après une version 1210 pour correction de bugs et améliorations!

bon ça tombe bien cette semaine je suis en vacance alors je me dit bon ben on recommence avec confiance puisque une semaine après, cette mise à jour dois être importante et la patatra .......;
que des bub avec cette version
j'ai fait moi aussi plein d'essais et de modifs mais après trois jours de travail dessus j'ai fais une restauration de mon systhème juste avant cette mise à jour 1210 heu ... heureusement que j'ai un serveur privé o))

J'ai juste eu a recréer mes 6 ou 6 produits de la semaine !!!

De plus je pense pas qu'il voulait une hot line mais juste une réponse comme moi et les quelques autres qui ont fait cette mise à jour FINAL de la 1210 de la part des programateurs de PS!!
Il suffit de voir le Forum....

De plus vu les problèmes avec cette version je ne comprend pas que il ne soit toujours proposer que cette version en téléchargement??

Il serait bien d'avoir en dispo la version 1208 qui elle fonctionne très bien!!!

Share this post


Link to post
Share on other sites

Il n'y a pas les groupes de client en 1.1.0.5, il y a donc une erreur quelque part dans l'énoncé.

Et pour informations, chez PrestaShop aussi on prends des vacances, donc en effet tout le monde n'est pas là et ne passe pas notre temps sur les forums.

Share this post


Link to post
Share on other sites

Donc maintenant que vous êtes de retour peut être devriez-vous enlever cette version 1210 non?

Share this post


Link to post
Share on other sites

Bah dans l'ancienne :

define('_PS_VERSION_', '1.1.0.5');


Peut être que je mélange pour les "groupes" de clients avec une autre de mes boutiques en 1.2, mais cela ne change rien à l'énnoncé puisque cette option est indisponible après mise à jour... ( en 1.2.1 ) Qu'est-ce qui peut justifier d'autres que mes catégories & produits ne soient pas visibles par les visiteurs ?

ils sont bien la en page d'accueil, mais accès restreint.
De plus dans la nouvelle (1.2.1) je n'ai PAS l'onglet de gestion des groupes APRÈS mise à jour.
Soit il y'à une erreur dans le fichier au téléchargement, soit il y'à de sacrés bugs avec la mise à jour.

Bugs qui excusez ressemble d'après vos dires à une mise à jour lancée vite fait avant de partir en vacances, et sont inacceptables sur une version FINAL !

Share this post


Link to post
Share on other sites

As-tu la possibilité de repassé à ton ancienne version?

Si oui, tu pourrai passer ensuite à la version 1208 qui elle fonctionne très bien !

je l'ai donc je pourrais te la filer !!

Mais je te conseille pas de continuer avec la 1210 car tu va découvrir sans cesses des problème, de toute façons cette version n'est pas suffisante en stabilité!!

Share this post


Link to post
Share on other sites
Peut être que je mélange pour les "groupes" de clients avec une autre de mes boutiques en 1.2, mais cela ne change rien à l'énnoncé


Si c'est une 1.1.0.5 avec des morceaux de 1.2 dedans, ça peut avoir son importance... t'as pas moyen d'être sûr ?

Share this post


Link to post
Share on other sites

non je confirme, c'est moi qui ai mélangé, il n'y avait pas la gestion des "groupes" préalablement.
habitudes avec une autre boutique plus récente.

Share this post


Link to post
Share on other sites

Pour éviter de ne broyer que du noir pour la team :) , je tient à dire que j'ai fait les 2 mise à jour sans problème de la 1.1.0.5 à la 1.2.0.8 puis à la 1.2.1.0 , et je ne rencontre pas de bug particulier pour le moment... peux être de la chance... ou peu être vous qui n'avais pas de chance, peu être un peu des deux!

Bon il est vrai en revanche que de sortir 2 version stable à l'intérieur de 2 semaine c'est un petit peu beaucoup lol :P mais bon ca m'apprendra à vouloir absolument les nouveautés tout de suite, la prochaine fois j'attendrais au moins 2 semaines, voir 1 mois, pour être sûr que le tout est stable!

Share this post


Link to post
Share on other sites

Moi j'ai fais la mise à jour, j'ai seulement le module de paiement par carte bleu qui fonctionne plus mais sinon pour le reste tout marche. :)

Share this post


Link to post
Share on other sites

T'a fait des testes dans les catégories de produits du Back ?

Si plus de 50 produits dans une catégorie le liens suivant marche t-il ?
Et retour a la catégorie ?

As-tu l'agrandissement de l'image au survole de la souris du Front?

Et sur une fiche produit, le bloc dans la même catégorie marche t-il (défilement) ?

Share this post


Link to post
Share on other sites

Personnelement,

Oui j'ai fait des tests dans la BO, effectivement retour a la catégorie fonctionne quand il veux, et dès qu'on modifie quelque chose on reviens a la page d'accueil du catalogue, faut toujours se retaper tout le chemin

L'agrandissement au survole de l'image je n'utilise pas cela, en revanche il est possible que cela vienne de ton thème personnalisé? Mais bon je dis ca comme ca je sais pas du tout j'y vais par déduction

Oui le bloc de la même catégorie fonctionne encore dans la fiche produit.

Mais bon, je n'ai pas dit que j'ai une version de PS sans bug, j'ai juste dit que les MAJ pour ma part s'était bien passé, pas de bug ou d'erreur SQL.

Mais sinon en effet, coté BO ya des petit truc chiant :P

Important à préciser, étant donné que j'ai fait peu de modification dans mes fichiers tpl par rappot au thème d'origine, j'ai repris le thème de Prestashop par défault, et j'ai tout recopié dans mon thème personnalisé pour écraser mes propre fichier, SAUF le fichier config, le fichier CSS, et le fichier IMG, ou j'ai copié également, mais à la place d'écraser les fichiers existant, j'ai ignoré, afin de n'ajouter que les éventuels nouveaux fichiers.

Share this post


Link to post
Share on other sites

Bonjour,

je débute avec prestashop, il y a 3 mois je télécharge et installe la version finale en cours sur la page officielle (la version 1.1.truc). Puis je vois dans mon BO que la 1.2.truc est finale, je télécharge (le 16 août), je sauvegarde bien tout ce qui doit l'être, je suis pas à pas la démarche pour l'UPDATE (cf/wiki), puis là je reçois le même message d'erreur que beaucoup "la table PS_PACK n'existe pas", je vais dans le fichier SQL, je la trouve et l'implante directement etc, etc.
Bref, après 1 nuit de plantage, j'en suis venu à la conclusion que si ca commence déjà avec l'installer puisqu'il n'implante déjà pas toutes les bases, vaut mieux retouner à la sauvergarde et attendre des jours meilleurs.

Je félicite le travaille que cela représente et l'investissement et j'espère pouvoir passer rapidement à cette nouvelle version pleine de promesse (sans me prendre la tête).

Cordialement

Share this post


Link to post
Share on other sites

Bjr a tous:
Je suis dessole de lire tout ca, j’ai fais de MAJ dans tout les boutiques, depuis la 1.1.05, la 1.2.0.1, la 1.2.0.3 et la 1.2.1.8 vers la 1.2.1 et je suis dessole, je n’ais pas trouve des problèmes…….
Je fais une copie de mes boutiques vers mon PC, je fais l’Install, j’ai copie mes img, modules, mails et mon setting.inc.php et tout a marche très bien…… Je pense qu’il faut jamais écraser mais renombrer avant de écraser, comme ca on peut retourner et recharger tout ce on avait avant.
J’espère m’avoir fais comprendra…

Share this post


Link to post
Share on other sites

Exemple de la dernière boutique en test depuis 3 mois
www.jenaprestyshop.com
Nous avons charge la boutique avec la ver. 1.2.0.1 et ca marche sans problème

Share this post


Link to post
Share on other sites

Y a toujours une exception qui confirme la règle !
profite en!!!

PS on à rien écrasé, mais ça n'a pas empêché les problèmes!!!

Share this post


Link to post
Share on other sites
Exemple de la dernière boutique en test depuis 3 mois
www.jenaprestyshop.com
Nous avons charge la boutique avec la ver. 1.2.0.1 et ca marche sans problème

Bonjour junnecito,
ton site ne s'affiche pas?...

Cordialement

Share this post


Link to post
Share on other sites

Salut

Hum je pense que tu Troll là junnecito déjà le premier site fonctionne pas secundo le site gourmetyvinos tourne sur du 1.1.0.5 si je ne me trompe pas.

Je suis desolé de lire tout ca, j’ai fais de MAJ dans tout les boutiques, depuis la 1.1.05, la 1.2.0.1, la 1.2.0.3 et la 1.2.1.8 vers la 1.2.1 et je suis dessole, je n’ais pas trouve des problèmes


Faut pas être désolé quand y'a de réels problèmes avec la dernière Version.
Bye
Yannick

Share this post


Link to post
Share on other sites

Bon en revanche j'ai quand même une petit peur, tout à l'heure quand j'ai mis un produit dans le panier dans le FO évidemment, j'ai eu droit à une belle fenêtre d'erreur SQL avec tout les détails.... j'ai réessayé après mais cette fois ci ca a marché... hum il est vrai que je commence a avoir peur de cet version, a savoir si elle est réellement stable? Car si j'ai eu ce type d'erreur, j'imagine que des clients vont en avoir... :(

Share this post


Link to post
Share on other sites

mcmregalos.com ver.1.2.1
jenasexyshop.com ver. 1.2.1
dessole, gourmetyvinos.com est toujour sur ver.1.2.0.1
et suzigifts.com ver.1.2.0.2
dessole, je je travaille pour la maj.
A+

Share this post


Link to post
Share on other sites

Voici le code d'erreur SQL que j'ai eu 1 fois en mettant un article dans mon panier... si ca arrive à un client ca enlève toute crédibilité à la boutique lol, et ceci ne s'affiche pas dans les log d'erreur, car ce n'est pas une erreur 404..

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '075 <= w.`delimiter2` AND d.`id_carrier` = 70 ORDER BY w.`delimiter1` ASC LI' at line 5
       SELECT d.`price`
       FROM `ps_delivery` d
       LEFT JOIN `ps_range_weight` w ON (d.`id_range_weight` = w.`id_range_weight`)
       WHERE d.`id_zone` = 6
       AND 0,075 <= w.`delimiter2`
       AND d.`id_carrier` = 70
       ORDER BY w.`delimiter1` ASC

Share this post


Link to post
Share on other sites

Salut

juste une question, pourquoi ce donné autant de mal pour votre Upgrade? Ne lisez vous pas sur le forum pour vous rendre compte que cette version et gavé de bug en Upgrade ? vous êtes bien patients,moi j'ai vite compris. ;-)

Bye
Yannick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More