en Jump to content
  • 0
chordz

Order page SSL issue

Question

i am having an issue regarding SSL on the order page.. I changed the ssl settings from the database.

the issue is that when the ssl is disabled. i can access the order page (after clicking on checkout). It shows everything in the cart and works perfectly . Even if i manually run the url with HTTPs link . it works without any SSL issue. But when i enable SSL from Back Office or Database .. it gives me this issue :

 

Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

 

Does anyone has an idea what should i do!

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Did you fill in the ssl url in your Backend panel?

I am sorry, what do You think by that.

I have the same problem

 

Thanks

Share this post


Link to post
Share on other sites
  • 0

yes i did! the domain is www.****** and so is the SSL url.. but i dont understand anything.. again when i disable SSL from BO.. it works correctly but on HTTP.. i have enter HTTPs manually.. but when i activate it via back office or database change.. it takes me to HTTPS alright .. but it shows me the redirection error.. And if i use friendly URLs. it gives me Page not found issue

Share this post


Link to post
Share on other sites
  • 0

no reply !.. please guys i need this. I have also contacted the domain provider but everything is fine from their side!

Share this post


Link to post
Share on other sites
  • 0

I contacted the domain providers again and asked them. They still say everything is fine from their side. Although they suggested i should change by hosting packing to use a VPS.

Share this post


Link to post
Share on other sites
  • 0

Did you really do BOTH these things:

 

1) go to back office -> preferences -> SEO & URLs -> scroll down and fill in Set shop URL

 

2) go to back office -> preferences -> general -> enable SSL

Share this post


Link to post
Share on other sites
  • 0

Yikes, forgot to add that you should reset the .htaccess file.  The easiest way that I know to do that is back office -> preferences -> seo & urls -> click whatever you don't currently have enabled under Set Up URLS -> Friendly URL ->  Yes/No, click save, then enable which ever of the two you want for the store.

Share this post


Link to post
Share on other sites
  • 0

Did you really do BOTH these things:

 

1) go to back office -> preferences -> SEO & URLs -> scroll down and fill in Set shop URL

 

2) go to back office -> preferences -> general -> enable SSL

I have already try this change but no sol'n

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More