Jump to content
proteusmk

Prosím o radu - súrne

Recommended Posts

Prosím o radu. Pri pridávaní nových výrobkov sa mi vyskytol nečakaný problém, ktorý som si vlastne všimol len náhodou. Potreboval som narýchlo vyhľadať vo svojom e-shope jeden výrobok a namiesto toho mi začalo vypisovať toto hlásenie:

Warning: preg_replace() [function.preg-replace]: Compilation failed: disallowed Unicode code point (>= 0xd800 && <= 0xdfff) at offset 1829 in ...tu je zadaná celá cesta a končí ... e-shop/classes/Search.php on line 103

 

Chyba by mala byť podľa tohoto hlásenia so súborom Search.php, tak som ho nahradil zo zálohového adresára, ale nič sa nezmenilo.... Prosím o radu.

Share this post


Link to post
Share on other sites

Zdravim,

 

bojujem s tym istym problemom. Search.php je prebrane ciastocne z systemu Drupal a zatial co som zitil dany problem s preg_replace ma nieco spolocne s libpcre instalovanej v systeme. Od urcitej verzie to vypisuje.... riesenie som zatial ziadne nenasiel (okrem "downgrade" systemovej libpcre)

Share this post


Link to post
Share on other sites

Pekný deň,

 

a kde by som našiel downgrade systemovej libpcre? Pokiaľ to pomôže, tak to rád stiahnem. Verziu prestashopu mám 1.4.6.2.

Share this post


Link to post
Share on other sites

On Search.php on /public_html/classes just delete line:


 


'\x{a80b}\x{a823}-\x{a82b}\x{d800}-\x{f8ff}\x{fb1e}\x{fb29}\x{fd3e}\x{fd3f}'.


 


Save and upload it now.


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More