Jump to content

Un cliente ha encontrado un problema con el módulo PayPalAPI


Recommended Posts

Un cliente ha encontrado un problema con el módulo PayPalAPI:

 

PayPal response:

TIMESTAMP -> 2011-10-08T03:49:46Z

L_ERRORCODE0 -> 10002

L_SHORTMESSAGE0 -> Security error

L_LONGMESSAGE0 -> Security header is not valid

L_SEVERITYCODE0 -> Error

PayPal ha devuelto un error

Un cliente ha encontrado un problema con el módulo PayPalAPI:

 

PayPal response:

TIMESTAMP -> 2011-10-08T03:49:46Z

L_ERRORCODE0 -> 10002

L_SHORTMESSAGE0 -> Security error

L_LONGMESSAGE0 -> Security header is not valid

L_SEVERITYCODE0 -> Error

PayPal ha devuelto un error

Share this post


Link to post
Share on other sites
  • 4 weeks later...

Tengo el mismo problema y mismo mensaje que comenta yoquiltrucci el 14 Jan 2011. He revisado todo a mi alcance, con la versión: PrestaShop™ 1.4.5.1 y PayPal v2.8.2, no tengo advertencia ni errores una vez configurado todo en Admin de la tienda pero al seleccionar el botón de pago: PayPal en el quinto y último paso de una compra... el siguiente problema:

Error de autorización de PayPal

 

Compruebe los registros:

  1. PayPal response:
  2. TIMESTAMP -> 2011-11-08T07:55:56Z
  3. L_ERRORCODE0 -> 10002
  4. L_SHORTMESSAGE0 -> Security error
  5. L_LONGMESSAGE0 -> Security header is not valid
  6. L_SEVERITYCODE0 -> Error
  7. PayPal ha devuelto un error

 

IMPORTANTE!!!!!!!!

Terminé de publicar el problema anterior y luego de hacerlo en este post, está solucionado así:

En el módulo de pago de PayPal, Modo de entorno de pruebas: tildar desactivado

Activado Desactivado

Espero que les sirva.

Share this post


Link to post
Share on other sites

Hola Tomasur:

 

Tengo exactamente el mismo problema que ustedes, pero no logro entender tu solución, pones Desactivado y Activado y no te logro entender, tengo instalado la última versión de PrestaShop™ 1.4.5.1

 

No encuentro en el módulo de Paypal la parte donde dices el "Modo de entorno de pruebas", tal vez sea porque tengo el back-office en Ingles. ¿Te refieres a desactivar el modo de prueba SandBox? En tal caso ya yo lo tengo desactivado desde antes y sigo con el mismo problemas.

 

Espero me puedas ayudar.

 

Un Saludo

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 1 month later...

Realmente hay 2 cosas a tener en cuenta.

El modo sandbox requiere estar registrado en developer.paypal.com y abrir las respectivas cuentas.

 

El problema aquí descrito, se soluciona con borrar la contraseña de API si ya la habíamos puesto.

Aunque sea la misma, y sea correcta, solo se debe poner 1 vez. (Un texto en rojo ayudaría mucho)

Share this post


Link to post
Share on other sites
  • 4 weeks later...

En mi caso se han dado los dos problemas.

- El de permisos en la carpeta modules

- El de la clave que comenta wippa en la configuración API del módulo de Paypal.

 

Por un lado a la hora de realizar el pago tanto por transferencia como por Paypal, devolvía un error 404. Una vez cambiados los permisos, la forma de pago por transferencia funcionaba bien pero la de Paypal mostraba el error que aquí se comenta.

 

Ambos han quedado resueltos.

Gracias

  • Like 1

Share this post


Link to post
Share on other sites
  • 1 month later...

Hola yo tambien con el mismo problema

 

Si le quito lo de la APi me pone esto

no puede utilizar Pago exprés si no tiene credenciales de API

 

Y si le pongo la API me da el primer error, alguna solucion???

Share this post


Link to post
Share on other sites

Hola de nuevo, quite la contraseña y ya no me sale el primer error, ahora me sale esto:

 

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@korotikos.es and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. Apache/2.2.21 (Unix) mod_ssl/2.2.21 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_fcgid/2.3.5 Resin/3.1.10 Sun-ONE-ASP/4.0.3 Server at korotikos.es Port 80

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Irantzu, tal vez podrías solucionarlo reinstalando el módulo de Paypal y configurándolo de nuevo.

Desinstalalo, borra rastros de /modules/ si ha dejado algun, reinstalao y configuralo a la primera.

 

 

No se si para estas fechas ya habrás resuelto el problema ;)

Share this post


Link to post
Share on other sites
  • 1 month later...

Me viene que ni pintado, gracias. Y la pregunta que tengo yo ahora es: ¿Cómo autorizar automáticamente un pago de Paypal que he hecho en Sandbox? Tengo cuenta Premier y las APIs funcionando correctamente, pero estoy interesado en que cualquier pago que me llegue se autorice en el momento que me paguen.

 

No, lo de quitar la contraseña no funciona, porque entonces me dice simplemente en el botón grande de Paypal: "Pagar con Paypal". Si pongo la contraseña me dice: "Pagar con Paypal, tarjeta Aurora, etc, etc..." pero entonces me da el famoso error de PayPal response... Y he mirado todos los datos y los tengo bien.

 

Ahora me va aparentemente bien con el Sandbox desactivado y con contraseña (no entiendo nada, pero ahora en principio funciona). Si me deja loguear dentro de Paypal es que el resto lo hace bien, ¿verdad? En fin, será cuestión de encontrar a alguien para ver si se hace el pago y si se "autoautoriza".

Edited by konvulsion2 (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Yo casi te aconsejaría que lo pruebes sin Sandbox, directamente con una cuenta.

 

Obtener una cuenta Bussiness no es muy complicado.

Share this post


Link to post
Share on other sites
  • 2 months later...
  • 5 months later...

(RESUELTO). Hola foro, les comento que he resuelto el problema de seguridad que me enviaba el módulo de Paypal 3.4.5, el error se encontraba en los datos de API Signature, hice las combinaciones posibles cuando se trata de i mayúscula (I) o L minúscula (l), ya que no hay forma de distinguirlas.

 

Espero sirva mi comentario, saludos!

  • Like 1

Share this post


Link to post
Share on other sites
  • 2 months later...

Hola:

 

Yo lo he solucionado reiniciando el modulo de PayPal.

 

En el listado de modulos buscas el de PayPal y tienes varias opciones: suprimir, desactivar, reiniciar y configurar. Pulsas reiniciar y luego configurar , ahi ya vuelves a poner los datos de la api. En mi caso necesitaba cambiar la cuenta de cobro y hasta que no le he dado a reiniciar no ha funcionado correctamente.

 

Un saludo a todos.

 

PrestaShop™ 1.4.6.2 y logo.gif PayPal v2.8.5

Edited by ctic (see edit history)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More