Jump to content
Sign in to follow this  
siobud

[Résolu] Login client impossible sur Safari

Recommended Posts

Tout d'abord grand merci pour votre solution de shop!

Simple, efficace et agréable à utiliser.  :)

Vivement les mises à jour et qu'il se développe à plus grande échelle (modules, thème, etc).

 

Je tenais juste à reporter un bug sous OSx 10.5.1, Safari 3.0.4.

Le login client est impossible. Après avoir entré le mot de passe et nom d'utilisateur et cliqué sur "'s'identifier" le compte utilisateur n'est pas accessible.

 

Meilleures salutations.

 

Nicolas

Share this post


Link to post
Share on other sites

Bonjour Nicolas

 

Nous sommes sur le bug actuellement et il est quasiment repare.

Le correctif sera dans la release 0.8.9.

Merci pour le signalement de cet important bug.

Share this post


Link to post
Share on other sites

Bonjour,

 

J'apporte ma petite pierre à l'édifice en donnant la solution, Safari (ancienne version) ne gère pas les formulaires avec action="", il vous redirige alors vers la page d'accueil. Nous avons mis à jour l'ensemble du code en conséquence, aussi je vous conseille d'attendre la nouvelle version 0.8.9 pour en bénéficier.

 

Cordialement,

Bruno Lévêque

Share this post


Link to post
Share on other sites

bonjour,

j'aimerais corriger ce bug sans faire une mise a jour complete.

pour cela j'ai remplacé les fichiers 'authentication.php' et 'themes/montheme/authentication.tpl' par les fichiers de la version 0.9.5 ; malgres tout, le bug persiste.

serait il possible d'avoir la liste des fichiers a modifier ?

Share this post


Link to post
Share on other sites

Bonjour reiser

 

Nous ne pouvons vous fournir une liste exhaustive.

En revanche, vous pouvez la constituer vous meme.

 

Pour cela il vous suffit d'effectuer une recherche sur vos fichiers PrestaShop avec les termes suivant : "action="" (la double quote ouvrante etant comprise dedans).

Apres cela il vous suffit de les remplacer par :

"action="'.$_SERVER['REQUEST_URI'].'" pour les pages .php

"action="{$smarty.server.REQUEST_URI}" pour les pages .tpl

 

Sachez tout de meme que rester en v0.8.5.1 est completement deprecie.

Share this post


Link to post
Share on other sites

bonjour et merci pour cette réponse.

j'avais essayé quelque chose dans ce gout la mais j'ai du inverser la syntaxe des TPL et des PHP...

enfin, tout est rentré dans l'ordre : merci.

 

Sachez tout de meme que rester en v0.8.5.1 est completement deprecie.

je comprend bien ... cela dit ma boutique est prête et je me garde les complications d' upgrade pour la version 1.0 ... fumiste que je suis !  ;D

Share this post


Link to post
Share on other sites

Content de savoir que cette modification s'est effectuee sans soucis :)

 

je comprend bien ... cela dit ma boutique est prête et je me garde les complications d' upgrade pour la version 1.0 ... fumiste que je suis !  ;D

Eh bien comme diraient nos amis anglophones See you on the 1.0 release ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More