Jump to content

Prosím o radu - chybová hláška Deprecated


zabza
 Share

Recommended Posts

Zdravím. Tlačítko hledat jsem použil, ale z výsledku nejsem moc moudrý.

Objevila se mi chybová hláška (chyby pro přehlednost zvýrazním tučně):
Deprecated: Function eregi() is deprecated in /home/www/adresaobchodu.cz/www/classes/Db.php on line 89

Ta se opakuje několikrát po sobě a je prokládána hláškami:

Warning: Cannot modify header information - headers already sent by (output started at /home/www/adresaobchodu.cz/www/classes/Db.php:89) in /home/www/adresaobchodu.cz/www/header.php on line 4

a

Warning: Cannot modify header information - headers already sent by (output started at /home/www/adresaobchodu.cz/www/classes/Db.php:89) in /home/www/adresaobchodu.cz/www/classes/Cookie.php on line 254

Jinak obchod je možné mezi těmi hláškami objevit (rozházený jak sviňa by někdo řekl).

V adminu jsem na tom stejně. Základní hláška s odkazem na řádek 89 se opakuje také a je doplněna hláškou

Warning: Cannot modify header information - headers already sent by (output started at /home/www/adresaobchodu.cz/www/classes/Db.php:89) in /home/www/adresaobchodu.cz/www/jmenoadmina/header.inc.php on line 15
Přihlášení pro admina se nezobrazuje.

Webftp i ftp je ok, MySQL také.

Používám verzi 1.1.0.5 (vím, že mě někdo bude kamenovat, ale bezchybně sloužila dva roky a přiznám se, že upgraedu se trochu bojím).
Pokud někdo poradíte, budu moc rád. Díky.

Share this post


Link to post
Share on other sites

Tvoj problem zrejme suvisi z verziou PHP, ktora bezi na tvojom webhostingu. 1.1.0.5 je velmi stara a zrejme si uz nerozumie s novou verziu PHP na tvojom serveri.

Upgrade z 1.1.0.5 by nemal byt problem, aj ked som sa pri jeho vykonavani uz stretol s roznymi problemami.

Share this post


Link to post
Share on other sites

Ano, moze to byt problem. Ak je tomu tak, potom mas len dve moznosti:
1. zmenit webhosting, kde ti bude tvoj stary shop bezat, ale je len otazka casu, kedby dany webhosting aktualizoval svoj software
2. urobit upgrade minimalne na 1.3.7.0

Odporucam urobit seriu testov, ktore overia hypotezu.

Share this post


Link to post
Share on other sites

Základní chyba je:
Deprecated: Function eregi() is deprecated...

Tato funkce je zastaralá v PHP 5.3, takže tuto verzi používáš. Stačí v php.ini, na konec řádku error_reporting přidat & ~E_DEPRECATED

Ostatní chyby jsou způsobeny jen tou první. Když první zmizí, zmizí i ostatní.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More