Jump to content

Recommended Posts

Hallo,

nach dem Umzug auf einen größeren Server habe ich die Datenbank importiert. Nun ist zwar alles da, aber der Warenkorb funktioniert nicht und gibt Fehler aus:

 

Warning: finfo_file(/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/modules/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/blockreassurance/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/views/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/img/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/img_perso/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/zoll.png): failed to open stream: No such file or directory

Wenn ich über FTP schaue, dann gibt es die Verzeichnisse, die dort stehen (nach../dunpop/...) auch gar nicht auf dem FTP.

Share this post


Link to post
Share on other sites

"nach ../dunpop/..."? Das taucht in den Links ja zweimal auf, die Verzeichnisse ../dunpop/modules etc. sollte es schon geben nur das folgende /homepages... hat da nichts zu suchen, vielleicht ein Fehler in der .htaccess .

Share this post


Link to post
Share on other sites

8 minutes ago, rictools said:

"nach ../dunpop/..."? Das taucht in den Links ja zweimal auf, die Verzeichnisse ../dunpop/modules etc. sollte es schon geben nur das folgende /homepages... hat da nichts zu suchen, vielleicht ein Fehler in der .htaccess .

Meckert er über ein Verzeichnis oder mehrere bei der Meldung?

Warning: finfo_file(/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/modules/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/blockreassurance/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/views/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/img/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/img_perso/homepages/29/d632282663/htdocs/clickandbuilds/PrestaShop/dunpop/zoll.png): failed to open stream: No such file or directory

Einen Modules Ordner habe ich, aber die Anderen img_perso, homepages, 29, views, etc. nicht. Meine Tiefe geht eigentlich immer clickandbuilds/PrestaShop/dunpop aus. Alles was in der Meldung danach kommt, finde ich im FTP gar nicht. Wo finde ich die htaccess?

Share this post


Link to post
Share on other sites

Stimmt, es scheint sich nur um EINE sehr, sehr lange Verzeichnisstruktur zu handeln ...

/homepages/29/... müßte das Stammverzeichnis bei deinem Webhoster sein.

Die .htaccess (mit Punkt am Anfang!) müßte im Verzeichnis dunpop liegen, darin werden Weiterleitungen festgelegt. Generell sollte man wenn man einen Serverumzug macht solche Grundkenntnisse besitzen oder jemanden beauftragen.

Funktioniert denn sonst alles, sowohl der Shop als auch das BackOffice? Wenn ja kannst du auch unter SEO & URLs die Friendly URLs dekativieren, speichern und dann wieder aktivieren und speichern, dabei wird die .htaccess neu generiert.

Share this post


Link to post
Share on other sites

3 hours ago, rictools said:

Stimmt, es scheint sich nur um EINE sehr, sehr lange Verzeichnisstruktur zu handeln ...

/homepages/29/... müßte das Stammverzeichnis bei deinem Webhoster sein.

Die .htaccess (mit Punkt am Anfang!) müßte im Verzeichnis dunpop liegen, darin werden Weiterleitungen festgelegt. Generell sollte man wenn man einen Serverumzug macht solche Grundkenntnisse besitzen oder jemanden beauftragen.

Funktioniert denn sonst alles, sowohl der Shop als auch das BackOffice? Wenn ja kannst du auch unter SEO & URLs die Friendly URLs dekativieren, speichern und dann wieder aktivieren und speichern, dabei wird die .htaccess neu generiert.

Vorab ein groés Danke, dass du immer so viel hilfst!

Ich habe den Shop mit einem Mini Paket bei 1&1 angefangen. Als ich da an die Grenzen gekommen bin, habe ich auf ein höheres Paket umgestellt und mein Berater schrieb mir, dass ich nur die Datenbank sichern und nach dem Upgrade einspielen muss. Mehr nicht.

Nach dem Upgrade ging alles (auch ohne DB einspielen), bis ich nach zwei Tagen den Warenkorb getestet habe. Der ging nicht... Ich habe dann den Support angeschrieben und ihnen geschildert was passiert ist. Dann habe ich die DB eingespielt wie vom Support beschrieben. Ging noch alles, aber der Warenkorb weiterhin nicht.

Dann sagten die mir, ich müsste die Config an die Datenbankänderung anpassen, konnten aber nicht sagen, wie man das macht. Von wegen, einfach nur importieren... Wozu hat man denn Experten, die sagen, dass es nur 1 Klick ist und dann nicht helfen :(

JEdenfalls bin ich mit der Config nicht weitergekommen und habe dann hier gefragt, da der Support meinte, es liegt an Prestashop. Ja, eben war es noch die config...

Jedenfalls ist das der Grund warum ich keine Hilfe für den Umzug hatte. Es sollte ja nichts gemacht werden von meiner Seite.

Ähm, eine .htaccess habe ich nicht gefunden. Ich habe unter Seo & URLS die Option aktiviert, deaktiviert wie du geschrieben hast. Änderte aber nichts.

 

Aber: Mich hat der Dateipfad (....modules....) und die fehlende Datei zoll.png irritiert. Also habe ich zunächst versucht ein beliebiges Bild mit dem Namen hochzuladen per FTP. Klappte aber nicht. Der Fehler blieb.

Dann habe ich überlegt, wo ich dieses Bild mal eingebaut habe. Da ich es nicht mehr wusste, habe ich alle Module deaktiviert und nacheinander wieder aktiviert. Nach jedem Modul geguckt, ob sich an dem Fehler was ändert. Am Ende war es das Modul Customer Reassurance v5.0.0 - von PrestaShop. Dort hatte ich Anfang des Jahres eine CMS Datei erstellt mit einem Zoll Hinweis für den Warenkorb. Modul wieder aktiviert und CMS Datei deaktiviert und der Warenkorb geht wieder.

Nun frage ich mich natürlich, warum die Datei weg ist. Der Support sagte ja, dass der Inhalt 1:1 umzieht. Warum sollte die Datei bzw. die CMS oder der Pfad weg sein und diesen Fehler produzieren? So ganz ist mir das nicht klar 😕

Share this post


Link to post
Share on other sites

Also wenn der Shop bereits vor dem Einspielen der Datenbanksicherung funktionierte greift er wohl auf die alte Datenbank zu (entweder ist die noch erreichbar oder du kannst auch nach der Paketumstellung diese weiter nutzen). Wenn du jetzt die Datenbanksicherung einspielst (wo eigentlich, beim Provider, bei Prestashop?) mußt du vielleicht auch die Zuordnung des Shops zur Datenbank in der Konfiguration ändern. Überprüfe doch einmal im Prestashop BackOffice unter "Erweiterte Einstellungen" die Seite "Information". Schau da auch gleich mal welche PHP-Version aktiv ist.

Wenn du die .htaccess nicht im Stammverzeichnis des Shops findest, ist vielleicht dein FTP-Programm (oder wie du auf die Dateien zugreifst) so eingestellt daß versteckte Dateien nicht angezeigt werden.

Die Inhalte von CMS-Seiten werden nicht als Datei, sondern in der Datenbank abgelegt.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More