Jump to content
Puppo

PS 1.7.6.4 Artikel im Warenkorb immer nicht an Lager

Recommended Posts

Hallo zusammen

habe einen Update meines Shops durchgeführt von 1.6.X auf die aktuelle Version PS 1.7.6.4. Soweit alles ok aber

egal welchen Artikel, der mit genügend Lager vorhanden ist in den Warenkorb gelegt wird, zeigt es dann im Warenkorb an "Der Artikel XXXXXXXX in Ihrem Warenkorb ist nicht in gewünschter Menge verfügbar. Bitte, passen sie die gewünschte Menge an."

Ich kann einfach nichts dazu finden. Hat jemand eine Idee, wo ich ansetzen kann?
Shop ist jetzt wieder im Wartungsmodus damit sich die Kunden nicht total ärgern.

Vielen Dank und Gruss

 

 

Share this post


Link to post
Share on other sites

wow, dachte es sind viele Zuhause in diesen Zeiten.

Niemand? 

Ich bin um jeden Hinweis dankbar!

Share this post


Link to post
Share on other sites

Neue Artikel funktionieren im Checkout.

Somit muss es irgendwie mit dem Lagerbestand zu tun haben. Vorher hatten wir die erweiterte Lagerverwaltung aktiv.

Wenn ich die Bestände prüfe sieht aber alles gut aus. Irgendwie muss da etwas schief laufen bei einer Tabelle...

Würde mich über eure konstruktiven Gedanken zum Problem freuen.

Share this post


Link to post
Share on other sites

Nachts schlafen die meisten ...

Generell gibt es bei einem Upgrade von 1.6 auf 1.7 oft Probleme, bei einem laufenden Shop ist so etwas gefährlich. Die erweiterte Lagerverwaltung gibt es so in 1.7 ja nicht mehr, ich würde mir einmal die Tabellen direkt anschauen und die Einträge alter mit denen neuer Artikel vergleichen.

Hast du einmal versucht, ob der Fehler auch auftritt, nachdem du bei einem Artikel den Lagerbestand geändert hast? Testweise unter Leistung alle Fremdmodule und Overrides deaktiviert?

Share this post


Link to post
Share on other sites

Danke für die Antwort.

Was ich bis jetzt rausgefunden habe:
Bestand ändern hilft nicht.
Artikel öffnen und neu speichern hilft.

-> Ich muss jetzt also jeden Artikel öffnen und speichern.

Sollte da jemand eine Massenmassnahme wissen, gerne!

Share this post


Link to post
Share on other sites

Wie gesagt, ich würde direkt in der Datenbank vergleichen und ggf. kannst du da den falschen Eintrag auch gleich korrigieren. Eine Möglichkeit wäre vielleicht auch die kostenlose Prestools-Suite (prestools.com), deren Installation sowieso sinnvoll ist.

Share this post


Link to post
Share on other sites

Danke, Prestools kenne ich und nutze ich auch, habe aber dort jetzt keine Funktion gesehen die mir quasi jeden Artikel neu speichert.

Bin jetzt dran und zwei Kollegen helfen. Solange ich keine andere Lösung habe ist der manuelle Workaround halt so.

Tabellen zeigen keine Unterschiede beim Bestand vor und nach dem Speichern auf.

Danke fürs mitdenken und Gruss

Share this post


Link to post
Share on other sites

Nachdem du irgendeine Änderung an einem oder per Massenbearbeitung allen Artikeln vorgenommen hast kannst du diese en bloc speichern, ob das den Fehler beseitigt, kannst du ja erst einmal mit einzelnen Artikeln testen.

Der Unterschied wird wohl kaum beim Bestand liegen, sondern in irgendeinem anderen Feld evtl. auch in einer anderen Tabelle (die z. B. für die Lagerverwaltung in 1.6 verwendet wurde).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More