Jump to content
MikeRogler

gerade einen Hook gesetzt für Kontaktformular im Modul Menu für Mobile endgeräte

Recommended Posts

Oops! An Error Occurred

The server returned a "500 Internal Server Error".

Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.

Jetzt wird mir das angezeigt. Ich komme nirgens mehr rein.

Hilfe

Share this post


Link to post
Share on other sites
Posted (edited)

ich kann nicht einmal mehr die seite für wartung offline schalten

das steht im server unter logs

Fehler:    Directory /logs/access.log.02.1: no such file or directory
Fehler:    Verzeichnisinhalt konnte nicht empfangen werden

Edited by MikeRogler
was vergessen (see edit history)

Share this post


Link to post
Share on other sites

500 Internal Server Error.....must dein hoster fragen.

der fehler wird dir gezeigt,....Verzeichnisinhalt konnte nicht empfangen werden

Share this post


Link to post
Share on other sites

FATAL ERROR: Network error: Software caused connection abort

das steht jetzt auch noch unter logs im ftp programm

Share this post


Link to post
Share on other sites
Posted (edited)

FATAL ERROR: Network error: Software caused connection abort

Das Problem ist der Server selbst nicht Prestashop, deshalb an deinen Hoster wenden

Edited by SliderFlash (see edit history)

Share this post


Link to post
Share on other sites

der screenshot eine wiederherstellung von gestern ob das eine lösung wäre aber da bekomme ich diese fehlermeldung mit den Systemanforderungen

 

Share this post


Link to post
Share on other sites
Posted (edited)

nein erst mal den Hoster fragen was mit dem Server los ist erst dann Backup ausführen, so würde ich das machen.

Edited by SliderFlash (see edit history)

Share this post


Link to post
Share on other sites

1&1 wird wieder sagen es liegt an Prestashop bei 1&1 ist alles in ordnung

Share this post


Link to post
Share on other sites

wie kann ich das modul löschen wenn ich im admin bereich von ps nicht auf die module zugreifen kann?

Im FTP server dann ?

Share this post


Link to post
Share on other sites

Sehr geehrter Herr Rogler, vielen Dank für Ihre Kontaktaufnahme mit mir, bezüglich des Presta Shops. Bedauerlicherweise kann ich und auch die Kollegen der Technik Ihnen hier nicht weiterhelfen, da wir keine Skript Supporter sind sondern Hoster. Ich möchte Sie daher bitten sich in den PrestaShop Foren zu informieren unter https://www.prestashop.com/forums/.

dass ist die antwort von 1&1

Share this post


Link to post
Share on other sites
Posted (edited)
33 minutes ago, MikeRogler said:

wie kann ich das modul löschen wenn ich im admin bereich von ps nicht auf die module zugreifen kann?

Im FTP server dann ?

Ja, auf dem FTP das Verzeichnis des betroffenen Modules umbennen z.B. _old hinten anfügen.

Edited by JBW (see edit history)

Share this post


Link to post
Share on other sites

ich bin mir nicht sicher ob es ein modul war oder über design position

Share this post


Link to post
Share on other sites

Module sind im Verzeichnis /modules/, das hat nix mit deinem Theme aus dem Screenshot zu tun.
Genauere Hinweise wo der Fehler entsteht kannst du bei aktivierten Debug Modus sehen, dazu die Datei /config/defines.inc.php editieren und in Zeile 29 "true" setzen

define('_PS_MODE_DEV_', true);

 

Share this post


Link to post
Share on other sites

ich kann den debug modus nicht aktivieren weil ich nicht mehr draufkomme.

Share this post


Link to post
Share on other sites

Ich habe doch erklärt wie du den per FTP aktivierst!?

Share this post


Link to post
Share on other sites

bitte nochmal erklären für mich ohne programierkenntnisse

Share this post


Link to post
Share on other sites
Posted (edited)

Lade dir das Programm Editor runter https://www.heise.de/download/product/notepad-26659

danach öffnest du die datei /config/defines.inc.php  mit dem Editor und suchst diese zeile 29

steht

define('_PS_MODE_DEV_', true);

da müste false stehen den auf true stellen, dann oben im Editor die änderung speichern und die datei wider hochladen, dann siehst du es.

 

und für die Zukunft hier eine Seite für Anfänger wo du die Grundlagen lernen kannst " Wie Fange ich An"

 

Edited by SliderFlash (see edit history)

Share this post


Link to post
Share on other sites
vor 28 Minuten schrieb MikeRogler:

dass ist die datei im screenshot und dann

grafik.thumb.png.cbdd60f43ccd469e441cce82de9a5760.png

kannst du die cache löschen ? dann lösche die Cache

Share this post


Link to post
Share on other sites

wen du im Admin Center bist im Menu

Shop-Einstellungen/Allgemein dann oben im Tab Wartung,

Shop aktivieren auf Nein ,
mein ip-adresse hinzufügen (damit nur du den shop sehen kannst) und speichern.

 

Share this post


Link to post
Share on other sites

im admin center komme ich nicht mehr dorthin um den Wartungsmodus zu aktivieren.

daher muss ich es über FTP machen. aber wo?

Share this post


Link to post
Share on other sites

Das wird mir im Debug Modus als Fehler angezeigt.

Kann jemand helfen.

 

grafik.thumb.png.cfdf7efc37ca7cbedf12935bae5eae88.png

Share this post


Link to post
Share on other sites

Der Fehler ist im Modul contactform, resete diese bzw. entferne es direkt perFTP und installiere es neu. Seltsam ist das bei dir ganz andere Zeilennummer als in der aktuellen Modulversion angegeben sind, stelle sicher dass die die neuste Version installierst.

Share this post


Link to post
Share on other sites

Wenn ich den order des modul Contactform leere geht mein admim backoffice wieder sobald ich das Verzeichnis im ftp wieder fülle kommt der Fehler wieder 

Share this post


Link to post
Share on other sites

Oh je, in diesem Thread geht es aber kräftig durcheinander, mehrere gleiche (oder auf den ersten Blick identisch aussehende Screenshots hintereinander ohne nähere Erläuterung, zwischendurch eine Fehlermeldung von IONOS, daß dein Browser zu alt sei (ohne daß du schreibst, welchen Browser du verwendest und ob du einen anderen probiert hast) ...

Außerdem habe ich schon nicht verstanden, wie du "gerade einen Hook gesetzt hast", unter Positionen oder in einer Datei oder in einer Moduleinstellung? Denn das war ja ein Hook für das Kontaktformular und das Kontaktformular-Modul verursacht ja offenbar auch das Problem, also müßtest du genau diese Operation rückgängig machen, evtl. auch das Modul "Menu für mobile Endgeräte" deaktivieren.

Share this post


Link to post
Share on other sites
10 hours ago, MikeRogler said:

sobald ich das Verzeichnis im ftp wieder fülle kommt der Fehler wieder

Wie füllst du denn das Verzeichniss wieder? Hast du wie von mir geraten die neuste Version des Modules neu installiert?

Share this post


Link to post
Share on other sites

ich habe das verzeichnis mit der neuesten version des modul gefüllt.

Dass Modul "Menu für mobile Endgeräte" hab ich auch deaktiviert.

Der Fehler kommt immer wieder sobald in den Ordner Modul Contactform fülle.

Ich habe im Modul einen Link gesetzt (der dann als button in den Kategorien zu sehen ist) für die Kontaktseite da der Button Kontakt auf der Mobilseite nicht die richtige Kontaktseite öffnet.

Den Link im Modul Menu/Mobile habe ich aber gelöscht da es vielleicht der auslöser war, aber auch nicht.

Share this post


Link to post
Share on other sites

komischerweise finde ich das Modul Mobile/menu nicht auf dem Server

Share this post


Link to post
Share on other sites

bin ratlos dann muss der fehler wohl den hooks kommen im bereich position ?

Share this post


Link to post
Share on other sites

Ich meine das Modul "contactform" neu zu installieren denn da tritt ja der Fehler auf

Share this post


Link to post
Share on other sites

ja trotzdem. ich habe gestern mit hilfe von Magicalname die hooks gelöscht über ftp und die alten hooks aus der db sicherung aufgespielt dann ging es wieder. also gelöst.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More