Jump to content
Yan16

Shop Owner New Order Email Notification not working

Recommended Posts

Posted (edited)

Hi Everyone 

I am having issues receiving the confirmation email when ordering from the site.   I think I have tried everything! Let me explain.

  • The client receives the confirmation email just fine,
  • The online contact form also works  correctly (both the client and shop receive email), 
  • The test email works fine from BO email configuration

The only thing that DOES NOT WORK are the confirmation order emails to the Merchant!

Solutions I have tried but with no success.

  • I have installed mailalerts module
  • I have changed the PHP mail Funcion to SMTP emails
  • Checked with host company there is no restrictions plus there is NO LOG of emails being sent to the shop owner when order is confirmed. No trace of email...
  • Tried all email formats (text and HTML)

But no luck! My order confirmation emails still do not arrive to the shop owner! 

What Can this be? 

Thanks in advance, 

 

 

 

Edited by Yan16 (see edit history)

Share this post


Link to post
Share on other sites

Prestashop doesn't send confirmation email to merchant by default. You need module for that -- do you have one installed?

Share this post


Link to post
Share on other sites

Hi Guys

Thanks for reply in the end I managed to solve this issue!  My problem was that the mail alert module i had installed was not working I got this from GitHUB  https://github.com/PrestaShop/mailalerts  AND THIS DOES NOT WORK with latest prestashop.  

For those with similar issue you need to download the mail alert module directly from Prestahop Modules Manager,  (just search for mail alert) this is the correct one and this will solve the issue of sending mail confirmations to merchant. 

Best

 

Share this post


Link to post
Share on other sites

yan16, good luck

Even though I installed the mail alert module from module manager, shop owner or even the customer still can not received order confirmation email.

 

this is a big problem for me

 

Share this post


Link to post
Share on other sites

HI  weixuan0710

I am not much of an expert here but you should try the following steps.

  • First test you prestashop in mail configuration to make sure it sends emails correctly. 
  • Changed the PHP mail Function to SMTP to send emails, this works some times!  ( > Email configuration )
  • Checked with you host company to make sure there  is no restrictions plus get them to check the log to see if prestashop is sending emails.  ( > Email configuration ) 
  • Try with all email formats (text & HTML) ( > Email configuration )
  • Perhaps try another mailalert module I understand there are some paid options that might work better for your instalation. (From what I understand this is the main one... u need to try). I tried 3 diff ones until  I found the one that worked for me... not sure why but it did! 

Hope this helps. 

 

Best 

Share this post


Link to post
Share on other sites
8 hours ago, Yan16 said:

HI  weixuan0710

I am not much of an expert here but you should try the following steps.

  • First test you prestashop in mail configuration to make sure it sends emails correctly. 
  • Changed the PHP mail Function to SMTP to send emails, this works some times!  ( > Email configuration )
  • Checked with you host company to make sure there  is no restrictions plus get them to check the log to see if prestashop is sending emails.  ( > Email configuration ) 
  • Try with all email formats (text & HTML) ( > Email configuration )
  • Perhaps try another mailalert module I understand there are some paid options that might work better for your instalation. (From what I understand this is the main one... u need to try). I tried 3 diff ones until  I found the one that worked for me... not sure why but it did! 

Hope this helps. 

 

Best 

Hi, Yan16

Thanks for your reply, really appreciate your time and patience.

i sorted out my problem. Probably everyone will laugh at me. The reason is when I change my logo of order email from .png to .jpg, everything is fine. 

See, such a little thing pain me ass at least 1 week time. Can not imagine Gmail even has the limitation on .png format in the email, not on .jpg.

other people can try to solve your email problem after seeing it. But the condition is that you find log errors in the back office with 552.0.5.7 (security contents  risk in the email.

thanks for Gmail about this limitation which it is really hard to find it out. I have to say I got my luck to figure out after I tried every solution.

Best regards

michael

 

 

  • Like 1

Share this post


Link to post
Share on other sites

That is both funny and sad. But it's definitely a good thing to know and remember. Thanks for sharing

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More