Vote to Improve PrestaShop

PrestaShop Forum: Build a free online shop. Count on the Community!

The best place in the world to ask questions about PrestaShop and get advice from our passionate community!

PrestaShop Forum: Build a free online shop. Count on the Community!

Jump to content

 
Photo

[Solved]Blured images of product...

blur image product

  • Please log in to reply
15 replies to this topic
Alain Costea

    PrestaShop Apprentice

  • Members
  • PipPip
  • 170 posts

Posted 01 May 2013 - 01:37 PM

Hello,
I have a problem: I don't understand why, all my images of products seems to be blured.
Only when i click them and are showd separatly, is ok, otherwise, are blured ( on featured, new products, product page).

I tried, jpg, png, cmyk, rgb...nothing.

Does somebody has an ideea?


Thank you.

Edited by Alain Costea, 03 May 2013 - 08:41 PM.

The real thing is to ask good questions...

splash_info

    PrestaShop Apprentice

  • Members
  • PipPip
  • 35 posts

Posted 01 May 2013 - 02:13 PM

Hello,

What is the initial resolution of your images (before upload) ? And are you using the default theme ?

Benjamin Utterback

    Community Jedi

  • PrestaTeam
  • 5841 posts

Posted 01 May 2013 - 02:21 PM

Hi Alain, thank you for the message. If you could, please provide screenshots and a URL if you can. It will help us greatly.

For now, you can let us the resolution and theme status of your website. Thank you splash!

Arnel

    PrestaShop Apprentice

  • Certified Partners
  • 89 posts

Posted 02 May 2013 - 12:07 AM

Hello Alain,

Sorry for the issues with your images. Just a quick word. In CASE you didn't look, remember the PREFERENCES- IMAGES menu in the Administrator dashboard. This lets you set your image sizes. That way, you can predict how your images will look based on the size. Check your images using a graphics tool like GIMP (free) or Adobe Photoshop. If your original image is small and then being blown up, then it will be blurry. Rule of thumb for image resolution - images for the web are typically 72dpi - any larger and your file size starts growing (and it's not necessary). Check it out, and if you're still having problems make sure to post the requested information so that we can give you a hand!

Regards,

Arnel C.
Community Support Team
Web Hosting Hub

Arnel C.

Customer Community Team

InMotion Hosting


Alain Costea

    PrestaShop Apprentice

  • Members
  • PipPip
  • 170 posts

Posted 02 May 2013 - 11:45 AM

Hello,
sorry for not nswering sooner ( personal problems)...
I use PS 1.5.4.

So:
The blur is inclusevely on default images: http://decorativ-art...BlurMacBook.jpg

I have not the default theme. But also in the default themes looks blured ( not so obviously, because the image window is smaller).

I tried different resolutions (72, 150, 200 300), .jpg, or .png, different dimensions, but it doesn't seem to work. Somehow I don't think it is a resolution problem, because if you click them looks like that: http://decorativ-art...rmacbookmax.jpg .

I checked the preferences/images, tried everything ( I think...), but not a change on front pages...

I must say, that, although I am a beginner on presta, css, php...etc, I know how to work with images, especially in corel draw.

Thanks for help, I don't know waht to try....
The real thing is to ask good questions...

the.rampage.rado

    PrestaShop Apprentice

  • Members
  • PipPip
  • 266 posts

Posted 02 May 2013 - 09:02 PM

If you had increased the size of the pics you have to hit 'regenerate thumbnails' so all pics get the proper dimensions. :)

Alain Costea

    PrestaShop Apprentice

  • Members
  • PipPip
  • 170 posts

Posted 03 May 2013 - 06:08 AM

I know, I do that after every modification on images from bo...
The real thing is to ask good questions...

yaniv14

    PrestaShop Addict

  • Members
  • PipPipPip
  • 733 posts

Posted 03 May 2013 - 06:31 AM

Can you enable your shop to see.

the.rampage.rado

    PrestaShop Apprentice

  • Members
  • PipPip
  • 266 posts

Posted 03 May 2013 - 10:54 AM

OK, then what're your image quality settings? 90 or less?

Alain Costea

    PrestaShop Apprentice

  • Members
  • PipPip
  • 170 posts

Posted 03 May 2013 - 08:39 PM

Hello,

How do i solved tis problem:
I changed small_default and medium_default from 45x45pxl to 58x59pxl, and from 180x180pxl to 212x212 pxl.That solved for thumbanils.
For home products, it doesn't worked anything I changed. But there will be just a few images shown directly, most of them will be seen through a module for colorizing background.

Thank you all for support.
The real thing is to ask good questions...

yaniv14

    PrestaShop Addict

  • Members
  • PipPipPip
  • 733 posts

Posted 03 May 2013 - 09:47 PM

But please enable your shop so I can take a look.

Alain Costea

    PrestaShop Apprentice

  • Members
  • PipPip
  • 170 posts

Posted 03 May 2013 - 11:04 PM

ok, now it is enabled.

You can look at the default images to see the blur I was talking about..

(don't look at the new object, because they are little haotic...i have little problems to center the colorize module, and to establish some good looking diemensions)

I can't stay too much enabled, because, normally on 1 may it should be officially open, and there are many persons, that tries to see what is happening... :)

Anyway, when your done looking, please tell me, so i can disabled again...

thank you.
The real thing is to ask good questions...

yaniv14

    PrestaShop Addict

  • Members
  • PipPipPip
  • 733 posts

Posted 04 May 2013 - 06:48 AM

Ok you can disable your site again.

I didn't see any problem with your site, the blury images (default that come with prestashop) look like that because you are stretching the image.
like in the home page the original image size (for home_default) is 124x124 and you showing it 192x192 so of course it will look blury, if you will make sure all you image will be at least 600x600 than you wont have any problem, as you can see in your own images.
the same thing for the thumbnails & the main product image.

Let me know if I am missing something or.....

Alain Costea

    PrestaShop Apprentice

  • Members
  • PipPip
  • 170 posts

Posted 04 May 2013 - 12:49 PM

Thanks.
Yes, you are right ( and the ones before you), everything is about original image size/bo image settings.

Thank you.
The real thing is to ask good questions...

the hat lady

    PrestaShop Apprentice

  • Members
  • PipPip
  • 138 posts

Posted 05 May 2013 - 10:32 PM

When you load images and even regenerate the shop has to be set to All Shops. Not the individual shop. Then the blurs go away.

the hat lady

    PrestaShop Apprentice

  • Members
  • PipPip
  • 138 posts

Posted 05 May 2013 - 10:35 PM

However an issue with the images I am still having is the small images in back office most do not appear now.
Ben I would love some insight on this.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users