Jump to content

Prestashop 1.7.5.2 install error 12%, when creating database tables


Recommended Posts

Hi,

I have stuck with this error.

I try to install a fresh prestashop 1.7.5.2., but i have 500 server error, when creating database tables, at 12%.

I search on forum but nothing help me to solve this problem.

I try to change the language with english, but nothings change.

I change the FastCGI to CGI but same errors.

 

Server info:

Operating system CentOS Linux 7.6.1810
Perl version 5.016003
Path to Perl /usr/bin/perl
BIND version 9.9
Postfix version 2.10.1
Mail injection command /usr/lib/sendmail -t
Apache version 2.4.6
PHP versions 5.6.40
Webalizer version 2.23-08
Logrotate version 3.8.6
MySQL version 5.5.60-MariaDB
ProFTPD version 1.35
SpamAssassin version 3.4.0
ClamAV version 0.101.2

 

error.thumb.jpg.fc332adba2e3894a93595fd5067ae05c.jpg

 

In Apache error log: 

[Mon Jun 24 18:56:56.684450 2019] [fcgid:warn] [pid 8035] [client 84.232.235.31:59199] mod_fcgid: stderr: PHP Warning:  file_put_contents(/home/.../public_html/perene.ro/var/cache/prod/cacert.pem): failed to open stream: No such file or directory in /home/.../public_html/perene.ro/classes/Tools.php on line 2051, referer: http://perene.ro/
[Mon Jun 24 18:58:47.485615 2019] [fcgid:warn] [pid 8001] (104)Connection reset by peer: [client 84.232.235.31:59263] mod_fcgid: error reading data from FastCGI server, referer: http://perene.ro/install/index.php
[Mon Jun 24 18:58:47.485660 2019] [core:error] [pid 8001] [client 84.232.235.31:59263] End of script output before headers: index.php, referer: http://perene.ro/install/index.php

server-info.jpg

Share this post


Link to post
Share on other sites
  • 4 weeks later...
  • 4 weeks later...
On 7/22/2019 at 8:01 PM, TomSoiree said:

Check CHMOD in var/cache/prod

I encounter exact the same problem but checking the CHMOD didn't do anything (I run on ea apache php72)

Would be good if Prestashop would supply a list with the exact PHP configuration needed. Since there are dozens of PHP packages available and each version applied throws some different error, it's a MAZE run to install Preastashop.

Installed OpenCart yesterday and was done within 5 minutes.

Prestashop caused me to waste an entire day together with my server guys, trying to figure out what the heck is missing.

 

Edited by renegades (see edit history)

Share this post


Link to post
Share on other sites
  • 1 year later...

Had the same problem with server's error log "mod_fcgid: read timeout from pipe".

Google led me to "https://stackoverflow.com/questions/7199440/fread-timeout-with-mod-fcgid-read-timeout-from-pipe".

The recommended fix did work for me without further investigation of these timeouts...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More