Jump to content
Caio Ferreira

Cadastro de Clientes - Lento Demais (jogando a toalha)

Recommended Posts

Senhores,

Boa tarde, desculpem mais uma vez incomodar, estou a ponto de jogar a toalha.

Não sou desenvolvedor, apesar de já ter sido programador de tecnologias desktop. 

Montei e consegui manter uma loja para o negócio de minha esposa, tudo vinha andando bem, nada foi atualizado nem alterado, porém de uns tempos para cá, estou com o seguinte problema.

--- O site esta com a navegação normal, mas quando é adicionado um item ao carrinho, e o cliente tenta criar sua conta para comprar, algumas (muitas) vezes, porém não todas, fica extremamente lento, levando até mais de 2 minutos na tela de cadastro dos dados do cliente e endereço, já tentei deixar o checkout com 5 passos e com 1 passo, mas acontece nas duas oportunidades, já tentei debugar e não peguei nada de errado .... isso vem me criando alguns sérios problemas, de pessoas tentando comprar e nos informando que não conseguiram devido a esta lentidão ... vale lembrar que ao passar desta tela o site volta ao normal .... ou seja, a lentidão esta apenas no momento de cadastrar o usuário, mas já é  suficiente para espantar quem quer comprar ... estou próximo de jogar a toalha mesmo do Prestashop, apesar de ter gostado bastante ... alguém teria alguma dica que eu possa tentar para solucionar este problema??? abaixo segue os dados, qualquer ajuda é muito bem vinda. Obrigado.

SITE: https://www.mimoslab.com.br

Versão: 1.6.1.23  (ficamos nesta versão pois ao criar o site tivemos problemas no modulo dos correios)

OBS: o servidor esta todo configurado certinho (HOSTGATOR), e eles informam que não viram nada que justifique a lentidão, apenas em alguns momentos picos de uso do servidor.

 

Mais uma vez, obrigado senhores.

 

 

Share this post


Link to post
Share on other sites

O ideal é ativar o "modo debug" e o "debug profiling" para saber exatamente o que está dando problema.

Provavelmente é algum dos módulos que você instalou que pode ser incompatível com a versão do PrestaShop.
Ou ainda o servidor mal-configurado. A Hostgator é um dos servidores "muito ruins", especialmente se for um compartilhado.

 

Share this post


Link to post
Share on other sites

Daniel,

Vi que você entrou e criou um usuário de testes, antes disto eu havia removido um módulo e feito alguns teste, nos meus teste havia ficado melhor.

Você teve dificuldades no seu cadastro ?

Dei uma analisada com o debug profiling depois de sua sugestão, não tem nada e nenhum módulo que apresente um tempo alto. ..... agora pela manhã fiz alguns teste satisfatórios, mas como disse anteriormente o erro se manifesta aleatoriamente, vou continuar testando hoje para verificar se era o módulo mesmo.

Mais uma vez obrigado, e qualquer dica é sempre bem vinda.

Abs,

Caio Ferreira

 

Share this post


Link to post
Share on other sites
On 6/22/2019 at 12:24 PM, Caio Ferreira said:

Você teve dificuldades no seu cadastro ?

Não. Correu normal.

Dei uma analisada com o debug profiling depois de sua sugestão, não tem nada e nenhum módulo que apresente um tempo alto. ..... agora pela manhã fiz alguns teste satisfatórios, mas como disse anteriormente o erro se manifesta aleatoriamente, vou continuar testando hoje para verificar se era o módulo mesmo.

 

A ideia é essa. Debugar quando o problema ocorrer.
 

Boa sorte!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More