Jump to content
Sign in to follow this  
GeneralComputer

Errore importazione CSV

Recommended Posts

Buonasera a tutti!

Sto impazzendo da praticamente tutto il giorno per cercare di capire come mai prestashop mi restituisce un errore non ben definito al momento di importare nel catalogo i miei prodotti tramite CSV.

L'unica cosa che mi dice è " Errori riscontrati: error". Nient'altro!

Ho provato  a togliere tutto il non essenziale dal csv, ma niente! Non capisco come risolvere...

Idee?

Share this post


Link to post
Share on other sites

Se è corretta la compilazione potrebbe essere un problema legato a caratteri non convenzionali, prova prima dell'import a convertire il file in utf8 utilizzando note++. Controlla anche il titolo dei prodotti che non contenga caratteri vietati (sono indicati sul backoffice di fianco al campo titolo del prodotto)

 

Share this post


Link to post
Share on other sites

Sto facendo tutte le prove possibili, a forza di scremare ho trovato che questa stringa "Campo di rilevamento:10 m a 15  per H installazioni = 2.2-2.5 m" mi crea l'errore...

Non capisco per quale motivo...

 

Trovato! E' il carattere "=", grazie per l'aiuto!

Edited by GeneralComputer (see edit history)

Share this post


Link to post
Share on other sites

No, niente, tolgo i caratteri e fin qui tutto bene... Quando dico di importare anche le immagini, dopo un po' va in errore...

Provo a caricare 100 prodotti alla volta, vediamo che succede...

 

Ho anche controllato inserendo un prodotto. Tutt ok per quanto riguarda anche la tabella delle caratteristiche, invece se inserisco tipo 300 prodotti, si sballa tutto, compresa la tabella delle caratteristiche...

 

Boh!

Share this post


Link to post
Share on other sites

Niente, quando inserisco i link delle immagini, inizia e ad un certo punto si ferma, anche se metto 10 prodotti nel csv.

Con due prodotti non dà errore... Ho provato a scremare i prodotti per vedere se fosse un problema di una determinata voce ma niente, semplicemente lo fa quando ci sono più di 20 prodotti in lista con i link alle immagini...


Le immagini sono nello stesso server, ho fatto l'upload tramite ftp..

Se attivo il debug mode, mi esce questo log:

User Deprecated: The "prestashop.core.import.dir" service is private, getting it from the container is deprecated since Symfony 3.2 and will fail in 4.0. You should either make the service public, or stop using the container directly and use dependency injection instead.

Ed anche questo:

User Deprecated: The "prestashop.core.import.file_finder" service is private, getting it from the container is deprecated since Symfony 3.2 and will fail in 4.0. You should either make the service public, or stop using the container directly and use dependency injection instead.

Anche questo:

Translation not found.

[
  "id" => "Categorie"
  "domain" => "AdminShopparametersFeature"
  "locale" => "it-IT"
]

 

Non so come fare, inserire tutti i prodotti senza le immagini non mi serve a niente...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More