Jump to content
Sign in to follow this  
Orishas

Lors de l'install

Recommended Posts

Bonjour à tous,

J'ai déjà installé une fois la version 1.0.
J'ai essayé la version 1.1 et j'avais eu un soucis lors de l'install, j'avais ce message

L'option PHP "register global" est désactivée (recommandé)

Je pensais qu'il s'agissait d'un message car c'est une version BETA
Mais quand j'ai réinstallé la version 1.0 pour essai de nouveau, le message est apparut aussi, donc rien a voir avec la version.
Quelqu'un peut-il me dire de quoi il s'agit? Où dois-je activer ce register global ?
Et quelle sont les conséquences si celle-ci n'est pas activée?

D'avance merci ;-)

3106_4mXfhTFxN3vupirXq1Jv_t

Share this post


Link to post
Share on other sites

L'optiion register global s'active (ou se désactive) dans le fichier PHP.INI du serveur (donc il faut y avoir accès).
Si tu loue un hebergement tu n'y aura malheureusement pas accés sauf chez OVH qui autorise cette configuration depuis le .htaccess (d'autre le font peut etre aussi, mais je ne sais pas)

Cette option permet lorsqu'elle est a on permet de transferer facilement les variable PHP d'une page à l'autre du site le fait de la désactiver améliore la sécurité !

Share this post


Link to post
Share on other sites

ok, merci, je suis chez PHPNET et je n'ai pas accès à ça je pense.
Donc, si elle est désactivée, c'est mieux niveau sécurité alors...

Gracias, je pensais que j'allais avoir des soucis ;-)

Share this post


Link to post
Share on other sites

Certains hébergeurs (PHPNux) permettent également de la désactiver depuis le panneau d'administration.

D'une manière générale, on considère aujourd'hui que register globals doit toujours être à "Off". D'ailleurs je crois que PHP6 ne permettra plus de la mettre à "On".

Share this post


Link to post
Share on other sites

Hum... Orishas... Le message de l'install t'indique qu'en fait elle est activée (car "register global est désactivée" est en rouge).

Quand elle est désactivée, la ligne est en vert...

Share this post


Link to post
Share on other sites

Pffff oui effectivement...
Je n'ai fais que "lire" et non regardé la couleur.
Ai pas cette logique encore :-P
Donc... peut rien faire moi :-(

Share this post


Link to post
Share on other sites

Chercher sur le Net ou demander à ton hébergeur comment modifier l'état de cette variable.

Share this post


Link to post
Share on other sites

Normalement, tu dois pouvoir regler cela avec le .htaccess
Peut etre en mettant php_value register_globals "0" dedans.

Share this post


Link to post
Share on other sites
Normalement, tu dois pouvoir regler cela avec le .htaccess
Peut etre en mettant php_value register_globals "0" dedans.


Je ne vosi pas comment faire cela dans ce fichier, la ligne n'existe pas et j'ai peur que la syntaxe soit mauvaise.
Vais regarder sur le net en attendant que l'hébergeur réponde à ma question.

Encore merci ;-)

Share this post


Link to post
Share on other sites

Le fait de renommer que ce soit .htaccess ou htaccess.fi, ne change rien à mon affaire.
Toujours en rouge.

Je continue mes investigations car chez Phpnet, mes bases sont bien en php5 et les explications sont pour passer du 4 au 5

Share this post


Link to post
Share on other sites

J'étais justement dessus mais pas dans la même rubrique.
J'y arrivais tout doucement à trouver des infos sur le forum de PHPNET.

Merci beaucoup, je vais essayé ça.

Share this post


Link to post
Share on other sites

Quand je renomme le fichier en .fi comme c'est demandé. ou même en .htaccess
Je n'ai plus rien pfff
Si le laisse en .txt, c'est toujours la même chose.

Pourtant j'ai bien ajouté la ligne qu'ils conseillent.

3116_HMvcrO5iCIIC1bKokb1a_t

Share this post


Link to post
Share on other sites

Via la console d'administration de chez phpnet, il y a moyen de changer le register global et le désactiver.
Voilà qui est fait.
J'ai juste encore une question...
Vu que dans les changements seront pris en compte le lendemain.
Dois-je attendre que les changements soient effectifs (demain) pour installer PS ou je peux l'installer? et demain tout rentrera en ordre lors de la mise à jour du RG?

Merci ;-)

Share this post


Link to post
Share on other sites

Tu peux l'installer aujourd'hui, ça ne devrait pas poser de problème.

Share this post


Link to post
Share on other sites

Encore une question.
Hier, j'ai installé et tout ok.
Aujourd'hui, je me connecte et.... probl avec l'apparence
J'avais la black diamond, le fond est blanc normalement (hier) aujourd'hui, noir sur noir, on ne vois rien.
J'ai remis le theme par défaut PS, et le footer n'est plus en bas, mais dans la colonne de droite.
Y-a-t-il un rapport entre le fait d'avoir changé le register global?
Vu que le changement se faisait aujourd'hui...

Gracias ;-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More