Jump to content
PDH

Problem with products with combinations

Recommended Posts

Hello, 

I install prestashop version 1.7.3 and add new products. The products have a lot of combinations. I see the combinations on my product page (see screenshot) 

When i update a product with combinations, then we get a problem. I see nog longer the products on the backoffice. (see screenshot), 

The product is not longer working on the backoffice. 

Can maybe somebody help me with this problem? 

Thanks for helping. 

Schermafbeelding 2018-03-29 om 12.36.17.png

Schermafbeelding 2018-03-29 om 12.38.02.png

Share this post


Link to post
Share on other sites

No, i have the  Look my new screenshots. 

 

I see the combinations not on the backoffice of the products. that is the problem

I see only the combinations on my stock page. and the products have a quantity of 100.5abcd8b88ea33_Schermafbeelding2018-03-29om14_14_04.thumb.png.aa183aacabff91e9a5d660ed8f2f2698.png5abcd94f10605_Schermafbeelding2018-03-29om14_15_12.thumb.png.a01b0e254bd6a37cf0b760d5e6928edb.png

 

Share this post


Link to post
Share on other sites
23 minutes ago, PDH said:

I have make this video of the problem. 

Products.mov

try change feature name. A simple name without "," or other symbols, maybe it help. Might be some errors when saving due long names with symbols

Share this post


Link to post
Share on other sites

Hmmmm thanks for helping, i test it and i have the same problem. 

I have discovered 

2 combinations it works and i see the combinations on the list

more than 2 combinations it is not longer working. 

Share this post


Link to post
Share on other sites

I have kind of the same problem... doesn't work with combinations and also my old combinations have problems with the latest update 1.7.3. (now i'm 1.7.3.1 but still don't work)

Share this post


Link to post
Share on other sites
On 29/3/2018 at 3:24 PM, PDH said:

Hmmmm thanks for helping, i test it and i have the same problem. 

I have discovered 

2 combinations it works and i see the combinations on the list

more than 2 combinations it is not longer working. 

 

I have the same problem, have you found a solution? 

 

Thanks!

Share this post


Link to post
Share on other sites

Anyone?! Seriously, what is wrong with this platform? Does anyone ever fix anything? I'd be better off using a customised version of Wordpress!...

Share this post


Link to post
Share on other sites

Having the same problems. I can get one set of combinations to show up in the frontend, but if I have a product with 2 or more combinations (ie sizes, color, etc) only the first combination will work. The other one shows up in the front end, but there's nothing in the second combinations field and there's no fields to select.

Wish I knew 1.7.4 was full of bugs before I installed it. Been having nothing but issues after issues and it doesn't even seem like Prestashop is being supported very much nowadays. At least not the newer version.

May have to install 1.6 to get a functional site.

Share this post


Link to post
Share on other sites
1 hour ago, RamboRich said:

Having the same problems. I can get one set of combinations to show up in the frontend, but if I have a product with 2 or more combinations (ie sizes, color, etc) only the first combination will work. The other one shows up in the front end, but there's nothing in the second combinations field and there's no fields to select.

Wish I knew 1.7.4 was full of bugs before I installed it. Been having nothing but issues after issues and it doesn't even seem like Prestashop is being supported very much nowadays. At least not the newer version.

May have to install 1.6 to get a functional site.

You should definitely consider installing 1.6, life is so much easier. Also, you should check out thirtybees. It's a fork of PrestaShop 1.6, but with additional functionality as standard and it works really well. It's also compatible with 99% of PrestaShop 1.6 modules because it's based on 1.6 :) Definitely worth a look if you're looking for a more stable platform.

Share this post


Link to post
Share on other sites

I do have 1.6.x installed on two other websites and had no problems (maybe minor ones) and they are working fine. I figured on this current site, migrating from an old OsCommerce 2.2 site, that i'd try out PS 1.7.4.

Had a lot of issues, but seemed to iron them all out so far in the last 3-4 days, except this one. I'm going to try a couple things first then if it doesn't work, will go to 1.6.x or maybe an other storefront altogether as it doesn't seem like PS is keeping up to date with bugs, answering questions, etc. I see alot of questions in the forums that haven't been answered in over a year or more.

I really need to get combinations working and it is... for the first set of attributes but not if you add a second set or third set, etc..

I know 1.7 is newer, but it has been out a while. If anything, why release it if not ready?

Edited by RamboRich (see edit history)

Share this post


Link to post
Share on other sites

Good Lord, I think I solved the problems.

When generating combinations, you can generate, say 4 combinations of color (generate) then say you have 2 different sizes then generate the two sizes afterwards... it won't work that way.

You have to generate all the combinations in one shot. In other words, if you add a separate series of attribute combinations after you already have another set generated, it will give you a blank field box for all the combinations after the first (default) one.

If you do them all at one time (ie color, then red, blue, black) and then select sizes (large, medium) and then hit the generate button, it will work.

 

If I remember correctly, 1.6 didn't operate this way. But anyways, that was the fix for me.

  • Thanks 2

Share this post


Link to post
Share on other sites
Posted (edited)

Hi everyone,

I used before 1.6 with combinations and believe that it was difficult to manage. I thought that 1.7 will improve the management of combinations, but besides combinations from 1.6, here the combinations are nightmare. I have the following situation: Added a new product on which i wanted to show only colors, i selected all the colors to add in combinations but PS added an imaginary size on the combination, a size that i never selected; moreover, i added a size, thinking that it is not working colors without size, added the size in combination with all colors, pressed Generate and surprise - PS added combinations formed from my size, the imaginary size and each color - real NIGHTMARE!!

Dear PS team, i asked this in 1.6 and probably there was many others that asked this: SOMETIMES, THE COMBINATIONS ARE USELESS, NEED TO DISPLAY IN PRODUCT PAGE ONLY THE ATTRIBUTE COLOR, OR ONLY THE ATTRIBUTE SIZE, OR BOTH BUT WITHOUT COMBINATIONS...WHY TO BE MANDATORY TO ADD COMBINATIONS??? WHEN THIS NIGHTMARE WILL BE SOLVED???

Edited by leozao (see edit history)

Share this post


Link to post
Share on other sites
Guest stelly
Posted (edited)
On 3/29/2018 at 3:24 PM, PDH said:

Hmmmm thanks for helping, i test it and i have the same problem. 

I have discovered 

2 combinations it works and i see the combinations on the list

more than 2 combinations it is not longer working. 

i have exact the same problem.

can PLEASE someone help me??

It works with Chrome, but NOT with Safari!

Edited by stelly (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More