Jump to content

Deconnection Intempestive du backoffice prestashop 1.7 chez 1and1 internet


Recommended Posts

Mon backoffice se deconnecte à chaque fois, je n arrive pas à ajouter des produits ni changer s=certains parametres, j'ai essayer de desactiver l'option verification de l'adresse ip du cookie je n'y arrive pas car quand je change l'etat du bouton et j'appuye sur le bouton enregistrer je suis deconnecté et du coup je reviens au meme point donc nulle part.

pouvez vous m'aider à contourner cette difficulter svp

merci

Share this post


Link to post
Share on other sites

  • 1 month later...
  • 2 weeks later...

Bonjour,

Merci pour la piste de la table ps_configuration. Dans mon cas (PS 1.7.2.4 hébergé chez Yulpa.io) elle n'a pas fonctionné.

Au passage, avec PS 1.7.2.4, pour mettre la valeur PS_COOKIE_CHECKIP à 0 il est aussi possible de passer par : Tableau de bord > Paramètres avancés > Administration > Paramètres généraux > Vérifier l'adresse IP du cookie = NON

Du coup j'ai remis tous les paramètres d'origine Vérifier l'adresse IP du cookie = OUI et Durée de vie du cookie front-office et back office = 480 (heures).

Puis j'ai fini par cliquer sur le bouton "Rester connecté" au moment du login sur /admin###, et depuis, plus de déconnexion intempestive :)

 

 
 

Share this post


Link to post
Share on other sites

  • 7 months later...
  • 1 year later...
Le 20/02/2018 à 5:02 PM, emmah a dit :

J'avais  également le même problème. 

Cette solution semble fonctionner.

"Allez dans la table ps_configuration, mettez la valeur PS_COOKIE_CHECKIP à 0 et reconnectez-vous."

 

Merci, ça a fonctionné pour moi

Share this post


Link to post
Share on other sites

  • 7 months later...

Bonjour moi aussi ca me déconnecte tout le temps depuis plusieurs jours, je n'arrive pas à mettre de nouveau produit et j'ai même du mal a voir mes commandes ou mes paniers.

Je n'arrive meme pas a aller dans administration pour mettre le cookie a 0.

Je suis chez one and one et j'ai la version Prestashop 1.7.6.1

Merci d'avance de votre réponse.

 

Share this post


Link to post
Share on other sites

Bonjour,

vous êtes chez ionos donc le seul hébergeur de la planète à vendre des hébergement illimité mais limités en nombre de fichiers donc vous devez vous rendre dans votre espace client chez ionos pour savoir si vous n'avez pas atteins le quota limite de fichiers qui vous empêche alors un fonctionnent normal de votre site.

Seul moyen : Changer pour un vrai hébergeur respectueux de ses clients comme le sont des services comme O2Switch et PlanetHoster.

Edited by Mediacom87 (see edit history)

Share this post


Link to post
Share on other sites

  • 4 weeks later...
  • 1 month later...

Bonjour 🤝 , pour mon cas j'ai aussi le même problème, je suis sur la version prestashop 1.7.6.7; 

après mes testes et j'ai constaté que si je change le fournisseur d'accès internet directement TOUS PASSE CORRECTEMENT et si je rentre à ce même fournisseur d'accès internet le problème recommence.
Pour ceux qui ont le même problème essayer d'abord de changer le fournisseur d'accès internet et regarder si ça passe.

Share this post


Link to post
Share on other sites

  • 5 months later...

Bonjour,

Effectivement j'ai le même cas de figure : 

  • Déconnexion à chaque fois que j'essaie de cliquer sur un lien du menu de gauche (côté back).

J'ai du :

  • Aller en db
  • Table ps_configuration
  • Et changer PS_COOKIE_CHECKIP=1 en PS_COOKIE_CHECKIP=0

Note :

  • PrestaShop 1.7.7.1
  • Hébergeur : ionos
  • PHP 7.4

Etrange qu'il faille changer cette valeur pour que le back-office de PrestaShop fonctionne 🤔
Savez-vous pourquoi il faut désactiver cette option (permettant de vérifier l'adresse ip du cookie afin d'éviter que votre cookie soit volé) ?

Edited by eewee (see edit history)

Share this post


Link to post
Share on other sites

6 minutes ago, elvis fressard said:

Bonjour il faut aller ou pour faire le changement, je suis debutante désolé 

"Aller en db

Table ps_configuration

Et changer PS_COOKIE_CHECKIP=1 en PS_COOKIE_CHECKIP=0"

Bonjour @elvis fressard,

Il faut que tu te connectes sur ton PMA (=PHPMyAdmin).
Il s'agit de l'outil proposé par ton hébergeur souvent, pour disposer d'une interface graphique pour consulter ta base de donnée.
Puis choisir la table nommée ps_configuration (ps étant le préfixe de tes tables, qui peut être différent chez toi).
Et trouver la colonne nommée name avec la valeur PS_COOKIE_CHECKIP et change sa colonne value=1 par value=0.

Sinon si tu n'es pas déconnecté de suite tu peux essayer d'aller ici : 

  • Advanced Paramenters -> Administration -> Général (Prestashop 1.7) -> Vérifier l'adresse IP du cookie -> NON.
Edited by eewee (see edit history)

Share this post


Link to post
Share on other sites

18 minutes ago, Mediacom87 said:

826420977_tableaucompatibilitephp1.6.1.x-1.7.8.jpg.afdcdd4d9c6adc2985a062e7a82611bd.jpg

Je viens de changer la version PHP (de 7.4 vers 7.3.27)
PS_COOKIE_CHECKIP basculé de nouveau sur value=1
= j'ai toujours le même cas de figure (déconnexion à chaque clique sur un lien du menu de gauche) 😢

Share this post


Link to post
Share on other sites

Bonjour je rencontre la même erreur j'ai un PrestaShop  1.7.6.8 mon BackOffice ne cesse de se déconnecter quand je clique sur un bouton du BO , cela me redirige automatiquement vers la page de connexion j'ai appliquer les changements dans la BDD mais cela ne résous pas mon problème, pouvez-vous m'aider svp c'est assez urgent 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More