Jump to content
Soliloquy

Installed new template, but when I try to enable it I get a blank page

Recommended Posts

When I try to enable a new template (by clicking on "Use This Template") the resulting page, which should be asking about modules to disable/enable, is blank. The template isn't changed in the front office either.

I tried reverting to the default template and then installing it, but still got the blank page. Every other template I try works properly. And I made sure that the new template is for the version of PrestaShop that I'm using.

Share this post


Link to post
Share on other sites

I enabled debugging mode and got this error:

Fatal error: Cannot redeclare class BlogCategory in /home/…/public_html/test/modules/smartblog/classes/BlogCategory.php on line 149

 

I'm running PrestaShop 1.6.1.6. I installed the template by uploading the zip file for it on the "Add New Theme" page. Pretty sure this isn't a compatibility problem because the site I bought it from says it's compatible up to 1.6.1.x, although they didn't specifically say 1.6.1.6.

Thanks for your help!

Share this post


Link to post
Share on other sites

I went to the Modules and Services page to see if I could fix this by disabling the blog, but got this error on the page where I usually get the list of modules:

 

Fatal error: Cannot redeclare class BlogCategory in /home/.../public_html/test/modules/smartblog/classes/BlogCategory.php on line 149
[PrestaShop] Fatal error in module file :/home/.../public_html/test/modules/smartblog/classes/BlogCategory.php:
Cannot redeclare class BlogCategory

.

Share this post


Link to post
Share on other sites

OK,  so Ithink you installed smartblog on default theme but also new theme you are trying to enable have 

same module. Maybe renamed or similar blog module that use same named BlogCategory.php class.

 

Try this, find out what is that blog module that comes with new theme. Find it in root modules folder and 

rename it ( just add _ in front of name). Then try to activate new theme again. This way you should be able to keep

post you already have. Other way to rename smartblog to _smartblog  and install blog module that comes with new 

them is also possible solution but question is what will happened with your current posts.

 

Try it out and good luck.

Share this post


Link to post
Share on other sites

Success! I renamed the module directories as instructed, and was able to enable the new template. It is displaying, but I'm getting a number of error messages that say:

Notice: Undefined offset: 0 in /home/.../public_html/test/override/classes/Link.php on line 103

Do I need to do anything about this, or just turn off debugging mode?

Edited by Soliloquy (see edit history)

Share this post


Link to post
Share on other sites

Glad to hear :)

 

Those are notices and if you notice some issues in front office that should be fixed.

But if not you can disregard them.

 

And yes it is displaying because of debug mode, that should be disabled now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More