Jump to content
nmtoro

SOLUCIONADO Los precios aparecen sin iva en algunos ordenadores.

Recommended Posts

Buenas tardes, he tenido un problema con un cliente en mi web artesaniacordobesa.com y es que resulta que un cliente entra en la web y ve los precios sin IVA, luego cuando va a comprar si aparecen con IVA. No se por que puede ser debido esto, por si alguno tiene alguna idea de por que puede ser. Gracias y un saludo a todos.

Edited by nmtoro (see edit history)

Share this post


Link to post
Share on other sites

Buenas tardes, he tenido un problema con un cliente en mi web artesaniacordobesa.com y es que resulta que un cliente entra en la web y ve los precios sin IVA, luego cuando va a comprar si aparecen con IVA. No se por que puede ser debido esto, por si alguno tiene alguna idea de por que puede ser. Gracias y un saludo a todos.

¿En los impuestos (Localización -> Reglas de tasas/Impuestos) tienes bien configurada la regla para  los paises?

 

¿Tienes activada la geocalización en Preferencias -> Geolocalización?

 

Versión exacta de Prestashop que usas en tu tienda.

 

Yo este producto de tu tienda: http://www.artesaniacordobesa.com/es/home/196-cordoban-de-la-ciudad-de-cordoba.html lo veo a 215 Euros ¿Este precio es con u sin impuestos?

Share this post


Link to post
Share on other sites

Buenos dias Victor, la configuracion de IVA la tengo bien, el precio que me dices es con IVA, y asi aparece el la web, por lo menos en mi navegador, tengo activada la geolocalizacion y la version es la PrestaShop™ 1.5.6.2, por casualidad he limpiado la cache y el cliente le salen ya bien los precios, no se si eso tiene algo que ver, pero este cliente en particular ya ve los precios con IVA. No se si habrá sido algo puntual, pero si tu ves bien los precios deberia de haber fucionado.

Si se os ocurre por que haya podido ser agradeceria me lo dijeseis, si no lo doy por zanjado el tema.

Muchas gracias Victor, yo son varias las que me has ayudado, esta y otras ayudando a otros. Reitero mi agradecimiento.

Share this post


Link to post
Share on other sites

Revisa tambien la configuracion de los grupos de clientes. Ahí tienes la opciones de poner que los precios esos clientes lo vean con iva o sin iva

Share this post


Link to post
Share on other sites

Me cuelo para molestar  :lol: XD

 

En este caso no creo que sea problema de la configuración de grupos, porque si en unos equipos estando sin logearte te aparece el precio mal y en otros ordenadores tambien sin logearte si te aparecen los precios con IVA, a lo mejor es algun bug de tu versión.

 

¿Esos determinados usuarios que estan entrando en tu tienda (comentan que no son todos, que eso es lo extraño), si desactivas la geocalización, has comprobado si le aparecen bien los precios ?

 

A mi tambien me aparece el precio que te ha dicho Nadie en tu web, y entiendo que dices que ese es con IVA incluido y que eso es correcto ¿no?

 

Si que me suena que hace muchos, muchos años por el foro algun caso parecido y estaba relacionado con algun conflicto de la cache, pero vete a saber donde estan ahora esos temas con todo lo que ha llovido.

Edited by Sergio Ruiz (see edit history)

Share this post


Link to post
Share on other sites

Hola:

 

Supongo que puede ser una tontería pero me ocurrió algo similar cuando veía la web desde el móvil y era el navegador que utilizaba, en aquél caso una versión de Opera. Sólo me ocurría en el móvil con lo que al cambiar el navegador se solucionó. No digo que sea el caso pero a lo mejor podría tener algo que ver.

 

Saludos

papuki

Share this post


Link to post
Share on other sites

Muchas gracias a todos por la ayuda, como comente anteriormente creo que se trataba de algo del navegador, pero he probado con otros equipos con el mismo navegador y no tenia problema alguno, lo que hice fue limpiar la cache, asi me comenta el cliente que ya ve bien los precios con el iva incluido, todo lo que me comentasteis lo mire y lo tenia correcto. Asi que creo que la solucion fue limpiar la cache. Reitero mi agradecimiento y doy por cerrado el tema, o eso espero.

Share this post


Link to post
Share on other sites

Muchas gracias a todos por la ayuda, como comente anteriormente creo que se trataba de algo del navegador, pero he probado con otros equipos con el mismo navegador y no tenia problema alguno, lo que hice fue limpiar la cache, asi me comenta el cliente que ya ve bien los precios con el iva incluido, todo lo que me comentasteis lo mire y lo tenia correcto. Asi que creo que la solucion fue limpiar la cache. Reitero mi agradecimiento y doy por cerrado el tema, o eso espero.

Me alegro de que hayas podido solucionar la incidencia, no se te olvide añadir la palabra "Solucionado": https://www.prestashop.com/forums/topic/269515-solucionado-%C2%BFcomo-poner-la-palabra-solucionado-en-el-titulo-del-tema/ al titulo del tema,

 

Saludos,

Share this post


Link to post
Share on other sites

Tengo el mismo problema que comentabais antes. En algunos ordenadores me aparecen los precios con I.V.A y en otros los precios sin I.V.A. Tengo la geolocalización por I.P. desactivada. Tengo todos los grupos de clientes con impuestos incluídos. He vaciado la caché y el problema persiste. ¿Alguna otra pista? Por daros un ejemplo

 

http://topaztopaz.com/manualidades/2654-cera-patinar-500-ml-cerezo-3302150036357.html

 

El precio incorrecto sin I.V.A es de 7,40 euros

 

El precio correcto con I.V.A. es de 8,95 euros

 

A algunos clientes les pasa lo mismo. El I.V.A. les aparece al final del proceso cuando van a pagar y me dicen que les he engañado con el precio.

 

Un saludo

post-1224235-0-26302400-1495225871_thumb.jpg

post-1224235-0-00223000-1495225873_thumb.jpg

Share this post


Link to post
Share on other sites

A mi me pasa lo mismo, algunos clientes ven el precio con Iva y otros sin IVA, si me meto en navegación de incognito lo veo con IVA, es un problema de las cookies que a mi empresa le esta afectando bastante, pero no logro entender el origen del fallo, entiendo que es un conflicto de cache.

Si alguien sabe algo sería ideal que hicieran algún aporte o un enlace donde resuelvan este problema.

 

Gracias, un saludo.

Share this post


Link to post
Share on other sites

Hola a todos, 

La solución de este problema para prestashop 1.7.X

Se que este tema lo habéis  cerrado pero nada de lo que se menciona aquí pudo resolver mi problema. Básicamente es lo mismo que mencionais “Prestashop mostraba producto sin IVA según el dispositivo o país de donde se consultaba la tienda”.

Mi solución en particular tiene que ver con el módulo de geolocalización. Dicho módulo debe tener estas preferencias para evitar este problema: http://doc.prestashop.com/pages/viewpage.action?pageId=29655275&_ga=2.251508549.2136120206.1573214461-822544563.1561979908

Esta ha sido la solución para mi caso después de probar de todo. Espero os ayude.

Edited by hobnil
error en texto (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More