Jump to content
nordlittoral

Erreur "Jeton (token) invalide" en back-office

Recommended Posts

Bonjour,

 

Je viens de créer ma boutique en hébergement chez OVH (j'étais en cloud auparavant).

 

Sans rien modifier dans les réglages du back office, à part avoir débrayé l'option "Améliore la sécurité du front-office"

 

J'ai systèmatiquent l'erreur suivante lors de la création d'un produit, d'une catégorie : "Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité."

 

post-1115954-0-30971500-1485270645_thumb.jpg

 

Avez-vous une idée de la raison ?

 

Merci de votre aide précieuse

 

Ben

Share this post


Link to post
Share on other sites

J'ai exactement le même problème depuis ce matin ...

 

Bonjour Vincent, tu as réussi à résoudre ton problème ?

 

Cdlt

 

Benjamin

Share this post


Link to post
Share on other sites

Bonjour,

 

Oui en ce qui me concerne le problème s'est réglé de lui-même hier après-midi. Depuis tout semble correct je croise les doigts...

 

Cdlt 

Share this post


Link to post
Share on other sites

Bonjour,

 

Oui en ce qui me concerne le problème s'est réglé de lui-même hier après-midi. Depuis tout semble correct je croise les doigts...

 

Cdlt 

 

Ca alors ! La chance. Je vais attendre un peu alors !

Share this post


Link to post
Share on other sites

Salut.

Je m'incruste sur le post.

Nouvelle boutique Presta 1.7 sous OVH et j'ai un bug sur les modules.

"Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité."

Des idées, là je vois pas.

MErci d'avance.

Share this post


Link to post
Share on other sites

Je ne sais pas si cela est la réponse mais en désactivant le SSL sur toute la boutique (General>parametres generaux)  je n'ai plus eu de probleme apres.

Share this post


Link to post
Share on other sites

Le problème vient d'ovh lorsque vous activez le ssl.

Toutes les connexions sont re-routées vers leur serveur proxy qui gère le ssl et tout le monde repart avec la même IP, super non ?

Forcément les vérifications ne fonctionnent plus...

Share this post


Link to post
Share on other sites

Pour ma part c'etait beaucoup plus simple...

La version de php sur mon compte OVH ne correspondait pas à celle indiqué dans le .ovhconfig.

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

Même souci de mon côté.

Impossible d'accéder aux modules installés.

Jeton (token) invalide...

 

Site hébergé en mutualisé chez OVH

PHP 5.4.45

 

J'ai essayé d'activer et de désactiver le SSL

J'ai changé les droits d'écriture FTP

 

Sous l'onglet "Paramètres avancés" / "Log" j'ai le message d'erreur suivant:

Impossible de charger les données depuis Addons. Data from PrestaShop Addons is invalid, and cannot fallback on cache

 

Je ne sais pas si ça a un rapport...

 

Merci pour votre aide

Share this post


Link to post
Share on other sites

Je confirme, je suis passé de php 5.4 à php 5.6, c'est RESOLU !

 

Dans .ovhconfig : 

app.engine=php
app.engine.version=5.6
http.firewall=none
environment=production

 

Merci moiettoi !

Share this post


Link to post
Share on other sites

Le pire, c'est que dans les prérequis de la 1.7, Prestashop annonce php 5.4 !

 

Sinon, avec php 5.5, c'est ok également.

Share this post


Link to post
Share on other sites

Bonjour,

 

Je suis hébergé sur OVH en Prestashop 1.7.0.6

 

Moi aussi j'ai ce problème, ce message "Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité." est récurrent, pour ma part uniquement sur l'onglet produit de mon BO, au bout d'une dizaine de tentative je fini par y accéder mais une fois dans une fiche produit les modifications ne prennent pas et le message "Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité." apparait à nouveau !

 

J'ai vérifié avec OVH ma version PHP, je suis en 7.0 legacy et même sur une version intérieur 5.4, 5.5 ou 5.6 ça ne change rien, SSL ou pas ça ne change rien non plus !

 

Quoi faire ? quelqu'un a t'il une idée ?

 

Merci d'avance.

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

 

Pensez à votre version de PHP.

La 5.4 pose problème. Par contre ceux qui ont migré en 5.5 ou 5.6 n'ont plus eu ce problème (j'en fais partie)

 

Bon courage

Denis

Share this post


Link to post
Share on other sites

sauf d.vy ... je n'avais pas vu ton commentaire. 

Avez-vous essayé la 1.7.1.1 pour ceux qui sont en PHP 5.5, 5.6 ou 7 avec encore des problèmes ?

Share this post


Link to post
Share on other sites

D’après vous, est ce que le "Module 1-Click Upgrade" est bien adapté pour une mise à jour 1.7.0.6 vers 1.7.1.1 ?

Je ne me sent pas apte à faire cette mise à jour manuellement !

Share this post


Link to post
Share on other sites

Je l'ai fait à deux reprises, de 1.7.0.6 à 1.7.1.0 et enfin 1.7.1.1 sans problème !

Pour une fois que ça marche :)

Share this post


Link to post
Share on other sites

Wah, super, je vais testé ça ce soir alors, je vous direz ce qu'il en sera ensuite.

 

merci pour le témoignage !

Share this post


Link to post
Share on other sites

Bonjour,

J'ai exactement le même soucis. Je l'ai eu au début sur un modification produit et là c'est pour accéder à la page de mes modules. Je ne sais pas si c'est avec ce soucis, mais en essayant d'accéder à mon site j'ai eu ce message " Link to database cannot be established: SQLSTATE[HY000] [2002] Connection refused ".

Donc actuellement j'ai " 
Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité. " en version 1.7.0.6 et en php 7.0.15

Share this post


Link to post
Share on other sites

j'avais également eu ce même genre de problème pour accéder aux modules et j'avais réglé le problème simplement en vidant le cache dans l'onglet :

"paramètres avancés" - "performance"- puis en haut à droite "vider le cache"

  • Like 1

Share this post


Link to post
Share on other sites

Petite piste ...

quand vous avec ce message Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité. " 

--> vous enlevez dans l'url la partie après index.php puis faites entrée. Vous repartez alors de zéro pour le token.  

Share this post


Link to post
Share on other sites

j'avais également eu ce même genre de problème pour accéder aux modules et j'avais réglé le problème simplement en vidant le cache dans l'onglet :

"paramètres avancés" - "performance"- puis en haut à droite "vider le cache"

Je crois que le soucis c'est résolu pour moi. Du moins pour le moment..

Share this post


Link to post
Share on other sites

Salut,

 

PHP 7.0.19

Prestashop 1.7.1.1

et toujours ce problème de token, la boutique est en ssl sur cloudways (hébergement digitalocean)

 

Merci,

Share this post


Link to post
Share on other sites

Bonjour,

Php 7 et en vidant  le cache sans aucun module ajouté toujours le problème .

Je suis en presta  1.7.4 une instal toutes fraîche je pensais vraiment que ce problème était résolue avec les mise à jours ...

Une solution à était trouvé ? 

Share this post


Link to post
Share on other sites

La 1.7 n'a rien résolu de ce côté, au contraire (pour info, le cœur de la 1.7 c'est une 1.6.0.10^^)

Le token invalide provient soit de l'hébergement (Souci d'ip), soit du js et dans le cas où un module hooké en backofficeheader aurait une variable également nommée "token".

Sachant que la dernière lue est celle prise en compte.

Pour éviter le problème OVH/ hébergement, commencez par désactiver le controle de l'ip dans le contexte.

Ensuite le token est toujours construit de la même manière: $this->token = Tools::getAdminToken($this->controller_name.(int)$this->id.(int)$this->context->employee->id);

la fonction de Tools ne faisant qu'un simple encrypt des données ci-dessus.

Donc si le token est invalide c'est soit que le context->employee a été réinitialisé (pb de cookie ou ip), soit qu'un autre script (hors core) l'a modifié.

Edited by Eolia (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

Merci Eolia pour cette réponse .

Je pense plus pour un js car je suis tombé sur ce poste de github mais je ni comprend aps grand chose .... :

https://github.com/PrestaShop/welcome/pull/32

Quand pense tu ?

Comment désactiver le contrôle de l'ip dans le contexte. pour éviter le problème OVH/hébergement ?

Merci pour ton aide.

 

Share this post


Link to post
Share on other sites

image.png.e283984ed941d99ccebfb325f451f7fd.png

 

Mais vous êtes en 1.7 ?  Si c'est le cas, je ne peux rien pour vous :( 

Share this post


Link to post
Share on other sites

C'est de la pure curiosité mais @Eolia, tu ne travailles pas du tout avec Prestashop 1.7 ?

Share this post


Link to post
Share on other sites

Pourquoi perdre mon temps sur un projet bancal ?

Share this post


Link to post
Share on other sites

Il me semblait aussi que la version 1.7 était pas super au point...

Ca me rassure quelque part ! :-)

Share this post


Link to post
Share on other sites

Apparemment la version 1.6 ne sera plu suivie fin 2018 soit dans  moins de  3 mois .

Je trouve tout de même  étonnant que la version 1.7 ne soit pas plus utilisé et plus poussé d'un point de vue développement.

Il y à des boutique en production sous  1.7?

 

Share this post


Link to post
Share on other sites

Plus suivie ne veut pas dire plus fonctionnelle, au contraire.

Les modules et thèmes sont toujours écrits pour cette version et les 250 000 boutiques qui tournent dessus ne vont pas se transformer en citrouille le 31 décembre à minuit^^

Share this post


Link to post
Share on other sites

bonjour une personne a trouvé la solution au problème ? merci a vous 

Share this post


Link to post
Share on other sites

Bonjour à tous,

j'ai exactement le même problème.

Hébergeur OVH en mutualisé. En pièce jointe la config Prestashop en mode debug. 

Merci de votre aide.

config_prestashop.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More