Jump to content

Erreur "Jeton (token) invalide" en back-office


Recommended Posts

Bonjour,

 

Je viens de créer ma boutique en hébergement chez OVH (j'étais en cloud auparavant).

 

Sans rien modifier dans les réglages du back office, à part avoir débrayé l'option "Améliore la sécurité du front-office"

 

J'ai systèmatiquent l'erreur suivante lors de la création d'un produit, d'une catégorie : "Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité."

 

post-1115954-0-30971500-1485270645_thumb.jpg

 

Avez-vous une idée de la raison ?

 

Merci de votre aide précieuse

 

Ben

Share this post


Link to post
Share on other sites

Salut.

Je m'incruste sur le post.

Nouvelle boutique Presta 1.7 sous OVH et j'ai un bug sur les modules.

"Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité."

Des idées, là je vois pas.

MErci d'avance.

Share this post


Link to post
Share on other sites

Le problème vient d'ovh lorsque vous activez le ssl.

Toutes les connexions sont re-routées vers leur serveur proxy qui gère le ssl et tout le monde repart avec la même IP, super non ?

Forcément les vérifications ne fonctionnent plus...

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

Même souci de mon côté.

Impossible d'accéder aux modules installés.

Jeton (token) invalide...

 

Site hébergé en mutualisé chez OVH

PHP 5.4.45

 

J'ai essayé d'activer et de désactiver le SSL

J'ai changé les droits d'écriture FTP

 

Sous l'onglet "Paramètres avancés" / "Log" j'ai le message d'erreur suivant:

Impossible de charger les données depuis Addons. Data from PrestaShop Addons is invalid, and cannot fallback on cache

 

Je ne sais pas si ça a un rapport...

 

Merci pour votre aide

Share this post


Link to post
Share on other sites

  • 3 weeks later...
  • 2 months later...

Bonjour,

 

Je suis hébergé sur OVH en Prestashop 1.7.0.6

 

Moi aussi j'ai ce problème, ce message "Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité." est récurrent, pour ma part uniquement sur l'onglet produit de mon BO, au bout d'une dizaine de tentative je fini par y accéder mais une fois dans une fiche produit les modifications ne prennent pas et le message "Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité." apparait à nouveau !

 

J'ai vérifié avec OVH ma version PHP, je suis en 7.0 legacy et même sur une version intérieur 5.4, 5.5 ou 5.6 ça ne change rien, SSL ou pas ça ne change rien non plus !

 

Quoi faire ? quelqu'un a t'il une idée ?

 

Merci d'avance.

  • Like 1

Share this post


Link to post
Share on other sites

D’après vous, est ce que le "Module 1-Click Upgrade" est bien adapté pour une mise à jour 1.7.0.6 vers 1.7.1.1 ?

Je ne me sent pas apte à faire cette mise à jour manuellement !

Share this post


Link to post
Share on other sites

Bonjour,

J'ai exactement le même soucis. Je l'ai eu au début sur un modification produit et là c'est pour accéder à la page de mes modules. Je ne sais pas si c'est avec ce soucis, mais en essayant d'accéder à mon site j'ai eu ce message " Link to database cannot be established: SQLSTATE[HY000] [2002] Connection refused ".

Donc actuellement j'ai " 
Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité. " en version 1.7.0.6 et en php 7.0.15

Share this post


Link to post
Share on other sites

j'avais également eu ce même genre de problème pour accéder aux modules et j'avais réglé le problème simplement en vidant le cache dans l'onglet :

"paramètres avancés" - "performance"- puis en haut à droite "vider le cache"

  • Like 1

Share this post


Link to post
Share on other sites

Petite piste ...

quand vous avec ce message Jeton (token) invalide: accéder à ce lien peut entraîner un éventuel problème de sécurité. " 

--> vous enlevez dans l'url la partie après index.php puis faites entrée. Vous repartez alors de zéro pour le token.  

Share this post


Link to post
Share on other sites

j'avais également eu ce même genre de problème pour accéder aux modules et j'avais réglé le problème simplement en vidant le cache dans l'onglet :

"paramètres avancés" - "performance"- puis en haut à droite "vider le cache"

Je crois que le soucis c'est résolu pour moi. Du moins pour le moment..

Share this post


Link to post
Share on other sites

  • 3 weeks later...
  • 1 year later...

La 1.7 n'a rien résolu de ce côté, au contraire (pour info, le cœur de la 1.7 c'est une 1.6.0.10^^)

Le token invalide provient soit de l'hébergement (Souci d'ip), soit du js et dans le cas où un module hooké en backofficeheader aurait une variable également nommée "token".

Sachant que la dernière lue est celle prise en compte.

Pour éviter le problème OVH/ hébergement, commencez par désactiver le controle de l'ip dans le contexte.

Ensuite le token est toujours construit de la même manière: $this->token = Tools::getAdminToken($this->controller_name.(int)$this->id.(int)$this->context->employee->id);

la fonction de Tools ne faisant qu'un simple encrypt des données ci-dessus.

Donc si le token est invalide c'est soit que le context->employee a été réinitialisé (pb de cookie ou ip), soit qu'un autre script (hors core) l'a modifié.

Edited by Eolia (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

Merci Eolia pour cette réponse .

Je pense plus pour un js car je suis tombé sur ce poste de github mais je ni comprend aps grand chose .... :

https://github.com/PrestaShop/welcome/pull/32

Quand pense tu ?

Comment désactiver le contrôle de l'ip dans le contexte. pour éviter le problème OVH/hébergement ?

Merci pour ton aide.

 

Share this post


Link to post
Share on other sites

Plus suivie ne veut pas dire plus fonctionnelle, au contraire.

Les modules et thèmes sont toujours écrits pour cette version et les 250 000 boutiques qui tournent dessus ne vont pas se transformer en citrouille le 31 décembre à minuit^^

Share this post


Link to post
Share on other sites

  • 1 year later...
  • 1 month later...
  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More