Jump to content
Bob_prestashop

Problème installation prestashop 1.7 ovh mutualisé

Recommended Posts

Bonjour,

 

Je n'arrive pas à installer prestashop 1.7 sur mon hébergement mutualisé ovh.

Je fais l'installation sur un sous-domaine.

J'ai essayé de relancer l'installation plusieurs fois, même en effaçant la base de données et les fichiers ça ne fonctionne pas.

 

NB : avant l'installation j'ai eu un message

 

" Set short_open_tag to off in php.ini*. "

 

Lors de l'installation ça bloque à la partie : Install modules.

 

Merci pour vos réponses !

 

PJ : screenshot installaton.

 

 

post-480044-0-24092800-1479428462_thumb.jpg

Share this post


Link to post
Share on other sites

Bonjour

 

Vérifier quel version de php vous avez et mettez php7

et tester votre installation.

 

ou

 

vous mettez ça dans un php.ini que vous mettrez a la racine de votre site

 

short_open_tag = off

 

et vous l'enregistrer en utf8

 

Comme c'est un problème d'installation je déplace dans le forum Installation de prestashop et mise à jour

Share this post


Link to post
Share on other sites

Ah bon ?

 

C'est si compliqué que ça ?

 

Le service technique de ovh m'a dit de prendre un dédié où un vps pour le problème de php.ini.

 

C'est quand même fou on ne peut pas prendre un simple mutu ovh pour installer PS 1.7 maintenant ?!

Share this post


Link to post
Share on other sites

Bah disons que la version de PS 1.7 ne sera pas réellement stable avant quelques bons mois. Et en plus, OVH surtout sur du mutu (surchargés au possible), c'est pas se donner tous les atouts pour partir du bon pied. Sauf si tu vises 3 visites par jour :) Et que tu n'as pas besoin de leur SAV

Share this post


Link to post
Share on other sites

ok dc presta de propose direct une version pas stable en telechargement !!!!!

 

Sympa les mecs, je vais test une version antérieure alors, par ce que je viens de tester le fichier ini et ça marche pas !

 

Merci !

Share this post


Link to post
Share on other sites

oui, moi pour l'instant je ne mets pas à jour mes sites, et quand on me demande un devis pour un passage en 1.7, j'explique que je ne proposerai pas ce service avant 1 an !

 

donc oui, prends la 1.6.1.9 et tu seras peinard (la branche 1.6 a près de 3 ans, ça commence à être stable)

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour

 

Vérifier quel version de php vous avez et mettez php7

et tester votre installation.

 

ou

 

vous mettez ça dans un php.ini que vous mettrez a la racine de votre site

 

short_open_tag = off

 

et vous l'enregistrer en utf8

 

Comme c'est un problème d'installation je déplace dans le forum Installation de prestashop et mise à jour

 

Bonjour,
 
j'ai toujours l'erreur Set short_open_tag to off in php.ini alors que j'ai essayé les solutions suivantes:
 
- En activant php7
- En mettant short_open_tag = off dans un fichier php.ini en utf8
 
J'ai aussi mis php_value short_open_tag 0 dans .htaccess mais alors j'obtiens un message internal error. 
 
Pouvez-vous m'aider à résoudre ce problème ? 

 

Share this post


Link to post
Share on other sites

Il faut ajouter à la racine du site un fichier .user.ini (avec le point devant :-) contenant :

short_open_tag = Off

Et peu importe la version de PHP, car chez OVH elles sont toutes à la valeur "On". Les fichiers phpinfo() sont ici http://pro.ovh.net/infos/

Normalement cela devrait se faire aussi via .htaccess (voir https://secure.php.net/manual/en/configuration.changes.php ), mais il me fut impossible d'obtenir ainsi un résultat.

Share this post


Link to post
Share on other sites
On 29/10/2017 at 10:42 PM, d2air said:

Il faut ajouter à la racine du site un fichier .user.ini (avec le point devant :-) contenant :

short_open_tag = Off

 

Avec l'ajout de ce fichier, je n'ai plus ce warning lors de l'installation de Prestashop 1.7 sur une offre Performance d'OVH.

Share this post


Link to post
Share on other sites

Bonjour,

Je suis dans le même cas de figure : j'ai voulu installer Prestashop 1.7 (avec le module en 1 clic d'OVH et en manuel)

- En manuel : Lors du contrôle de compatibilité système, j'ai le message : Set short_open_tag to off in php.ini*.  Le dossier admin ne se renomme pas et je n'ai pas accès au backoffice (page blanche)

- Avec le module : je n'ai pas accès au backoffice (page blanche)



J'ai ouvert un ticket chez OVH, voilà la réponse :
 

Citation

Suite aux vérifications, je constate que le souci rencontré est lié au
variable "short_open_tag".

Je tiens à vous préciser que la variable "short_open_tag" est mise en "ON" par
défaut.

Vous ne pouvez pas modifier cette variable, il n'est pas possible avec
l'infrastructure mutualisée d'agir sur les variable php et mettre
"short_open_tag" en "Off".

Pour plus d'informations, veuillez consulter le lien suivant :

http://fpm5.5-check.cluster003.ovh.net/phpinfo.php

Donc OVH propose Prestashop 1.7 avec son module 1 clic qui ne fonctionne pas et Prestashop propose un système qui ne fonctionne pas sur un hébérgement qui est très répandu ?

Merci

 

Share this post


Link to post
Share on other sites

Bonjour,

Moi je viens d'installer prestashop 1.7.5 sur un performance chez OVH, j'ai eu le message "Set short_open_tag to off in php.ini" lors du contrôle de compatibilité. 

L'installation c'est bien passé et tout a l'air de bien fonctionner .

Mais je me demande quand même avant de me lancer dans un paramétrage complet , quel problème peut poser ce warning ?

 

Cordialement

Alex

Edited by AlexMYN (see edit history)

Share this post


Link to post
Share on other sites

C'est pas pb grave comme problème (en tout cas, bien moins que d'utiliser PS 1.7 ou d'être en mutu sur OVH). PS demande (mais c'est juste un avertissement) de mettre à off ce paramètre pour ne pas autoriser les bouts de code PHP à commencer juste par <? mais par <?php obligatoirement

  • Like 1

Share this post


Link to post
Share on other sites

Merci pour ta réponse,

Je suis chez OVH depuis plusieurs années et je n'ai jamais eu aucun problème avec eux, ils m'ont même aider 2 ou 3 fois pour des problème en un temps record.

Pour ce qui est de PS 1.7, je pense qu'il commence à être stable, j'ai aussi un 1.6 qui fonctionne bien mais je voudrai tenter le 1.7.

D'ailleurs il est en 1.6.9, j'ai déjà essayé de le mettre a jour, mais a chaque fois erreur avec page blanche a la fin.

Share this post


Link to post
Share on other sites

Bonjour

J ai eu un souci récement , ne plus pouvoir acceder à ma partie admin au niveau de prestashop.
Version version presta : 1.7.4.3
Type d'hebergement : OVH mutualisé perf2014x1 Gold
Tout fonctionnait sans souci à un moment plus accés à l'interface admin " backoffice "
en attachement les fichiers Logs du mois 9 et mois 10

J ai pris contact avec le support OVH , là on m'a conseillé de reinstaller le module PHP en 1 click
ON a eu une erreur , puis en les recontactant voici la réponse :
"La tache en erreur est annulée.
Je vous invite à installer le module manuellement, car il existe un souci actuellement, au niveau du module en 1 clic."

Demandant conseil à un ami , il signal qu'il s'agit d'un souci de PHP avec l'évolution de Prestashaop
Sur les Forums , on dit que le souci vient d'OVH Hbergement qui force les gens à passer vers le VPS
Source : https://www.prestashop.com/forums/topic/569467-probl%C3%A8me-installation-prestashop-17-ovh-mutualis%C3%A9/1
Source 2 : http://community.ovh.com/t/perf2014x1-max-execution-time-trop-court/1022/16 plustot on parle de PHP issues " Problems"

 

Merci pour votre aide 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More