Jump to content
Niper33

Blocklayered (navigation a facette) ne fonctionne plus

Recommended Posts

Bonjour,

Je suis sur prestashop cloud 1.6.1.3

 

Depuis 2 jours, le blocklayered ne fonctionne plus sur ma boutique. Lorsque j'essaie de reconstruire l'index celui ci me renvoi vers une page blanche. De plus, les filtres sur ma boutique ne sont plus présents. J'ai réinitialisé, désinstallé, réinstallé mais rien n'y fait. J'ai remarqué aussi par le biais de filezilla que dans le dossier config, il n'y a plus le fichier config.inc.php ! Est ce que cela à un rapport ? Si cela viens de ce problème là, est-il possible de le réparer ou de le récupérer ? 

En vous remerciant par avance de votre aide précieuse et de vos conseils

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

Je suis sur prestashop cloud 1.6.1.3

 

Depuis 2 jours, le blocklayered ne fonctionne plus sur ma boutique. Lorsque j'essaie de reconstruire l'index celui ci me renvoi vers une page blanche. De plus, les filtres sur ma boutique ne sont plus présents. J'ai réinitialisé, désinstallé, réinstallé mais rien n'y fait. J'ai remarqué aussi par le biais de filezilla que dans le dossier config, il n'y a plus le fichier config.inc.php ! Est ce que cela à un rapport ? Si cela viens de ce problème là, est-il possible de le réparer ou de le récupérer ? 

En vous remerciant par avance de votre aide précieuse et de vos conseils

Cordialement

Bonjour

 

Activer le débug sur le CLOUD : 

 

dans le .htaccess à cette ligne si elle n'y est pas mettez là au début

 

setEnv HTTP_PS_MODE_DEV_ false à true

 

Si c'est un problème d'interprétation d'un fichier vous verrez un message d'erreur. Copier Coller au moins la 1ere ligne.

Si le nom de votre dossier d'administration apparait remplacé le par des *****.

 

Sur le CLOUD les dossier système ne sont plus accessible  juste : modules, override, thèmes et .htaccess, le dossier config est visible mais rien dedans tel setting.inc.php et 3 raccourcis qui ne servent a rien pour l'utilisateur footer.php header.php et init.php

Share this post


Link to post
Share on other sites

Bonjour et merci pour votre réponse

Je m'excuse de mon ignorance mais vous avez peut être la solution à mon probleme :

 

.htaccess à cette ligne si elle n'y est pas mettez là au début

 

setEnv HTTP_PS_MODE_DEV_ false à true

 

J'ouvre donc le .htaccess à la racine du premier dossier et je l'ai passé à true. C'est bien cela ?

 

Si c'est un problème d'interprétation d'un fichier vous verrez un message d'erreur. Copier Coller au moins la 1ere ligne.
Si le nom de votre dossier d'administration apparait remplacé le par des *****.

 

Je suis désolé mais je ne comprend pas ou je dois voir un message d'erreur ??? Désolé de mon ignorance

Pourriez vous être un peu plus précis svp

En vous remerciant pour votre aide

Share this post


Link to post
Share on other sites

Bonjour,

Je viens de faire votre solution, lorsque je clique sur reconstruire l'index dans le module navigation à facette : j'ai toujours ma page blanche mais sans aucun message....

pareil pour tout ce qui est index ...

Point positif j'ai reussi a réafficher les filtres mais lorsque l'on en selectionne 1 il se met en chargement avec une petite roue et rien ne se déclenche.

Pourriez vous m'aider svp ?

Cordialement

Edited by Niper33 (see edit history)

Share this post


Link to post
Share on other sites

petit up avec nouvelles observations

J'ai remarqué que le tri par défaut de la boutique ne fonctionne pas si le module blocklayered est activé !

Quelqu'un aurait une idée ?

Merci par avance

Share this post


Link to post
Share on other sites

Bonjour

 

Le message d'erreur s'il y a lieu s'affiche en général en haut de page et commence par Fatal error ou Warning etc..

dans le style : Warning: Cannot modify header information – headers already sent by (output started at /home/www/config.php:1) in /home/www/includes/pluggable.php on line 881

 

Si vous n'avez pas de message d'erreur ce n'est pas un problème de lecture des fichiers par le système du serveur.

 

 

 

J'ai remarqué que le tri par défaut de la boutique ne fonctionne pas si le module blocklayered est activé !

 

Faites des recherches sur le forum, ce problème n'est pas nouveau.

 

je viens de trouver possible que cette solution fonctionne mais attention ce n'est pas la même version de prestashop que la votre, donc à vérifier si le contenu du fichier est le même

 

sinon faites des recherches avec : tri par défaut  ne fonctionne pas module blocklayered est activé

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai à peu près le même problème remonté par un client, docn probablement là depuis longtemps, car je n'ai rien modifié depuis la mi 2016. 

 

Pas de tri de AàZ etc ni de changement de page possible (impossible de voir les produits suivant), j'ai trouvé que le module de navigation à facettes était le responsable du problème.

 

Prestashop 1.6.09 thème Manolia,

 

Quelqu'un aurait-il une solution ?

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai à peu près le même problème remonté par un client, docn probablement là depuis longtemps, car je n'ai rien modifié depuis la mi 2016. 

 

Pas de tri de AàZ etc ni de changement de page possible (impossible de voir les produits suivant), j'ai trouvé que le module de navigation à facettes était le responsable du problème.

 

Prestashop 1.6.09 thème Manolia,

 

Quelqu'un aurait-il une solution ?

Bonjour

 

Vous êtes héberger où ?

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More