Jump to content
renezo

[OPGELOST] PostNL track en trace url

Recommended Posts

Sinds afgelopen week heeft PostNL Parcelwareweb vervangen door hun nieuwe site op PostNL.nl ook de basis track en trace code is hierdoor gewijzigd. Als ik deze wil invoeren bij vervoerders blijf ik bij het opslaan het bericht krijgen dat er sprake is van een invalid url (prestashop 1.5.3.1) Zelf denk ik dat het komt omdat er in de nieuwe url de tekens #! voorkomen. Iemand een goed idee waar het aan te passen dat deze tekens wel worden geaccepteerd?
Voorbeeld van nieuwe URL: https://jouw.postnl.nl/#!/track-en-trace/BARCODE/LANDCODE/POSTCODE

Edited by renezo (see edit history)

Share this post


Link to post
Share on other sites

even zoeken in de topics  is probleem wat al behandeld wordt.  ergens op het forum   :D

 

wij hebben ook nog geen oplossing gevonden.

probleem zit hem in de postcode

Share this post


Link to post
Share on other sites

Dank voor de reactie maar een groter stuk van trackingcode steeds opnieuw invoeren heb ik ook al gepoogd maar ook daar de foutmelding dar hij invalid is

Share this post


Link to post
Share on other sites

voor de mensen zonder parcelware (weet niet of het met parcelware ook werkt, maar zo te zien komt het op hetzelfde url uit)

 

ikzelf heb het volgende ingesteld 

http://www.postnlpakketten.nl/klantenservice/tracktrace/basicsearch.aspx?lang=nl&B=@

tot nu toe werkt het (nog)goed 

 

het wordt (nog) automatisch doorgestuurd naar :

https://jouw.postnl.nl/?lang=nl#!/track-en-trace/HIER STAAT HET TET NUMMER/NL/POSTCODE

Edited by maconl (see edit history)

Share this post


Link to post
Share on other sites

voor de mensen zonder parcelware (weet niet of het met parcelware ook werkt, maar zo te zien komt het op hetzelfde url uit)

 

ikzelf heb het volgende ingesteld 

http://www.postnlpakketten.nl/klantenservice/tracktrace/basicsearch.aspx?lang=nl&B=@

tot nu toe werkt het (nog)goed 

 

het wordt (nog) automatisch doorgestuurd naar :

https://jouw.postnl.nl/?lang=nl#!/track-en-trace/HIER STAAT HET TET NUMMER/NL/POSTCODE

 

 

Dat werkt met 1.6.1.1  niet

Zie bijlage

post-346276-0-19881200-1445272232_thumb.jpg

Share this post


Link to post
Share on other sites

Bedankt voor de info Racemaniac

Helaas haal ik het vanavond niet meer om eea te bekijken 

zal proberen morgen met een fresh install te kijken 

(ikzelf heb de betreffende shop steeds geupgrade ( van PS 1.0 met tussenstappen van verschillende versies naar 1.6.1.1)

wellicht het hier in zit dat het bij mij (nog) wel werkt 

kom er zsm op terug

Share this post


Link to post
Share on other sites

Beste allemaal,

 

Mede door mdekker ben ik op het juiste spoor gezet, het probleem zit hem in het ! teken in de code en niet in de #.

Deze heb ik nu als ASCI gecodeerd de basis is nu "https://jouw.postnl.nl/#%21/track-en-trace/@" (zonder de ")

En via het bestellingenscherm het volgnummer BARCODE/NL/POSTCODE

 

Iedereen dank voor het meedenken.

Als je deze wijziging uitprobeert moet je wel zelf een nieuwe bestelling aanmaken. Testen werkt niet met oude bestellingen.

Edited by renezo (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Dat werkt met 1.6.1.1  niet

Zie bijlage

Schoot me ineens te binnen , ik heb destijds in v 1.4 eea aangepast , daarom werkt het bij mij nog steeds  :wacko:

zal eens kijken of eea uit dit topic aangepast kan worden voor de nieuwere 1.6 versies , 

kan helaas niet beloven (ivm enorme drukte) of het mij deze week nog gaat lukken 

 

wellicht iemand mee kan kijken ? mdekker?    :lol:

 

het gaat om :

https://www.prestashop.com/forums/topic/34444-track/?p=938620

 

heb daar destijds paar bestanden neergezet,,

eventueel in dat topic post 43 voor de codes erbij halen

Edited by maconl (see edit history)

Share this post


Link to post
Share on other sites

post-346276-0-07020800-1445421871_thumb.png

Beste allemaal,

 

Mede door mdekker ben ik op het juiste spoor gezet, het probleem zit hem in het ! teken in de code en niet in de #.

Deze heb ik nu als ASCI gecodeerd de basis is nu "https://jouw.postnl.nl/#%21/track-en-trace/@" (zonder de ")

En via het bestellingenscherm het volgnummer BARCODE/NL/POSTCODE

 

Iedereen dank voor het meedenken.

Als je deze wijziging uitprobeert moet je wel zelf een nieuwe bestelling aanmaken. Testen werkt niet met oude bestellingen.

 

Deze optie lijkt te werken echter bij het voltooien krijg ik een parse error.

Er wordt een nieuwe vervoerder (met nieuw ID)  aangemaakt (kopie) in plaats van dat de vervoerder aangepast wordt

 

 Iemand enig idee  wat de foutmelding inhoud ??

post-346276-0-07020800-1445421871_thumb.png

Share this post


Link to post
Share on other sites

attachicon.gifpostnl fout.PNG

 

Deze optie lijkt te werken echter bij het voltooien krijg ik een parse error.

Er wordt een nieuwe vervoerder (met nieuw ID)  aangemaakt (kopie) in plaats van dat de vervoerder aangepast wordt

 

 Iemand enig idee  wat de foutmelding inhoud ??

 

attachicon.gifpostnl fout.PNG

Beste Racemaniac,

In mijn database kan ik zien dat bij iedere wijziging weer een nieuwe vervoerder wordt aangemaakt waarbij de oude wordt uitgeschakeld.

Voor de goede orde mijn oplossing werkt in versie 1.5.3.1.

Succes.

Share this post


Link to post
Share on other sites

Heb een meest logische "oplossing" gevonden :

Gewoon de T&T code / link hardcoded in de sql database het betreffende record aangepast

 

Zolang dit een bug blijft  dus geen andere vervoerders aanmaken of aanpassen  :blink:

Share this post


Link to post
Share on other sites

Weet iemand inmiddels al wat de codering binnen Prestahsop is voor de postcode ??

https://jouw.postnl.nl/#!/track-en-trace/@/NL/??????

Deze url werkt gedeeltelijk, echter de postcode (   door ???????  aangestuurd)  wordt niet vanuit de SQL database overgenomen.  en men moet zelf handmatig de postcode steeds invullen.  De 3S  barcode (  @ )   wordt wel correct opgehaald uit de SQL

Blijkbaar is ??????  niet de juiste "zoek string"  in de SQL  voor de postcode

 

Iemand advies / raad  ???

 

Tnx

image.thumb.png.986d03b867e28662af0eae75a6f2a001.png

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More