Jump to content

Problema Codice Postale sempre rosso anche quando corretto


Kron03
 Share

Recommended Posts

Ciao a tutti,

ho un problema con il mio ecommerce Prestashop versione 1.6.1.0.

 

Ho cercato ovunque sul forum e online ma non ho trovato nulla sinceramente per risolvere questo problema..

 

Durante la compilazione della form d'iscrizione utente, quando l'utente inserisce i dati nel campo Codice Postale (CAP) qualsiasi sia il contenuto inserito nel campo, viene sempre segnalato di rosso come se il contenuto del campo non fosse corretto.

 

Premetto che ho controllato nelle impostazioni dedicate al CAP e attualmente ho attivo il campo con le impostazioni NNNNN, dunque dovrebbe accettare per corretto qualsiasi numero di 5 cifre.

 

Altro particolare, se provo ad avanzare con l'iscrizione, riesco a terminarla, quindi il sistema riconosce che i dati sono corretti ma segnala comunque di rosso il campo quando viene compilato.

 

E' già accaduto a qualcuno e avete trovato soluzione? Qualcuno ipotizza soluzioni o cause del problema?

Grazie in anticipo a tutti dell'aiuto!

post-1085236-0-45181200-1441186057_thumb.png

Edited by Kron03 (see edit history)

Share this post


Link to post
Share on other sites

Ciao Lui1969

 

e grazie del supporto.

 

Il bug si presenta sia sulla mia versione 1.6.1.0 sia sulla 1.6.1.1 (ho visto che sono nati altri 2 topic, uno in inglese e uno in spagnolo, di utenti che hanno la versione 1.6.1.1 con lo stesso problema).

 

Ho appena segnalato il bug a http://forge.prestashop.com

 

Grazie del supporto

 

Se qualcuno avesse trovato cause o soluzioni al problema è benvenuto nel topic :)

Share this post


Link to post
Share on other sites

ciao Kron ottimo direi hai segnalato il tutto e speriamo in una soluzione, appena hai notizie posta la soluzione in questo modo chi avrà il tuo stesso problema saprà come risolverlo

 

Certo Lui1969, appena ho notizie posto la soluzione.

 

Se qualcuno in ogni caso, avesse la soluzione in anticipo, è sempre ben accetta. :)

Share this post


Link to post
Share on other sites

Ciao a tutti,

forge.prestashop.com ha trovato la soluzione al bug, l'ho testata e funziona! La condivido immediatamente con voi.

 

Dovete aggiornare in ogni caso all'ultima versione per chi non ce l'ha ancora.

 

Copiate il file statesManagement.js che trovate a questo indirizzo: themes/default-bootstrap/js/tools/statesManagement.js

nella cartella del vostro tema attualmente attivo nello stesso percorso themes/VOSTRO-TEMA-ATTIVO/js/tools/statesManagement.js (In quel percorso esiste già un file ma non è corretto, quindi sovrascrivete il file quando lo copiate).

 

Fine.. tutto qua.. funziona ;)

 

come si fa a segnalare come solved il topic? :P

 

Buon lavoro a tutti e grazie per il supporto di chi ha partecipato al topic

Edited by Kron03 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

  • 1 year later...

Salve

Ho seguito alla regola queste istruzioni, ma purtroppo non sono riuscito a risolverlo. Ho copiato il file del default-bootstrap all'interno del mio template, ma non funziona ugualmente, anzi mi sparisce il campo CAP dall'elenco dei campi. Se rimetto il file statesManagement.js del templates mi resta sempre rosso. Nonostante abbia selezionato la non obbligatorietà del campo, mi rimane sempre l'asterisco rosso a fianco del CAP. Mi potreste aiutare?

Grazie mille

Sto utilizzando prestashop 1.6.1.1

Edited by polparo (see edit history)

Share this post


Link to post
Share on other sites

Probabilmente non è un bug di prestashop

vai sulla console del tuo browser. se hai chrome è sufficiente premere F12

controlla se ci sono degli errori javascript, sono in rosso

è possibile che ci sia qualche modulo non prestashop che interferisca perchè va in errore.

disabilita tutti i moduli non nativi ed eventualmente gli override.

 

se l'errore persiste probabilmente è un errore di prestashop, ma solo se usi il tema grafico standard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More