Jump to content

1.6.0.11 Bad Request Cookie Error


Recommended Posts

Kinda getting tired of software folks insisting that people move FORWARD with software that doesn't work!

 

I just upgraded to 1.6.0.11 because I was forced to (instead of 1.6.0.9 that my theme stated) and this thing is full of bugs...

 

The one I am dealing with right now is the

 

BAD REQUEST

Your browser sent a request that this server could not understand.
Size of a request header field exceeds server limit.

Cookie

 

I cannot find a fix for this anywhere in the available Prestashop resources and know that I am not the only one having the problem... others have commented too, but like most things - no answers are forthcoming.

 

Have I made an EXTREME MISTAKE investing my business in Prestashop - or are you guys gonna get your act together and start actually fixing these bugs??

 

Looking for the solution to the problem above as soon as possible...

Thanks

Share this post


Link to post
Share on other sites

How did you upgraded ? With 1-click module ?

 

Which cyphering method (mcrypt module) is installed on your server ? Blowfish ? Rijndael ?

 

Which settings did you made on Tab advanced parameters -> performance -> cyphering ?

 

Did you activate on tab "preferences -> general -> Increase Front Office security=YES ?

 

At least did you after upgraded your shop deleted the cookie-session and cache on your browser ?

 

You are using a third party theme/third parties modules ?

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

How did you upgraded ? With 1-click module ?

 

Which cyphering method (mcrypt module) is installed on your server ? Blowfish ? Rijndael ?

 

Which settings did you made on Tab advanced parameters -> performance -> cyphering ?

 

Did you activate on tab "preferences -> general -> Increase Front Office security=YES ?

 

At least did you after upgraded your shop deleted the cookie-session and cache on your browser ?

 

You are using a third party theme/third parties modules ?

 

Upgrade was with 1-click module

 

cyphering is Rjindael - << standard with install

 

"Tab advanced parameters -> performance -> cyphering" << does not exist in my admin panel

 

"preferences -> general -> Increase Front Office security=YES" << set to YES

 

After shop upgrade - whatever the application did as far as cookie handling or logging in/out is what happened << I do not have the mental capacity to remember every step a software application takes that appears to be standard - so the short answer is - I cannot tell you for sure what took place.

 

Theme is from membuy - but also seen on TemplateMonster... and it shows compatibility with Prestashop 1.6.x on both websites - so yes it is third party - but this is not a theme issue on the front end - this is a backoffice issue when working in the product catalog.

 

UPDATE:

I did discover that if I completely close all browser windows and log back in after opening the browser again - the problem appears to go away - at least for a time.

Share this post


Link to post
Share on other sites

"Tab advanced parameters -> performance -> cyphering" << does not exist in my admin panel cyphering is a block in the page performance. But it doesn't matter you already answered with Rijndael, so it is correct and I suppose you read ith from that setting.

 

So in first, and why you are also using non native modules/theme you should activate debug modus. In most of the cases not Prestashop has a bug, but the non compatible third party developments (specially themes form outside of Prestashop !!)

 

Turn on debug mode and read the errors showing in front-office and back-office: https://www.prestashop.com/forums/topic/224525-how-to-turn-on-error-reporting-for-debug-information-blank-page-500-internal-server-error/

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

"Tab advanced parameters -> performance -> cyphering" << does not exist in my admin panel cyphering is a block in the page performance. But it doesn't matter you already answered with Rijndael, so it is correct and I suppose you read ith from that setting.

 

So in first, and why you are also using non native modules/theme you should activate debug modus. In most of the cases not Prestashop has a bug, but the non compatible third party developments (specially themes form outside of Prestashop !!)

 

Turn on debug mode and read the errors showing in front-office and back-office: https://www.prestashop.com/forums/topic/224525-how-to-turn-on-error-reporting-for-debug-information-blank-page-500-internal-server-error/

 

Soooo..... non-native modules and themes are a No No huh?...  why bother?

 

man this is getting absolutely crazy... Prestashop team needs to get it together and at least put revision numbers in the headers of their code so they can keep things straight... No reason all of the things that are broken should have gotten broken with a minor revision change.

 

Now... I spent good money on professionally developed theme that got broken because Prestashop team changed the API (apparently) - - again - - yet another issue with the ad-hoc, hap-hazard manner in which code for this project seems to be managed. Themes from version 1.4 do not work with 1.5 which do not work with 1.6... seems to be a pattern - one which I cannot afford - even if the core is "free".

Share this post


Link to post
Share on other sites

Revision you will find in every script, also in the one really critical  which are modules for ex. I'm sure the problem is coming from your Theme.

 

If you don't want a software updating on each bigger version to the newest technique, so you should take a proprietary software and not an open source one... But also Microsoft & Co. updates his software core from time to time... ;)

 

If continuity of a running system is crucial for you, so you should first apply "never touch a running system" ! not if not needed !!

Edited by selectshop.at (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More