Jump to content

Go to solution Solved by El Patron,

Recommended Posts

Good night!

I do not know why but, we have not changed anything on our web, but since yesterday the JS files stopped working.

We used the default theme 1.6.0.6 and the top horizontal menu stopped work, you can not change the page in a list in the Administration menu, icon ajax running always appear moving, some payment option dont work, etc ...

Trying to fix it we have updated the page to 1.6.0.9 but the problem still happening. We also changed the permissions of all the folders and files to 755.

We have disabled some modules but it still happening.

I dont know what else to try.

 

Our website is www.llavemania.com

 

Any help?!

 

Thank yu so much

Share this post


Link to post
Share on other sites
  • Solution

this is what I see, you are not loading .js file that are not 'hard coded'

 

you have theme designed for 1.6.0.6.  themes/yourtheme/header.tpl does not have code to load javascript top.

 

with upgrade 1.6.0.7+, the default is to load javascript top

1.6.0.6 was forced all  bottom, so theme developers removed load .js from your themes  header.tpl

 

hence you are not loading any module/theme .js files.

 

-------

 

go to back office-->advanced parms-->performance

 

find the setting that moves all javascript to the bottom.  set load all javascript load bottom.  save

 

then re-test.

  • Like 1

Share this post


Link to post
Share on other sites

Or add this:

{if isset($js_defer) && !$js_defer && isset($js_files) && isset($js_def)}
	{$js_def}
	{foreach from=$js_files item=js_uri}
	<script type="text/javascript" src="{$js_uri|escape:'html':'UTF-8'}"></script>
	{/foreach}
{/if}

after this:

{if isset($css_files)}
	{foreach from=$css_files key=css_uri item=media}
		<link rel="stylesheet" href="{$css_uri|escape:'html':'UTF-8'}" type="text/css" media="{$media|escape:'html':'UTF-8'}" />
	{/foreach}
{/if}
  • Like 2

Share this post


Link to post
Share on other sites

Thank you so much for all, i've tried first to change this:

 

go to back office-->advanced parms-->performance

 

find the setting that moves all javascript to the bottom.  set load all javascript load bottom.  save

 

Because it was easeir for me and it fix the problem. I'm sure the other option too.

 

Thank you so much!!!

Share this post


Link to post
Share on other sites
  • 6 years later...
On 10/27/2014 at 10:17 AM, llavemani said:

go to back office-->advanced parms-->performance

 

find the setting that moves all javascript to the bottom.  set load all javascript load bottom.  save

Where can I that option?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More