Jump to content

Recommended Posts

Fala Pessoal

O site ainda está em desenvolvimento, no desktop está tudo OK.

Porém ao acessar de algum dispositivo móvel ele apresenta uma msg "este certificado não é de uma autoridade confiável"

Já entrei em contato com o suporte da hospedagem, eles me disseram que está tudo certo com o SSL e tudo mais.

Alguém já teve também esse problema ou sabe como resolvê-lo?

estou utilizando a versão 1.6.0.8 e o certificado digital é da Alpha SSL

Edited by Nisan (see edit history)

Share this post


Link to post
Share on other sites

Boas,

 

Poderia indicar o url do site e a versão do SO do telemóvel?

 

Cumps

Share this post


Link to post
Share on other sites

Se possue um certificado SSL e este está corretamente configurado entao idependente do browser que está sendo usado a página também será SSL. Prestashop nao é inteiramente SSL. somente o carrinho e log-in sao apresentados com https:

As páginas CMS e do produto nao necessariamente devem ter o prefixo https: as máquinas de busca reconhecem que a sua página possuem um certificado e dao preferencia, mesmo sendo que o SSL somente é mostrado após a sessao cookie.

 

O seu problema pode ter duas causas. O certificado nao está corretamente configurado no seu servidor, ou vc. está acessando a sua página com o dispositivo móvel de uma página cacheada. Deleta o cache e sessao de cookies. do seu browser no móvel.

 

Envie o link do seu site se o problema assim nao for resolvido.

Share this post


Link to post
Share on other sites

Valeu pelo retorno galera

Então o site ainda não está online, acredito que semana que vem esteja td pronto ai informo o link.

Vou ver esse lance do cache, pra ver se é isso

Já falei na hospedagem e está td ok.

Fiz o teste usando 2 aparelhos samsung diferentes com versões diferentes do android

 

Porém outro site que acessei que utiliza a msm hospedagem e SSL que eu, apresenta a msm msg e nem é um e-commerce. Portanto o problema não deve ser do PS. Foi por isso que imaginei que pudesse ser o certificado. Lembrando que no acesso via desktop e not tá ok. 

Edited by Nisan (see edit history)

Share this post


Link to post
Share on other sites

Se nao está online entao nao pode verificar a funcionalidade do certificado. O certificado é único ou seja registrado somente para o seu site ? Certificados do servidor nao servem.

Share this post


Link to post
Share on other sites

Expliquei errado

Na verdade os testes foram sim online, porém sem habilitar a loja, apenas liberando meu ip.

Sim o certificado é único para meu site.

 

 

Qdo eu disse "site que acessei que utiliza a msm hospedagem e SSL que eu", eu quiz dizer os mesmos serviços da empresa, e não que estamos usando o msm certificado em conjunto

 

E os aparelhos móveis estavam usando a msm rede pra conectar

Edited by Nisan (see edit history)

Share this post


Link to post
Share on other sites

Estou com outro problema tbm

Estava tentando apagar os pedidos de teste e acabei cometendo o erro de alterar o arquivo AdminOrdersController,

acontece que agora a tela COMPRA>PEDIDOS está em branco.

Retirei a linha que havia colocado e msm assim nada aconteceu, continua tela branca

É possível corrigir isso?

Share this post


Link to post
Share on other sites

Aparece o seguinte erro:

 

Fatal error: Class 'AdminOrdersController' not found in /home/tocaia/public_html/classes/controller/Controller.php on line 135

Share this post


Link to post
Share on other sites

Ou o ficheiro nao está sendo encontrado, ou nao possue direitos suficientes para ler. Altere o CHMOD do ficheiro para 0750 e verifique se resolve

Share this post


Link to post
Share on other sites

O CHMOD do ficheiro já está 750, e o erro continua

 

A linha 135 do Controller.php está assim:

return new $class_name($auth, $ssl);

Edited by Nisan (see edit history)

Share this post


Link to post
Share on other sites

Se nao resolve entao reponha o CHMOD correto para 0644. Retire o ficheiro standard do pacote de download e reponha.

 

As linhas do script nativas 133 à 135 sao:

	public static function getController($class_name, $auth = false, $ssl = false)
	{
		return new $class_name($auth, $ssl);
	}

Se nao resolver o problema, entao o certificado nao é reconhecido e problema da configuracao do mesmo ou do servidor. Contate o web-admin do seu servidor.

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

Não teve jeito mesmo.

Tive que reinstalar, pois depois do procedimento acima ficou tela branca pra tudo.

Não consegui nem mesmo acessar a área administrativa.

 

Porém em alguns testes que fiz depois, notei o seguinte: toda vez que fiz alterações em arquivos .tpl, ou em arquivos controller aconteceu o mesmo problema. Estava mudando o sitemap e tbm aconteceu isso.

 

Na hospedagem estava td correto msm o problema foi com o PS.

 

Já o certificado ainda continua apresentando aquela mensagem, logo que o site esteja em funcionamento posto o link para visualização.

 

Abraço

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More