Jump to content
rikardinho

[resolvido] Problema ao fazer Backup do Prestashop 1.4.8.2

Recommended Posts

Fala pessoal, beleza ?

Uso o prestashop 1.4.8.2 e estou mudando de host, com isto, estou fazendo o backup de um para subir em outro.

Estou baixando os arquivos + banco de dados do ANTIGO host, já no novo host eu instalo a versão 1.4.8.2 e subo os arquivos do BACKUP(+- 13mil arquivos), até ai tudo bem. O problema começa a ocorrer após finalização, eu já não consigo acessar a area administrativa do NOVO HOSTING. Então eu finalizo de subir o  banco de dados e continuo com o mesmo problema, entro com meu usuário e senha e aparece :

Existe 1 erro

  1. Empregado não existe ou a senha está incorreta.

Existe alguma solução para vocês conseguirem me ajudar ?

 

Muito obrigado comunidade!

Edited by rikardinho (see edit history)

Share this post


Link to post
Share on other sites

Vc criou e importou o banco de dados no novo servidor?

Definiu usuário e senha novos? Deu as permissões?

Atualizou o arquivo config/settings.inc.php com os novos dados de acesso ao servidor, banco, usuário e senha?

  • Like 1

Share this post


Link to post
Share on other sites

Daniel, bom dia!

Vc criou e importou o banco de dados no novo servidor?

- Exportei o banco de dados no ANTIGO HOST pelo PhpMyAdmin, fui no NOVO HOSTING e importei o mesmo banco de dados pelo PhpMyAdmin.

 

Definiu usuário e senha novos? Deu as permissões?
- Defini usuário e senha ao instalar o prestashop no NOVO HOSTING, baixei a versão 1.4.8.2 original e instalei ela. Quais permissões exatamente eu tenho que dar ?

 

Atualizou o arquivo config/settings.inc.php com os novos dados de acesso ao servidor, banco, usuário e senha?

- Correto, defini sim pelo File Manager do cPanel, quando subi os arquivos. Porém, ainda continua dando usuário e senha incorretos!
 

Edited by rikardinho (see edit history)

Share this post


Link to post
Share on other sites

Vc não deve "reinstalar" o PrestaShop, senão o sistema vai criar um novo arquivo settings.inc.php.

 

O procedimento de migração é apenas backup/restore dos arquivos e do banco de dados de um servidor pro outro.

Em seguida deve atualizar o arquivo config/settings.inc.php com os dados de acesso ao banco do novo servidor.

Só isso.

 

Recomendo ver os detalhes aqui: 

http://doc.prestashop.com/display/PS14/System+Administrator+Guide#SystemAdministratorGuide-MovingPrestaShop

  • Like 1

Share this post


Link to post
Share on other sites

Daniel,

 

Dei uma lida rápida aqui no documento que você, e verifiquei que estava fazendo o processo errado.
Eu estava instalando o prestashop no meu NOVO HOSTING, quando na verdade, eu não preciso fazer isto!

Pelo que li, é muito simples, veja se estou correto no que vou informar.
Eu baixo todos os arquivos da public_html(esta na raiz) + extrair o Banco de Dados do meu ANTIGO HOSTING;
Em seguida eu vou no meu novo hosting e subo os arquivos extraido no passo anterior ( vai estar em branco, pois não tem nada no meu novo hosting ), então eu subo todos os arquivos e crio um banco de dados, nesse banco de dados eu apenas importo o banco de dados exportado do meu antigo hosting e mudo o dados no arquivo config/setting.inc.php, depois tem que excluir os arquivos do cache e tudo mais, ai sem problema.

Está correto a minha analise sobre o que fazer ?
Obg.

Share this post


Link to post
Share on other sites

Sim totalmente correto. É so importar o banco de dados para um banco de dados VAZIO no seu novo Host e alterar no ficheiro settings.inc.php os dados do banco de dados novo (ou seja lá o nome do banco de dados, o usuário do banco de dados e a senha do usuário).

  • Like 1

Share this post


Link to post
Share on other sites

selectshop.at & Daniel,

Vou testar isto hoje sem falta! Volto com novidades se deu certo, ou não.

Muito obrigado!

Share this post


Link to post
Share on other sites

Pessoal,

100% funcionando, não tenho palavras para agradecer.
Muito obrigado mesmo.

Caso eu possa retribuir vocês, me avisem
Forte abraço!

Share this post


Link to post
Share on other sites

@selectshop.at

 

Pronto.
Apenas uma última dúvida, funciona na versão 1.5 e 1.6 ?

Obg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More