Jump to content
jumentin

Atualização completa de 1.5.2.0 para 1.6.0.6 no GODADDY ERRO 500

Recommended Posts

Bom dia a todos do fórum, pessoas preciso da ajuda de vocês, estou com um pequeno problema, pois a loja ainda não esta no ar, então posso fazer testes com ela sem medo, pois ainda não tenho nada lançado nela, contudo estou com uma falha estranha, tenho um Prestashop hospedado no Godaddy e lá somente esta funcionando a versão 1.5.2.0 quando instalo a versão mais nova da um erro interno no servidor "Error 500", porém a parte de Administração funciona perfeitamente, preciso muito da ajuda de vocês para elucidar esse problema. Aparentemente é algum ponto da atualização esta havendo incompatibilidade com o PHP ou com alguma outra ferramenta, queria ver se é possível solucionar o fato!!

 

http://www.luxuriaschilis.com.br/indexoo.php

 

Mandei duas imagens das informações da configuração.

 

Muito obrigado pela ajuda, um forte abraço a todos!!!

post-784135-0-85019500-1397303775_thumb.jpg

post-784135-0-54480700-1397303778_thumb.jpg

Share this post


Link to post
Share on other sites

Ative modo debug>: http://www.prestashop.com/forums/topic/282165-ativar-modo-debug/

 

O problema é que vc. está usando o Prestashop em um servidor Windows. Para falar a verdade servidores Windows sao problemáticos com qual quer tipo de software que nao seja da casa Microsoft.

 

Provavelmente está dando erro pois Prestashop necessita do ficheiro .htaccess que servidores Windows nao suportam. Vc. vai ter que traduzir o ficheiro -htaccess do root da sua loja para um ficheiro web.config. O IIS tem um tool para vc. poder tradu8zir. Verifique lá e coloque este ficheiro traduzido no root da sua loja.

 

Como expert em servidores, eu depois de um ano de sufoco com Prestashop em um servidor Windows, acabei desistindo. Isto porque mal vc. acaba colocando a loja para rodar, instala um módulo novo ou ativa um feature novo e comeca do zero noavmente dando erro. Acabei deixando Windows ser Windows e voltei au Linox que trabalha sem problema. Nao só com Prestashop....

Share this post


Link to post
Share on other sites

Bom dia

Com a minha loja, quando se clicam nos produtos tb dá erro 500.

 

o meu servidor é Linux.

 

Obrigada

Share this post


Link to post
Share on other sites

Boa tarde.

 

Estou com o mesmo problema - atualização de 1.5.3.1 para 1.6.0.9 - instalei um tema responsivo template monster - 

 

estava dando erro 500 removi o .htaccess não resolveu, ativei o debug e aparece o seguinte:

 

[PrestaShopException]

Current theme unselected. Please check your theme configuration.
at line 100 in file config/config.inc.php

94. try
95. {
96.     $context->shop = Shop::initialize();
97.     $context->theme = new Theme((int)$context->shop->id_theme);
98.     if ((Tools::isEmpty($theme_name = $context->shop->getTheme()) || !Validate::isLoadedObject($context->theme)) && !defined('_PS_ADMIN_DIR_'))
99.         throw new PrestaShopException(Tools::displayError('Current theme unselected. Please check your theme configuration.'));
100. }
101. catch (PrestaShopException $e)
102. {
103.     $e->displayMessage();
104. }

 

Quando acesso a página de temas não aparecem os jpg dos temas e aparece os seguintes erros:

Veja na imagem    

http://2emotos.com/erro-temas-prestashop.jpg

 Agradeço a ajuda

Share this post


Link to post
Share on other sites

Todos os themas e módulos nao nativos, assim como overrides deverao ser deinstalados antes de se fazerum um upgrade versao PS 1.5. para 1.6.

 

Temas responsivos nao mais servem para PS 1.6. por serem somente adaptivos e na verdade nao responsivos.

 

Vc. deveria fazer um roll-back da sua página, ou entao reativar o seu back-up e tentar novamente, desabilitando antes o tema, assim como também todos os módulos e overrides terceirizados. Somente o tema vc. desinstala manualmente. Use o tema default. para os m´dulos e overrides existe uma opcao no módulo 1-clique aonde vc. pode habilitar a desinstalacao durante o processo de upgrade. Veja lá nas opcoes Expert.

Share this post


Link to post
Share on other sites

Todos os themas e módulos nao nativos, assim como overrides deverao ser deinstalados antes de se fazerum um upgrade versao PS 1.5. para 1.6.

 

Temas responsivos nao mais servem para PS 1.6. por serem somente adaptivos e na verdade nao responsivos.

 

Vc. deveria fazer um roll-back da sua página, ou entao reativar o seu back-up e tentar novamente, desabilitando antes o tema, assim como também todos os módulos e overrides terceirizados. Somente o tema vc. desinstala manualmente. Use o tema default. para os m´dulos e overrides existe uma opcao no módulo 1-clique aonde vc. pode habilitar a desinstalacao durante o processo de upgrade. Veja lá nas opcoes Expert.

 

 

Acabei de concluir o processo mas não carrega nenhum tema nem o default comforme a imagem abaixo

 

http://2emotos.com/erro-temas-prestashop2.jpg

 

Assim que eu atualizo da erro 500 ja no log de atualização. Eu apago o .htaccess atualizo  e volta a aparecer o back-office mas o front não.

Edited by p1websolutions (see edit history)

Share this post


Link to post
Share on other sites

Aparece esse erro na página de temas

 

Notice na linha 260 no arquivo /home/doisemotos/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Trying to get property of non-object
 
Notice na linha 260 no arquivo /home/doisemotos/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Trying to get property of non-object
 
Notice na linha 263 no arquivo /home/doisemotos/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Trying to get property of non-object
 
Notice na linha 265 no arquivo /home/doisemotos/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Trying to get property of non-object
 
Notice na linha 266 no arquivo /home/doisemotos/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Trying to get property of non-object
 
Notice na linha 268 no arquivo /home/doisemotos/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Trying to get property of non-object
 
Notice na linha 269 no arquivo /home/doisemotos/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Trying to get property of non-object
 
Notice na linha 279 no arquivo /home/doisemotos/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Trying to get property of non-object
 
Notice na linha 280 no arquivo /home/doisemotos/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Trying to get property of non-object
 
Notice na linha 288 no arquivo /home/doisemotos/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code
[8] Trying to get property of non-object

Share this post


Link to post
Share on other sites

o erro me diz que o seu template ( e isto eu já tinho escrito em um outro tópico) nao é compatível com aversao Prestashop que está usando. Aliáse nenhum template codado para PS 1.5. (responsivo ou nao) serve para Prestashop 1.6. Temas responsivos codados para PS 1.5. na versade nao eram responsivos, mas sim adaptivos. Vc. vai ter que pedir ao desenvolvedor do seu tema fazer um upgrade para a versao Prestashop que vai usar no futuro.

 

Aparentemente o seu tema vem com overrides e nao adianta somente desinstalar. Vc tem que desinstalar e deletar no FTP na pasta /themes o tema e somente depois fazer um upgrade da loja com o tema default.

Edited by selectshop.at (see edit history)

Share this post


Link to post
Share on other sites

o erro me diz que o seu template ( e isto eu já tinho escrito em um outro tópico) nao é compatível com aversao Prestashop que está usando. Aliáse nenhum template codado para PS 1.5. (responsivo ou nao) serve para Prestashop 1.6. Temas responsivos codados para PS 1.5. na versade nao eram responsivos, mas sim adaptivos. Vc. vai ter que pedir ao desenvolvedor do seu tema fazer um upgrade para a versao Prestashop que vai usar no futuro.

 

Aparentemente o seu tema vem com overrides e nao adianta somente desinstalar. Vc tem que desinstalar e deletar no FTP na pasta /themes o tema e somente depois fazer um upgrade da loja com o tema default.

 

Bom dia e obrigado pela atenção.

 

Eu passei o caso para o desenvolvedor do tema e eles afirmaram que o tema foi escrito para o PS 1.6. Eu passei os dados de acesso, eles analisaram minha loja e afirmaram que o ocorrido, por falta de experiência minha, foi causado por ter instalado dois temas para a versão anterior (1.5.3.1) com todos os módulos e feito a atualização e instalação no novo tema sem remover nada.

 

Enfim me disseram que a instalação está repleta de problemas (inclusive não estou conseguindo nem fazer um roll-back  pois a página de módulos não carrega de forma nenhuma) e o ideal seria fazer uma instalação do zero. 

 

Eu gostaria de sua ajuda mais uma vez se possível. Quando eu fiz a primeira instalação eu subi por volta de 2.000 produtos via CSV importado de outra plataforma, mas o CSV não tinha fotos, descrição, combinações, etc...

 

Meu cliente está a mais ou menos 40 dias editando manualmente. O que eu preciso saber é se você tem algum tutorial ou possa me explicar como gerar um CSV completo para subir para a nova instalação.

 

Obrigado mais uma vez.

Share this post


Link to post
Share on other sites

Vc. nao tem um back-up do seu FTP e banco de dados antigo que possa usar ? Já existem pedidos ou clientes novos neste interim ? Eu iria tentar fazer um "roll-back" nao do 1-click, mas sim um roll-back manual de um back-up antigo.

Outra possibilidade seria exportar os artigos e importá-los através do back-office. A loja já possue muitos clientes e pedios ? Se sim, entao deveria exportá-los com o phpMyAdmin em um csv. e importar no back-office. Para os pedidos infelizmente eu nao tenho solucao. Estes vc. acabe perdendo de qualquer forma se com o roll-back do 1-clique nao funcionar, ou entao pedir á um Expert migrar o seu banco de dados.

Share this post


Link to post
Share on other sites

Vc. nao tem um back-up do seu FTP e banco de dados antigo que possa usar ? Já existem pedidos ou clientes novos neste interim ? Eu iria tentar fazer um "roll-back" nao do 1-click, mas sim um roll-back manual de um back-up antigo.

Outra possibilidade seria exportar os artigos e importá-los através do back-office. A loja já possue muitos clientes e pedios ? Se sim, entao deveria exportá-los com o phpMyAdmin em um csv. e importar no back-office. Para os pedidos infelizmente eu nao tenho solucao. Estes vc. acabe perdendo de qualquer forma se com o roll-back do 1-clique nao funcionar, ou entao pedir á um Expert migrar o seu banco de dados.

 Obrigado pela resposta.

 

A loja ainda não foi pro ar, não tem pedidos nem clientes. Eu tenho um backup sim, dos arquivos e banco, mas o pior é que, antes de atualizar  para o PS 1.6.0.9,  a versão 1.5.3.1 já estava com problemas, por isso eu atualizei. Te como eu recuperar só os produtos com imagens e combinações? E depois fazer uma nova instalação e subir os produtos novamente? 

Share this post


Link to post
Share on other sites

Sim. Simplesmente exporta os dados com um tool (p.ex. PrestaStoreManager) para um csv, instala uma versao original sem problemas e importa os produtos novamente com o Store Manager ou no back-office, mapeando as tabelas.

 

PrestaStoreManager vc. pode usar gratuítamente por 30 dias, depois ele nao mais funcionará sem licenca.

http://addons.prestashop.com/en/administration-tools-prestashop-modules/2937-store-manager-for-prestashop.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More