Jump to content

Recommended Posts

bonjour,

 

voilà mon problème avec des achat de plus de 70 kilos les points relay ne s affiche pas

et il y a un message erreur 99 en ligne rouge, pourtant tout est bien rentré

dans module de 1kilos à 70kilos tout fonctionne les points relay s affiche des que je dépasse 70 kilos plus de point relay bizarre si quelqu'un a une solution je vous en remerci.

Share this post


Link to post
Share on other sites
Bonjour,

 

peux tu préciser la version de prestashop utilisée, éventuellement mettre une capture d'écran par ce que je ne suis pas sûre de comprendre pour ton erreur 99 : il y a marqué ligne 99 dans le fichier xxx ou alors c'est dans la 99 configuration de poids pour les transporteurs...

Share this post


Link to post
Share on other sites

voila ce que j'ai rentré dans la base de donnée tout est correct

http://hpics.li/dcd65b6
http://hpics.li/deae106

 

voila l'erreur une foi la commande passé sur le site quand on depasse 70 kilos, on peu choisir mondial relay les frais de port s'affiche mais pas les points relay, et ca fait cette erreur avec ligne rouge.

 

http://hpics.li/3dcf47d


pour mon prestashop je suis en version 1.5.6.0

Share this post


Link to post
Share on other sites

 

Bonjour,
 
peux tu préciser la version de prestashop utilisée, éventuellement mettre une capture d'écran par ce que je ne suis pas sûre de comprendre pour ton erreur 99 : il y a marqué ligne 99 dans le fichier xxx ou alors c'est dans la 99 configuration de poids pour les transporteurs...

 

Bonjour,

 

je travaille avec Accrocarpe (je suis le développeur ayant mis la boutique en place).

Voici un descriptif complet du problème rencontré, évoqué dans un autre topic mais resté sans réponse à ce jour (l'assistance "technique" de Mondial Relay, quant à elle, ne donne aucun retour pour le moment):

 

Donc pour résumer, il s'agit d'une boutique Prestashop en version 1.5.6.0, avec le module Mondial Relay, en version 1.8.9.

 
Je rencontre des soucis sur le site après sélection de la méthode de livraison. Après appel à l'API Mondial Relay permettant de retourner les points relais disponibles (plus précisément dans le fichier modules/mondialrelay/classes/MRGetRelayPoint.php, méthode "send()"), j'obtiens systématiquement un code d'erreur 99 en retour, et ce lorsque le poids passé en paramètre excède les 70kg.
 
Voici un debug du tableau de paramètres envoyé au webservice pour un poids de 100Kg:
 
Array

(

[Enseigne] => XXXXX

[Pays] => FR

[Ville] => SARREBOURG

[CP] => 57400

[Taille] =>

[Poids] => 100000

[Action] =>

[security] => 150DF1736FAAD9C596D6787C0E873FC9

)

 
Voici ci-dessous le même tableau de debug PHP des informations fournies au webservice, mais avec un colis d'un poids de 50kg, et qui fonctionne parfaitement (la liste des points-relais disponible est bien affichée):
 
Array

(

[Enseigne] => EC003968

[Pays] => FR

[Ville] => SARREBOURG

[CP] => 57400

[Taille] =>

[Poids] => 50000

[Action] =>

[security] => 0A41EE8486E83BADAACC6B789C5BF14E

)

 
Concrètement, le message d'erreur affiché est le suivant;
There is an error number : 99
Details : Erreur générique du service. Cette erreur peut être dû autant à un problème technique du service qu'à des données incorrectes ou inexistantes dans la Base de Données. Lorsque vous avez cette erreur veuillez la notifier à Mondial Relay en précisant la date et l'heure de la connexion ainsi que les informations envoyés au WebService afin d'effectuer une vérification.
 
Pouvez-vous m'en dire plus sur l'erreur rencontrée? Y a-t-il éventuellement un paramétrage à mettre en place quelque part (poids maximum autorisé par exemple)?
 
Dernier point important: lorsque j'obtiens un message d'erreur, le montant des frais de ports est bien renseignée (avec le bon montant), ce qui veut dire que la tranche de poids est bien paramétrée dans le back-office.
 
En vous remerciant par avance!

Share this post


Link to post
Share on other sites

on effectue une commande sur mon site jusqu’à 70kilos les points relais s’affiche et tout fonctionne très bien mais dès qu’on dépasse 70kilos les points relais ne s’affiche plus et ça m’indique erreur 99

2544F006-3BA3-4714-AC98-562B17C4559D.jpeg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More