Jump to content
Sign in to follow this  
kris243

attribute and combination problem

Recommended Posts

hello guys

i have a problem in my store
customer ordered black color t shirt with xl size

but when she checkout the cart it is showing different color and size.

i checked in back office combinations are ok

can any help me guys

thank you

Share this post


Link to post
Share on other sites

Prestashop Version?
URL?

Are you sure you created the combination correctly?

Share this post


Link to post
Share on other sites

Difficult to help with so few information.

Did you make a try ? Did you reproduice this issue ?
If "yes", make a try with the PrestaShop default theme.

Share this post


Link to post
Share on other sites

@
kris243

Well i had a similiar problem and no one had reply`t then or give me a answer to try something, i say it is somewhere in the code off prestashop.
First a few questions,

Do u use SSL ?
In back-office / preferences/ scroll to the bottom what option is set by compatible template 1.1 YES Or NO.
The template you use is 1.1 or is it 1.2.xx ?

The problem that i had whas that for example,

I have a product red/blue/yellow/black so on the product page you can choose your color for example black, now you go to checkout your order and there you see not black but blue.
It choose always the first color that you have set as your default combination in this case it would be blue.
A other problem that you also have then is for example,
You have in stock 1 black/ 2 yellow / 2 blue /zero red , if you have the same problem that i had then you see only the total off 5 even when you tick red you still see 5 and you can also order the red one even when it is not in stock.
The red one isn`t red again cause in the checkout it is blue again.

Is this what you have ??

If you don`t use SSL then you can try to swicht YES/NO template 1.1 compatible and then try again and you see it proberly works then.
But if you have SSL then the only way to make the stock working again in combination with the SSL certificate is to set ( if you have a template 1.2.xx ) the option in preferences must be set to NO then.

What i have done to make it work is to edit the init.php and change line 107 http:// to https:// now the whole site is protected by SSL and the stock works again.


Greats ysco..

Share this post


Link to post
Share on other sites

@ ysco
thank you you are great!!!
I can try to swicht to NO template 1.1 compatible and all attributes works!!! ;-)
Regards Walter

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More