Jump to content
  • 0
lulaki

Cały sklep po SSL - nichciane rozwiazanie problemu

Question

Cały sklep po SSL nie dlatego ze tak bardzo dbam o bezpieczenstwo ale jako 'workaround'. Mianowicie, chcialem aby sklep byl wiarygodny i zapewnial bezpieczna wymaine danych. Kupilem certyfikat SSL DV (domain verification) i zaintalowalem. W sklepie ustawilem uzycie SSL dla logowania i zamowien. Na Chromie dziala super. Pojawila sie zielona klodka i osignalem to co chcialem. Kolejny test na FF i ... pojawia sie komunikat ze tam gdzie wchodze nie jest bezpiecznie (gorszy efekt niz jak nie ma SSL:)).

 

Wyglada na to ze w kodzie strony sa linki HTTP zamiast https i stad ten problem (ale czemu na FF jest a na Chromie nie ma). W kazdym badz razie nie bedac ekspertem w tym temacie wymusile caly skpe po SSL i problem zniknal (ale dziwne bo nadal sa linki HTTP w kodzie). 

 

Pytanie:

1) Co jest przyczyna ze na FF pojawia sie komunikat brak bezpieczenstwa przy zainstalowanym SSL (logowanie i zamowienia)

2) Czy SSL na caly sklep ma negatywny wplyw na SEO ?

 

Dzieki

 

Share this post


Link to post
Share on other sites

24 answers to this question

Recommended Posts

  • 0

Co dokładniej pobiera Ci przez http ? W pliku header.tpl zobacz czy nie pobierasz coś z http (facebook, analitycs, jquery) - jeżeli coś masz spróbuj zmienić na https.

Share this post


Link to post
Share on other sites
  • 0

a już zupełnie łatwiej będzie, gdy podasz url do sklepu to będize można sobie sprawdzić samemu co jest nie tak w kodzie ;)

Share this post


Link to post
Share on other sites
  • 0

przeanalizowałem kod i problem dotyczy tej wtyczki:

<script type="text/javascript" src="http://w.sharethis.com/button/buttons.js">/* <![CDATA[ *//* ]]> */</script>

jest ona dołączona do strony z produktem

 

możesz zweryfikować czy posiadasz taki moduł (sharethis) ?

Share this post


Link to post
Share on other sites
  • 0

Tak, mam zainstalowany i wlaczony, ale juz nie uzywam. 

Wylaczyc, odinstalowac co radzisz ?

Share this post


Link to post
Share on other sites
  • 0

jak chcesz korzystać, to zmodyfikować plik tpl modułu i zmienić http na https - lub {$base_url} na {$content_dir} w zależności od metody z której korzysta moduł.

Share this post


Link to post
Share on other sites
  • 0

przeanalizowałem kod i problem dotyczy tej wtyczki:

<script type="text/javascript" src="http://w.sharethis.com/button/buttons.js">/* <![CDATA[ *//* ]]> */</script>

jest ona dołączona do strony z produktem

 

możesz zweryfikować czy posiadasz taki moduł (sharethis) ?

wylaczylem modul. Kod zniknal ze strony produktu. Wylaczylem wymuszenie SSL w calym sklepie i przystapilem do testu.

Efekt niestety ten sam. na FfireFox wchodzac w 'kontakt' (przelacza na SSL) pojawia sie ! w trojkacie obok paska adresu i komunikat: Ta witryna nie dostarcza informcji o swojej tozsamosci. Polaczenie z ta witryna nie jest w pelni bezpieczne poniewaz zawiera ona nieszyfrowane elementy (np. obrazki).

Share this post


Link to post
Share on other sites
  • 0

strona główna:
sLZV4vv.png

 

koszyk:

TYfATcM.png

 

 

wszystko wygląda OK 

nie ma komunikatu o niezaszyfrowanych treściach

Share this post


Link to post
Share on other sites
  • 0

Mam ponownie wymuszone SSL. Ale kiedy wylacze pojawia sie blad  (chcialem zalaczyc screena ale nie wiem jak - klika image i prosi mnie o URL)

Share this post


Link to post
Share on other sites
  • 0

włącz pełny edytor posta, jest tam pole do wgrania plików

9xTfl0m.png

 

opcjonalnie wrzuć je na imgur.com i podaj linki

Share this post


Link to post
Share on other sites
  • 0

Screen w wejscia na sklep (np.kontakt) gdy wymuszenie uzycia SSL na wszystkich stronach sklepu jest wyłączone

 

post-727294-0-63971100-1389827771_thumb.jpg

Share this post


Link to post
Share on other sites
  • 0

cięzko cokolwiek powiedizeć na podstawie obrazka

to co byłoby potrzebne, to dostęp do sklepu w chwili gdy wyłączone jest wymuszenie SSL

Share this post


Link to post
Share on other sites
  • 0

Być może to przez ten fragment:
 

<link href="http://lulaki.pl/modules/feeder/rss.php?id_category=0&orderby=position&orderway=asc" title="Skontaktuj się z nami - Zabawki ręcznie robione" type="application/rss+xml" rel="alternate">

jeżeli nie korzystasz z RSS (a chyba ten link jest z tym związany) możesz usunąć tą linię całkiem.

Nie jestem pewny ale powinien znajdować się w pliku header.tpl

Share this post


Link to post
Share on other sites
  • 0

Dziekuje. Rozumiem ze jak dodam na stale https to problem powinien zniknac ? Jesli tak w ktorym pliku/plikach powinienem dokonac zmiany ?

 

edit. Ok. nie zauwazylem drugiego posta. 

Edited by d3v0n (see edit history)

Share this post


Link to post
Share on other sites
  • 0

Niestety. Wylaczylem modul 'feeder'. Kod ze strony zniknal. Problem wciaz istnieje.

 

Edit. Znalazlem winowajce. Tylko nie wiem jak naparwic

post-727294-0-93929900-1389912111_thumb.jpg

Edited by d3v0n (see edit history)

Share this post


Link to post
Share on other sites
  • 0

nie wiem jak jest w tym szablonie z którego korzytasz (masz zminifikowane pliki css więc trudno mi wskazać konkretny plik), ale w "standardowym" szablonie ten plik jest dołączany w pliku global.css (themes/TWOJ_SZABLON/css/global.css)

 

z tego co widzę - plik jest pusty.

więc można go usunać, wobec tego usuń ten kod:


@import "https://lulaki.pl/themes/theme681/css/grid_prestashop.css";

Share this post


Link to post
Share on other sites
  • 0

Dzięki. Pomogło!

 

Przywrocilem na razie oryginalny plik bo wystawilem ticket na ten problem i jestem cieakaw co mi powiedzia. Mysle ze gdzies jest bug bo jak wymuszam ssl w alym sklepie to tego problemu nie ma. 

 

Raz jeszcze dzieki ! Pozdrawiam

 

edit: Dostalem odpowiedz ze wsparcia technicznego gdzie zakupilem szabon:

 

The point is that its content (grid_prestashop.css) was moved to another file however you cannot just delete this file. Therefore it should be empty but with some blank spaces inside so the console errors won't appear.

Edited by d3v0n (see edit history)

Share this post


Link to post
Share on other sites
  • 0

Hej. Mam podobny problem związany z SSL (włączonym tylko na niektórych stronach, czyli koszyk, logowanie itp.). W chrome pojawia mi się komunikat  "Twoje połączenie z tą witryną nie jest w pełni bezpieczne". Wywaliłem bezpośrednie linki po http do obrazków, ale niestety problem dalej występuje. 

Możecie mi podpowiedzieć jak dalej debugować problem? Grepowanie po 'src="http://' wszystkich plików tekstowych było moim pierwszym hintem, ale jednak zwraca za dużo wyników... :)

 

Sklep: http://catofthemoon.com  

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, endriu107 said:

W konsoli przeglądarki powinno wyświetlać co jest wczytywane po http.

Dzięki, pomogło. Znalazłem winowajcę i już wszystko śmiga :)

Share this post


Link to post
Share on other sites
  • 0

Witam Wszystkich. Czy ktos by mi mogl odrobinke pomoc z certyfikatem ? Niestety mam wykrzyknik na klodce. Wszystkie odnosniki pozmieniane. Konsola niby pokazuje adres z bledami ale sprawdzajac w kodzie wyszystko jest po https. Siedze juz caly dzien i za chiny nie kumam. Moze jakas madrzejsza glowa cos podpowie. Z gory dziekuje.

Adres sklepu to www.tkaniny-meblowe.pl

Share this post


Link to post
Share on other sites
  • 0
On 7/21/2019 at 5:14 PM, polkompsa said:

Witam Wszystkich. Czy ktos by mi mogl odrobinke pomoc z certyfikatem ? Niestety mam wykrzyknik na klodce. Wszystkie odnosniki pozmieniane. Konsola niby pokazuje adres z bledami ale sprawdzajac w kodzie wyszystko jest po https. Siedze juz caly dzien i za chiny nie kumam. Moze jakas madrzejsza glowa cos podpowie. Z gory dziekuje.

Adres sklepu to www.tkaniny-meblowe.pl

(index):1507 Mixed Content: The page at 'https://www.tkaniny-meblowe.pl/' was loaded over HTTPS, but requested an insecure image 'http://www.tapicer-sulejowek.pl/images/ekoskora.jpg'. This content should also be served over HTTPS.
(index):1516 Mixed Content: The page at 'https://www.tkaniny-meblowe.pl/' was loaded over HTTPS, but requested an insecure image 'http://www.tapicer-sulejowek.pl/images/zakard.jpg'. This content should also be served over HTTPS.
(index):1525 Mixed Content: The page at 'https://www.tkaniny-meblowe.pl/' was loaded over HTTPS, but requested an insecure image 'http://www.tapicer-sulejowek.pl/images/plusz.jpg'. This content should also be served over HTTPS.
(index):1534 Mixed Content: The page at 'https://www.tkaniny-meblowe.pl/' was loaded over HTTPS, but requested an insecure image 'http://www.tapicer-sulejowek.pl/images/welwet.jpg'. This content should also be served over HTTPS.
(index):1543 Mixed Content: The page at 'https://www.tkaniny-meblowe.pl/' was loaded over HTTPS, but requested an insecure image 'http://www.tapicer-sulejowek.pl/images/fizelina.jpg'. This content should also be served over HTTPS.
(index):1552 Mixed Content: The page at 'https://www.tkaniny-meblowe.pl/' was loaded over HTTPS, but requested an insecure image 'http://www.tapicer-sulejowek.pl/images/skora.jpg'. This content should also be served over HTT

 

Zmien link na HTTPS

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More