Jump to content

Mise à jour 1.4.2.5 vers 1.5.6.1 les données produits, clients, panier etc sont vides


Recommended Posts

Bonjour,

 

alors après une tentative de mise à jour de la version 1.4.2.5 à la version 1.5.6.1 par 1click avortée

je tente la mise à jour manuelle

 

j'ai donc suivi les instructions du guide de mise à jour prestashop

et lorsque je tente l'installation sur monserveur local de ma base données récupérées (avec mes infos clients etc) j'ai ça:

 

Au moins une table avec le même préfixe a été trouvée, merci de changer votre préfixe ou de supprimer vos tables existantes

 

Help!!!

car si je mets un autre préfixe je fini bien l'installation, mais je n'ai plus aucun produit, clients etc!!!

merci d'avance

Share this post


Link to post
Share on other sites

Bonjour Gregory,

alors j'ai tenté la mise à jour lundi avec la dernière version du module upgrade et là je retente (me disant que j'ai ptet mal fait)

lundi, ma mise à jour a été faite et tous les produits avaient disparus, j'avais bien ma base clients, mes commandes mais plus aucun produit

 

là je viens de relancer la mise a jour automatique avec le module upgrade

et bien qu'il me marque "Settings update successful" en haut 

dans l'encadré est noté [Ajax/server Error for action upgrade Db]

Text status: "errors" error Thrown:" "jgXHR"

 

 

là la page de mon back office est en "loading" depuis 5 minutes et je n'ose pas y toucher de peur que ça fasse bugger 

 

merci de votre aide

Share this post


Link to post
Share on other sites

re bonjour le module upgrade est en version 1.2.5 oui 

alors du coup dans mon back office j'ai bien mes produits (enfin pas tous j'ai eu des pertes de données la dernière fois)

 

par contre si je mets ma boutique en fonctionnement et que j'essayede la voir j'ai une page blanche

 

je suis desespérée! cela veut il dire que je dois rester sur une version 1.4 de ma boutique alors que les nouvelles fonctionnalités ont l'air super?


voilà ce que j'ai en message sur le module upgrade :

version non modifiée de PrestaShop:
warning.gif 1 modifications de fichiers ont été détectées, dont 1 fichiers natifs (coeur et module) Afficher / masquer la liste


Fichier(s) de la solution (1)
  • config/defines.inc.php

Share this post


Link to post
Share on other sites

Re,

 

Non c'est quasiment normal vous utilisez des lors un template et des modules 1.4 sur une 1.5. Il y a du travail à faire après une mise à jour.

 

Faites afficher les erreurs au lieu de la page blanche svp. http://www.prestashop.com/forums/topic/229195-que-faire-en-cas-de-page-blanche-ou-partie-blanche-dans-le-shop/

 

Cordialement

Share this post


Link to post
Share on other sites

En fait mon template n'était pas cochez (template par défaut) par contre maintenant j'ai un autre souci le back office est tout en anglais ou presque du coup

 

là je ne sais pas quoi faire 

 

Share this post


Link to post
Share on other sites

voilà le message d'erreur quand je clique sur l'onglet modules en haut 

[PrestaShop] Fatal error in module dibs:
Access level to dibs::$smarty must be protected (as in class PaymentModule) or weaker

 

désolée je dois vous saouler mais je suis une grande débutante et même si je suis volontaire c'est un domaine colmpliqué

Share this post


Link to post
Share on other sites

voilà le message d'erreur quand je clique sur l'onglet modules en haut 

[PrestaShop] Fatal error in module dibs:

Access level to dibs::$smarty must be protected (as in class PaymentModule) or weaker

 

désolée je dois vous saouler mais je suis une grande débutante et même si je suis volontaire c'est un domaine colmpliqué

 

Pas de soucis, mais tous les ces questions ont été très largement posées sur le forum de mise à jour. En faisant une recherche vous verrez qu'il faut supprimer des modules 1.4. N'hésitez pas à confier certaines tâches à des agences ou freelances afin de vous recentrer vers la vente.

 

Cordialement

Share this post


Link to post
Share on other sites

encore un message d'erreur quand je tente la traduction du back office:  Warning! Your PHP configuration limits the maximum number of fields allowed in a form: 2000 for max_input_vars.

Please ask your hosting provider to increase the this limit to 4709 at least or edit the translation file manually.

 

 

mais c'est pas possible, vais je réussir à avoir un site à jour et actif :'(

Share this post


Link to post
Share on other sites

Re,

 

Il faut mieux s'entrainer à faire sa mise sur un serveur local en copiant le site.

 

Le problème essentiel la c'est que le module d'upgrade n'a pas pu aller au bout des étapes, sinon il aurait du vous mettre à jour la langue, supprimer ce modules etc. Mais sur des petits OVH, la mise à jour de la base tourne parfois en boucle (un problème de PID) ou dépasse la mémoire et du coup il ne fait pas les étapes ensuite. Etapes que vous devez donc faire manuellement malheureusement.

 

Cordialement

Share this post


Link to post
Share on other sites

maintenant que la mise à jour est faite puis je la laisser et 'réparer" les erreurs manuellement ou est ce trop "dangereux" ?

 

je vais regarder les pbs au fur et à mesure

 

mais j'avoue que je ne peux pas le laisser fermé plus longtemps je manque de rentré d'argent

 

merci de votre aide en tout cas

 

Julie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More