Jump to content

Passage de la 1.4.9 à 1.5.5


Recommended Posts

Bonjour,

J'aimerai savoir si il existe un module pour passer de ma 1.4.9 à une version 1.5.5 sans perdre mes infos : compte client, produit, photos etc...

j'aimerai installer une 1.5.5 propre et upgrader cette version avec ma Base de donnée de ma 1.4.9

ainsi qu'une parti de mes modules.

 

Merci d'avance à la communauté

 

www.aerographediscount.fr

Share this post


Link to post
Share on other sites

Oui il faut regarder les tuto de mises à jour, c'est prévu par prestashop :http://doc.prestashop.com/pages/viewpage.action?pageId=11272345 et http://doc.prestashop.com/download/attachments/1409083/Mettre-a-jour-PrestaShop.pdf tu as aussi des video sur youtube...

Par contre tous les modules que tu as acheté sont certainement prévu pour prestashop 1.4 exclusivement, donc renseigne toi auprès de chacun des webmasters de tes modules pour savoir si ils existe sur 1.5.

Share this post


Link to post
Share on other sites

bonjour ,

 

merci pour votre réponse.

 

actuellement ce que vous décrivez n'a pas lieu, puisque l'installation du template "simple responsive" et ses modules

(voir ici pour le template : http://www.prestashop.com/forums/topic/244041-free-simple-responsive-theme-15x/ )

ne provoque pas l'apparition des hooks correspondants, mais des erreurs liées

à la non-présence de ces hooks lors de l'interprétation du fichier xml lié à l'installation du thème+modules.

Edited by strapper (see edit history)

Share this post


Link to post
Share on other sites

Hello,

 

Ce thème n'est pas compatible 1.4 donc il va falloir me re expliquer ce problème de hooks manquants venant d'une 1.4, car pour l'instant on ne reproduit pas. On va mener encore quelques tests venant d'une 1.5.4.1 avec ce thème.

 

Comment vous pouvez venir d'une 1.4.10 alors que nous n'arrivons pas du tout à installer ce thème en 1.4, il y a des centaines d'erreurs.

 

Cordialement

Edited by Gregory Roussac (see edit history)

Share this post


Link to post
Share on other sites

bonjour,

 

effectivement vous ne pouvez pas installer un template pour ps 1.5 sur un ps 1.4,

ce qui a été mal compris.

 

http://forge.prestashop.com/browse/PSCFV-10228

 

ça me paraissait tomber sous le sens qu'un template pour prestashop 1.5

s'installait -après- une mise à jour vers prestashop 1.5 :)

 

merci d'avoir constaté que les hooks spécifiques à prestashop 1.5 ne se créent effectivement pas après une mise à jour

depuis prestashop 1.4... attention aux "id" des hooks existants svp,

comme décrit dans ce rapport de bug...

Share this post


Link to post
Share on other sites

Hello,

 

Je suis désolé mais il y a confusion et ce n’était pas très clair au contraire.

 

Venant d'une 1.4, l'upgrade ne réinstalle pas (encore) pour vous les modules (en fait il manque les methodes d'upgrade dans les modules), seuls les fichiers sont mis à jour. Si ces modules ont de nouveaux hooks ou de nouvelles tables, il faut les réinstaller vous même.

 

Si vous installez votre thème en 1.5 ("actuellement ce que vous décrivez n'a pas lieu, puisque l'installation du template "simple responsive" et ses modules" >> je ne vois pas comment vous auriez cela en 1.5 donc pour moi ce n'est pas juste), les hooks sont crées dynamiquement. je ne comprends donc pas comment il peut vous manquer des hooks si vous installez votre thème en 1.5.

 

Les hooks se créent dynamiquement, même si vous venez d'une 1.4, cela n'a pas d'influence. Cela n'a d’influence que sur les modules installés en 1.4. Ce qui doit être corrigé, ce que répond Jerome, c'est qu'il faille mettre a jour tous les modules pour pouvoir gérer leur propre mises à jour d'une 1.4.

 

Les modules installés en 1.4, qui ont des nouveaux hooks en 1.5 ou de nouvelles tables doivent être re installés manuellement. Typiquement le module homefeatured, dont la css en 1.5 n'est plus gérée après migration, car l'accrochage sur ce hook n'existait pas en 1.4

 

Cordialement

Share this post


Link to post
Share on other sites

Quand je vous relis, je comprends que venant d'une 1.4, votre thème ne peut s'installer car il manque des hooks. La specificité de la 1.5 c'est qu'il y avait trop de hooks, donc maintenant si les modules veulent se greffer sur un hook qui n'existe pas, il est crée à la volée. Pourquoi votre thème renvoit il des erreurs a l'installation je ne comprends pas ce ticket définitivement ! :unsure:

 

Cordialement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More