Jump to content
  • 0

Problem z tłumaczeniem e-maili


przemko
 Share

Question

Zainstalowałem sklep tydzień temu. Przebijam się wolno i dotarłem do momentu, w którym napisałem sam do siebie email.

E-mail po otrzymaniu wygląda tak:

Votre message a bien été envoyé à notre service client.

Twoja wiadomość została prawidłowo wysłana.

Wiadomość : test

Referencje zamówienia : -

Załącznik: -

Nous vous répondrons dès que possible.

 

Chciałem to zmienić. Znalazłem nawet miejsce i przyczynę. Przyczyną jest pewnie to, że ten francuski tekst jest napisany biało na białym tle w szablonie (Lokalizacja->Tłumaczenia).

 

Problem jest jednak większy, ponieważ przy próbie zapisu poprawionego formularza otrzymuję błąd:

 

Nie mozna zapisać pliku języka dla tematów e-maili, ścieżka to: /<<tu moja nazwa serwera>>/themes/default/mails/pl/lang.php

 

A niestety takiej ścieżki nie mam w strukturze katalogów. Jedyne, co mam to: /<<tu moja nazwa serwera>>/themes/default.

Katalogu mails niestety nie mam.

 

Prawdopodobnie gdzieś jest zapisana zła ścieżka do której ma zapisywać szablony. Dziwne tylko, że wie skąd je odczytywać.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Dodam może jeszcze, że temat e-maila, który do mnie doszedł brzmi: [nazwa sklepu] Your message has been correctly sent #ct1 #tc36erJI7xFNKc

 

Jak można zamienić ten tekst na polski?

 

W szablonach emaili szukanie po "your message" daje tylko jeden wynik. Formularz o nazwie "Temat dla reply_msg". Tam będzie jednak podobny problem. Tłumaczenie brzmi:

Dostępna jest odpowiedź na Twoją wiadomość #ct%1$s #tc%2$s

Obok jest trójkącik informujący "To wyrażenie używa specjalnej składni %1#s, %2$s". Jednak jak łatwo zauważyć to nie jest to samo co "#ct%1$s #tc%2$s". Prawdopodobnie więc nie zadziała.

Share this post


Link to post
Share on other sites

  • 0

Cześć. Powiedziałbym "prawie działa" :) Usterki, które wciąż występują:

1. E-mail, który przyszedł na adres obsługi klienta miał w temacie "Wiadomość z formularza kontaktowego [no sync]". Chciałem się pozbyć tego z końca, więc wszedłem w edycję szablonu, znalazłem miejsce i zdziwiłem się, bo przy opisie "Temat dla contact" było puste pole edytowalne. Wpisałem więc tam "Wiadomość z formularza kontaktowego". Po zapisaniu i wysłaniu emaila tekst w tytule emaila zmienił się na "Message from contact form [no_sync]". Chciałem wrócić do poprzedniego, ale niestety pole edytowalne przy opisie "Temat dla contact" jest nadal puste.

 

2. Podobna sprawa po stronie klienta. W pierwszej wiadomości tytuł brzmiał 'Przesłałeś wiadomość #ct1 #tc36erJI7xFNKc'. Drugi (po wyżej opisanej zmianie) brzmiał Your message has been correctly sent #ct1 ......

 

Jakiś pomysł co z tym zrobić?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More