Jump to content

przemko

Members
  • Posts

    27
  • Joined

  • Last visited

Everything posted by przemko

  1. Hi all, Hope you will be able to help me finding (and fixing) a bug that seems to be the same as described above. I have a shop (version 1.7.6.5, PHP 7.2, default/classic prestashop template) and everything works fine.... except product variants. When a user opens a product page to select different color of that product, the page displays a message "An error occurred while processing your request" under the "Add to cart" button. The inspect console tells that the server returns "500 Sever Error", saying "Oops, something went wrong." Log on the server says "POST /index.php?controller=product&token=7c5103bec05826f1beae2462fd282f67&id_product=102&id_customization=0&group%5B2%5D=8&qty=1 HTTP/2" 500 Does anybody know what can be the reason and how to fix this? I'm not sure where to look for a reason and I'm not too skilled to debug and analyze the source code. I can implement a fix in code if somebody will tell where to fix and what.
  2. @tdsoft: I'm sorry, but it is not possible to give you access to a live shop with client data (GDPR violation) and also where we have connections with banks, card acceptants, couriers, etc. The thing is more than simple: you install the plugin on any server, you open the page, you click inspect and you see the problem. If that's not possible, we may set a zoom session and I can show you live, but please believe me: the problem is clearly visible when you just inspect the front-end in any browser (Chrome, FF, Opera)
  3. Hello @tdsoft. Yes, I did that (commented out that line). Otherwise I was getting errors in the console and other jQuery components didn't work. Nevertheless, the truth is that all the warnings that you see in my post above are logged only when your module is activated. When it is deactivated, then the log console is empty. That means all these warnings are caused by your module. Please note that the above warnings are also thrown on pages where the zoom function is not used (for instance on main page or on catalog pages, where it is disabled in module configuration on admin side). It would be really great if you fix that. The module works great, but it clearly does something wrong.
  4. @tdsoft - Can you please release a version where this bug is corrected? It also appears on my site, so I had to comment this line to stop avalanche of jquery errors. In addition, there are other things which would be nice to fix: There is a log appearing in the console "Added jQuery!" - even on pages where zoom is deactivated (for instance on my catalog pages). When I use the zoom lens, there is another information logged, that is "False" reported by core.js in line 28. Next to this "false" there's a counter which counts up when a cursor stays on the picture. it only stops counting when the cursor is taken out of the picture (see picture below for numbers on blue background). There are other errors showing: In core.js line 39, position 74593: Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help http://xhr.spec.whatwg.org/ Source map error: Error: request failed with status 404 Resource URL: https://--mysite--/themes/core.js Source Map URL: core.js.map
  5. I just noticed exactly the same issue as elle effe, that is: when you open a category page with many products, the check for available number of items works only on the first page. When you click "next" or a link to further pages of that category, the script responsible for checking stock when you increase/decrease number of ordered items fails. I noted two side effects: 1. There is no more control over how many items you may add to cart 2. jQuery fails on that page and page starts to throw/log errors in browser's console @HiPresta: can you please see what's wrong and fix?
  6. I still see it available for download on previous page (first post in this thread).
  7. It's available in that module's config. Go to admin page, modules, click configure.
  8. When you are on exactly that page, can you scroll down until you see a group "ADDTOCARTBUTTON" and open it? Then you will see the following:
  9. Tak. Ten search ma wpisany domyślnie chyba tylko jeden hook. Jeśli chcesz go powiesić na innym, to musisz wyedytować sobie plik z tego modułu, dodać jego rejestrację do innego hooka ręcznie, a potem dopiero zainstalować. Jeśli masz zainstalowany obecnie, to musisz odinstalować najpierw, potem zrobić zmiany, a potem zainstalować ponownie. U mnie zadziałało, dodałem go do displayNav1 i działa bez problemu. W pliku bonsearch.php zrób dwie zmiany (popatrz co ja zrobiłem, żeby dodać w displayNav1): public function install() { $configurations = $this->getConfigurations(); foreach ($configurations as $name => $config) { Configuration::updateValue($name, $config); } return parent::install() && $this->registerHook('displayTop') && //dodaję rejestrację modułu dla hooka displayNav1 $this->registerHook('displayNav1') && $this->registerHook('displayHeader'); } Druga zmiana (na samym dole pliku): public function hookDisplayHeader() { $this->context->controller->addJS($this->_path . '/views/js/bonsearch.js'); $this->context->controller->addCSS($this->_path . '/views/css/bonsearch.css'); } public function hookDisplayTop() { $this->smarty->assign(array( 'root_url' => _PS_BASE_URL_.__PS_BASE_URI__ )); return $this->display($this->_path, '/views/templates/hook/bonsearch.tpl'); } //dodaję przyczepienie do displayNav1 public function hookDisplayNav1() { $this->smarty->assign(array( 'root_url' => _PS_BASE_URL_.__PS_BASE_URI__ )); return $this->display($this->_path, '/views/templates/hook/bonsearch.tpl'); }
  10. Can you read what I wrote 1 post above few days ago? I think that's the answer...
  11. OK. Dzięki za podpowiedź. Wygląda na to, że po podmianie na serwerze w tym katalogi, w panelu admina pokazują się właściwe szablony. Natomiast edytowanie szablonów przez panel admina nie działa. Na tę chwilę już nie jest to aż tak mocno istotne, bo posprzątałem po stronie serwera, ale sprawa jest dziwna.
  12. Cześć, Mam problem z podmianą szablonów emaili w Presta 1.7.6.5. Kiedy wchodzę od admina w tłumaczenia i zmieniam treść, to po zapisie nic się nie dzieje. W sensie zmiany się nie zapisują. W związku z tym podmieniłem zawartość katalogu mails/pl na serwerze i po wejściu w admin->tłumaczenia nadal widzę stare szablony. Nie mam pojęcia o co chodzi. W katalogu mails mam podkatalogi pl, en i themes. Emaile podmieniane były polskie i te, które widzę w adminie też są polskie, na podstawie których robiłem moje, więc to nie jest tak, że korzystam np. z angielskich. Wyczyściłem cache w menu wydajność oraz usunąłem katalog var/cache/prod, wyczyściłem cache przeglądarki i dalej widzę stare szablony w panelu admina, a na serwerze są nowe. Możecie coś poradzić?
  13. You need to chose "module translation" in the menu, not "template translation" because the module contains its own label on cart button instead of reference to the template button. The good thing is that I see the developer put in comments that in the future this button should be done by importing the standard/template cart button, so when that happens, all will be done automatically. But for now you need to translate it separately. Also please mind that there are two save buttons "Save" and "Save and stay" on the translation page. The "Save and Stay" does not work for me properly, so I was using "Save" and going back and forth to this translation. Would be good if in the future there is just one translation block with one "Save" button and one "Save and Stay" button instead of multiple ones.
  14. I installed it on 1.7.6.5 without issues. The downloaded zip file is called "UNZIP_FIRST_BAZoomMagnifier.zip". Did you unzip it first and then tried to install the zip that is inside?
  15. Hello, First and foremost: thanks for this great module! I installed it and see on console that it throws warnings. The reason is this line: if ((src == baproductzoom_cover_img_old) && noevent == false) { console.log(noevent); return false; } Is this part needed or it can be removed? The warning message on console contain text "false" and reference to the part of code you see above.
  16. Hi all, I just made the updagrade from 1763 and 1765 using 1-click upgrade and it failed (time-out). The last info on the screen was that 55 modules needs to be updated. What should I do in this sitiuation? Can I somehow manually finish the upgrade? If yes, what's the steps I need to take?
  17. Agreed. It doesn't work for me either. @BonPresta - I have installed your great search module and spot the same issue. Can you please help? It displays all matched products in search results, no matter on how many I set as a limit on the back-end. Back-end value is saved, but just not used by front-end. Side question: Is it possible to add also as back-end option searching in description, not just in product name? Can you please help me fixing the issue? My set-up: classic Prestashop theme, PS version: 1.7.6.3 Will appreciate a lot your quick help. I hope this error is easily solvable. Thanks!
  18. Dzięki za informację. W sumie szkoda, bo rozwiązałoby trochę problemów. Może ktoś w przyszłości dorobi ten mały fragment i moduł byłby w pełni funkcjonalny. Mam jeszcze kilka przemyśleń w związku z tym problemem faktur i paragonów dla kogoś, kto chciałby się w przyszłości zająć tematem :) Na chwilę obecną po zainstalowaniu modułu w tej wersji, która jest: po stronie klienta w historii zamówień widać link do dokumentu (faktury), więc jeśli ktoś wybrał fakturę, to ok. Natomiast jeśli ktoś wybrał paragon i go dostanie wraz z przesyłką (z kasy fiskalnej), a w zakładce swojego profilu widzi automatycznie wygenerowany dokument faktury, to robi się z tego problem prawny. Jeśli to trafi do jakiegoś urzędu skarbowego, to można mieć problem, że się daje klientowi zarówno fakturę jak i paragon. Trzeba więc albo zablokować możliwość ściągania przez klienta faktury ze strony albo nazwać fakturę "potwierdzeniem operacji" albo "rachunkiem", żeby się nie narażać. Wtedy jednak faktury trzeba gdzieś generować oddzielnym oprogramowaniem (przepisując dane), co daje szansę pomyłek i wymaga pracy. Rozdzielenie tych dwóch dokumentów byłoby o tyle pomocne, że można by było po prostu wydrukować same faktury z Presty i przekazać do zaksięgowania i nie trzeba by było "odcedzać" faktur, które były tak naprawdę paragonami, bo paragony byłyby innym rodzajem dokumentów.
  19. OK. Fixed. In theme.css you need to change: .carousel .carousel-inner { height: 340px } to: .carousel .carousel-inner { height: auto } Would be good if someone from Prestashop include this fix into standard, so it is not overwritten with next update.
  20. OK. Fixed. In theme.css you need to change: .carousel .carousel-inner { height: 340px } to: .carousel .carousel-inner { height: auto }
  21. OK. Naprawione. W theme.css trzeba było zmienić: .carousel .carousel-inner { height: 340px } na: .carousel .carousel-inner { height: auto }
  22. Hej, Mam szybkie pytanie: po zainstalowaniu i przetestowaniu wygląda to tak, że pomimo wyświetlanej informacji po stronie admina, że został wybrany paragon, mimo wszystko generuje się automatycznie faktura. Czy da się to jakoś zmienić, żeby przy wybranym paragonie generował się jakiś inny dokument (paragon)? Wiem, że taki dokument nie będzie fiskalny, więc muszę go sobie potem wydrukować na fiskalnej, natomiast jeśli dokument faktury tak czy siak się generuje i mam po prostu zignorować, to księgowość będzie czepiała, że numeracja faktur ma dziury, więc jest podstawa dla urzędu skarbowego do przeprowadzenie kontroli... Dlatego idealnie byłoby, gdyby zakup z zaznaczonym paragonem powodował wygenerowanie jakiegoś innego rodzaju dokumentu.
  23. Hi there, I installed clean Prestashop 1.7.6.3 and use classic theme. I attached the standard slider to displayBanner hook, so it is displayed as full width. The bug that I spot is that when I enlarge browser width from "mobile-like-size" up, the slider is fully visible and the banner inside is enlarged properly and proportionally only until the picture in banner reaches width of 1182px. When it is resized to 1183px, it gets overlapped by the content & background of displayNav hook. When I increase the width even more above 1200px, the slider image is still enlarging, but its bottom part is more and more hidden under the background of the item below. I think that may happen when the browser as whole exceeds 1200px. Probably CSS is not prepared for that, so when the media/min-width property is more than 1200px or media/max-width is set to 1199px and there is no instruction in css what to do next, then the banner is spoiled. Can you please quickly help me fixing the problem? I'm not css and prestashop guru, so I'm not sure what to change. I tried to change something in the the carousel configuration in theme.css, but it didn't work. By the way - the cache in my prestashop is switched off and I clear cache every time I change something (blindly) in css just to be sure I see fresh version. As a test banner I was using 1110x340 px and 1920x400 px images. See attached picture. Can you please help? I this issue is probably easy to fix and it looks bad on my shop. Thanks a ton!
  24. W az.pl adres/nazwa dostępu do bazy danych jest dziwaczna i zawiera id hostingu, czy jakoś tak. Jeśli podajesz localhost, to się prawdopodobnie nie połączy i może dlatego masz problem. Poprawną nazwę znajdziesz w panelu (w moim przypadku tzw. stary panel). Ogólnie to odradzam az.pl. Właśnie jestem w trakcie przenoszenia się od nich do innego operatora. Powód jest prosty: czysta presta po zainstalowaniu rzucała co chwilę błędami typu Internal Sever Error albo Resource Limit Exceeded. Kiedy zgłaszałem to do nich, to mówili, że to są błędy, które mogą wynikać z czegokolwiek, więc mi nie pomogą zbytnio w ustaleniu co jest powodem. Jako poradę zaoferowali mi przejście na droższy abonament i wtedy wszystko miałoby być w porządku. Do tego od 3 tygodni czekam na naprawę błędu, bo na stworzonej subdomenie, na której miał stać sklep nie da się uruchomić serwisu www. Komunikat przy próbie uruchomienia www na tej subdomenie jest typu "Błąd 1234567, skontaktuj się z administratorem". Co kilka dni, kiedy pytam, to odpowiedź jest: nasi administratorzy pracują nad rozwiązaniem problemu.
  25. Cześć, Mam nadzieję, że ktoś będzie mi w stanie szybko pomóc, bo problem chyba nie jest trudny do rozwiązania, a jest irytujący dla osoby nie znającej się mocno na css. Założyłem czystą prestę 1.7.6.3 i theme classic. Przepiąłem standardowy Slider do displayBanner, żeby był w pełnej długości ekranu. Są jednak pewne problemy, bo strona się trochę rozjeżdża. Pomożecie? Problem 1: kiedy strona w przeglądarce jest węższa niż 1200px (a obrazek w slajderze jest nie większy niż 1182px), to nie ma problemu. Przy zmianie rozmiaru dobrze się skaluje i wszysto widać. Natomiast kiedy poszerzam przeglądarkę i obrazek w slajderze poszerza się na 1183px lub powyżej, to obrazek ze slajdera zaczyna chować się pod elementy menu, które są w poniżej (elementy z displayNav). Załączam obrazek przedstawiający "mały ekran" i "poszerzony ekran". Problem 2: u dołu strony pojawił się pasek przewijania, który przewija tak naprawdę tylko kilka pikseli. To też jakiś efekt uboczny po wsadzeniu tego slidera do displayBanner. Pomożecie mi proszę naprawić problem? Co już robiłem: - wyłączyłem cache, żeby mieć zawsze świeży widok, natomiast i tak czyszczę cache z poziomu admina w presta, na wszelki wypadek - zmieniałem w theme.css height dla elementu carousel item z 340px na 440px, ale nie pomogło. Będę wdzięczny za wszelką pomoc.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More