Jump to content

Recommended Posts

Bonjour à toutes et à tous.

 

J'ai un souci pour upgrader mon site de la version 1.4.9.0 vers la version 1.5.3.1 (la dernière quoi).

 

Lorsque j'essaie de le mettre à jour via le module 1-click upgrade (version 1.0.5 téléchargée aujourd'hui même, mais j'ai eu le même problème avec chaque version depuis la 1.0.1...), on me retourne l'erreur suivante : "Erreur Javascript (parseJSON) détectée pour l'action"updateConfig".Début de la restauration ..."

 

En cherchant un peu, j'ai trouvé une solution proposée par Bruno Leveque ici : http://www.prestashop.com/forums/topic/192406-cant-auto-upgrade-any-version-same-error-every-time/ mais qui malheureusement ne résout en rien mon problème.

 

Ci-joint le rapport de la console Firebug.

 

Est-ce que quelqu'un pourrait m'aider ? SVP ? Merci !

post-385214-0-37270400-1360681158_thumb.jpg

Share this post


Link to post
Share on other sites

Bonjour à toutes et à tous.

 

J'ai un souci pour upgrader mon site de la version 1.4.9.0 vers la version 1.5.3.1 (la dernière quoi).

 

Lorsque j'essaie de le mettre à jour via le module 1-click upgrade (version 1.0.5 téléchargée aujourd'hui même, mais j'ai eu le même problème avec chaque version depuis la 1.0.1...), on me retourne l'erreur suivante : "Erreur Javascript (parseJSON) détectée pour l'action"updateConfig".Début de la restauration ..."

 

En cherchant un peu, j'ai trouvé une solution proposée par Bruno Leveque ici : http://www.prestashop.com/forums/topic/192406-cant-auto-upgrade-any-version-same-error-every-time/ mais qui malheureusement ne résout en rien mon problème.

 

Ci-joint le rapport de la console Firebug.

 

Est-ce que quelqu'un pourrait m'aider ? SVP ? Merci !

J'ai le même problème; avez vous trouvé une solution entre temps ?? Merci d'avance

Share this post


Link to post
Share on other sites

bonjour,

pour ma part j'ai une page totalement blache qui s'affiche et rien...

merci pour ce topic

Share this post


Link to post
Share on other sites

 

Lorsque j'essaie de le mettre à jour via le module 1-click upgrade (version 1.0.5 téléchargée aujourd'hui même, mais j'ai eu le même problème avec chaque version depuis la 1.0.1...), on me retourne l'erreur suivante : "Erreur Javascript (parseJSON) détectée pour l'action"updateConfig".Début de la restauration ..."

 

 

 

Bonjour,

 

Il faut vérifier les droits d’écriture pour le serveur sur le dossier /adminXXX/autoupgrade/

 

Checkez que ce dossier est bien inscriptible, par exemple qu'il soit bien en 777 récursif peut aider.

 

En gros il n'arrive pas à écrire de fichier dans ce dossier a configuration que vous enregistrez.

 

Cordialement

Share this post


Link to post
Share on other sites
Bonjour,

 

J'ai eu le même problème lors d'une migration de PrestaShop  (de 1.5.6 à 1.6)

 

Dans mon cas il ne s'agissait pas d'une question de droits d'écriture, mais à cause d'une erreur qui s'affichait au début du retour en json, le rendant inutilisable pour le javascript.

 

L'erreur résultait d'un problème du serveur SQL du type :



Warning: mysqli::mysqli(): Headers and client library minor version mismatch. Headers:50535 Library:50619 (...)


 

J'ai solutionné ça en éditant un fichier du module  "Mise à jour en un clic" (version 1.4.0) :



/modules/autoupgrade/db/MySQL.php


 

à la ligne 37 (pour la version 1.4.0)  :



if (!$this->link = @mysql_connect($this->server, $this->user, $this->password))


 

J'ai simplement rajouté @ devant mysql_connect afin que rien ne soit retourné en cas d'erreur.

Notez que cette méthode est déjà utilisée dans les autres fichiers de connexion aux bases de données du module.

 

La migration a pu ensuite s'effectuer sans problème.

 

En espérant que ça peut aider ceux qui rencontrent ce type de problème.

Share this post


Link to post
Share on other sites

Bonjour,

 

Merci pour la remontée. Je ne connais pas ce warning. Je pense votre driver mysql ne correspond peut etre pas au serveur mysql. En général il faut mieux eviter de migrer avec le display error à on pour eviter les json contenant des erreurs/warning php. Je commit cependant le @.

 

Merci. Cordialement.

Share this post


Link to post
Share on other sites

Bonjour Gregory,

 

Merci de votre retour.

 

Effectivement display error à off aurait solutionné également le problème. Mais comme nous faisions une migration sur un espace de test, justement pour traquer les éventuelles erreurs de nos modules et thèmes perso lors du passage en 1.6, nous avions besoin d'avoir display error sur on (plus simple que les logs lors des tests).

 

Et le warning est bien un problème lié au driver mysql, mais c'est une autre histoire... Néanmoins pour ceux que ça intéresse, Dotdeb en parle sur cette page :

http://www.dotdeb.org/2014/04/04/about-the-mysql_connect-headers-and-client-library-minor-version-mismatch-warning-2/

 

Bonne journée

Share this post


Link to post
Share on other sites

Bonjour,

 

Je ne vois pas trop le rapport entre les deux erreurs désolé.

 

Essayez de mettre des droits 777 récursifs sur /var/www/vhosts/archerie-de-champagne.com/httpdocs/admin_archerie/autoupgrade/

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour à toutes et à tous.

 

J'ai un souci pour upgrader mon site de la version 1.4.9.0 vers la version 1.5.3.1 (la dernière quoi).

 

Lorsque j'essaie de le mettre à jour via le module 1-click upgrade (version 1.0.5 téléchargée aujourd'hui même, mais j'ai eu le même problème avec chaque version depuis la 1.0.1...), on me retourne l'erreur suivante : "Erreur Javascript (parseJSON) détectée pour l'action"updateConfig".Début de la restauration ..."

 

En cherchant un peu, j'ai trouvé une solution proposée par Bruno Leveque ici : http://www.prestashop.com/forums/topic/192406-cant-auto-upgrade-any-version-same-error-every-time/ mais qui malheureusement ne résout en rien mon problème.

 

Ci-joint le rapport de la console Firebug.

 

Est-ce que quelqu'un pourrait m'aider ? SVP ? Merci !

 

 

Salut,

 

J'ai moi-même eu ce message d'alerte ("Erreur Javascript (parseJSON) détectée pour l'action"updateConfig".Début de la restauration ...") lors d'un essai de mise à jour de Prestashop 1.4.8.3 à la version 1.6.0.9, alors que lors d'une précédente mise à jour, tout s'était très bien déroulé.

 

Cela ne provenait pas du fichier de php.ini (tous mes paramètres serveurs étaient compatibles avec la nouvelle version Prestashop et la configuration demandée par le module étant donné que j'étais en local), je n'ai pas non plus touché au fichier Db.php (comme cela est mentionné dans le tutoriel d'aide à la mise à jour suivante, http://doc.prestashop.com/display/PS16/Automatic+update ).

 

L'erreur provenait du fait, que lors du rapatriement en local, j'ai bien modifié le Nom de domaine côté back office, mais j'avais omis de le modifier également dans le fichier : config/settings.inc.php dans define('__PS_BASE_URI__', '/');, ce qui ne transparaissait puisque le site fonctionnait parfaitement, seul le module 1-click Upgrade refusait de s'exécuter. Une erreur bête, qui peut certainement arriver à d'autres. Si tel est le cas, j'espère vous faire économiser quelques minutes de frustrations inutiles ;)

Share this post


Link to post
Share on other sites

Bonjour,

 

Ce sont les erreurs au moment de l'arret de l'upgrade ?

 

Par ce que je ne pense pas que ce cela soit ça le problème. Il faudrait plutot regarder directement dans les logs Apache d'erreur.

 

A priori il dit que ce fichier /var/www/vhosts/archerie-de-champagne.com/httpdocs/config/index.php est manquant ou ne peut pas etre lu.

 

Ensuiet il dit qu'un declaration dans ce fichier d'override /var/www/vhosts/archerie-de-champagne.com/httpdocs/override/classes/controller/FrontController.php ( installé par un module probablement) n'est plus compatible avec la defiition de la fonction dans le coeur. Dans ce fichier vous pouvez rempalcer     public function displayHeader() par     public function displayHeader($display = true) pour que cet avertissement disparaisse. Encore une fois ce ne sont probelement pas la raison de l'arret de l'upgrade.

 

Cordialement

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More