Jump to content
Sign in to follow this  
arobase

[Résolu] Disparition de tous les produits et catégories niveau backend

Recommended Posts

Bonjour,

Mon problème peut paraître "déjà lu" mais pourtant, y a des dissemblances avec les cas recensés.

Tous les produits et toutes les catégories ont disparu du Backend et du frontend. Jusque là, on a déjà vu.

Explication : Après installation de PS version 1.1.0.5 avec le template de base, je me suis connectée une 1ère fois dans le back, histoire de visiter. Lors de cette 1ère visite, les produits fictifs (téléphones mobiles) s'affichaient normalement. J'ai juste parcouru tous les onglets, j'ai touché à rien. Me suis déconnectée. Puis lors de la connexion suivante, plus rien dans le catalogue. Je n'avais pourtant encore touché à rien. L'onglet "produits" a disparu ainsi que celui des "catégories".

POURTANT :
J'ai vidé mon cache,
J'ai vérifié sur plusieurs navigateurs,
Et je le répète, je n'ai rien modifié entre ma 1ère visite et la suivante.

ça me fait penser à une espèce d'expiration du genre "si vous ne travaillez pas sur le site dans les jours suivants, tous les produits s'autodétruiront..."

Trève de mauvaise boutade... quelqu'un peut m'aider ?

Merci d'avance !

9066_eARLvz6EpDvJKRLqBDlK_t

Share this post


Link to post
Share on other sites

Essaye d'afficher un éventuel message d'erreur en faisant comme suit :


Page blanche ou incomplète : afficher les erreurs PHP

Lorsque le FO et/ou le BO affichent une page blanche, ou incomplète sans qu'aucun message d'erreur n'apparaisse, il est nécessaire d'activer l'affichage des erreurs PHP pour en connaître la cause.

Dans le fichier config/config.inc.php mettre
@ini_set(‘display_errors’, ‘off’);
à 'on'.

Réactualiser la page concernée et si ça affiche une erreur, copier/coller une partie de l'erreur dans l'outil de recherche du forum.
Si aucun topic utile n’est trouvé, poster le message d’erreur en question dans un topic en cours en rapport avec le problème ou créer un topic.

Share this post


Link to post
Share on other sites

Merci pour le tuyau,

J'ai modifié le fichier config et maintenant le message d'erreur s'affiche.

Je repars à la conquête de la solution...

Share this post


Link to post
Share on other sites

Finalement je reviens ici.. la fonction recherche du forum ne donne rien et je sais pas où poster vu que je ne cerne pas trop mon blem.

ça concerne une erreur sur une ligne qui n'existe pas... ?

Voilà le message d'erreur : Fatal error: Cannot redeclare class AdminProducts in /...AdminProducts.php on line 4782

Hors mon fichier AdminProducts.php comporte même pas 2500 lignes..

Merci pour vos réponses.

Share this post


Link to post
Share on other sites

Bon en fait les produits ont même disparu de la base de données... étrange.

du coup, on repart du début en re-uploadant presta.

Merci quand même

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More