Jump to content

{résolu} Gros pb d'affichage sur Internet explorer


Le-cathare
 Share

Recommended Posts

Bonjour,

 

J'avais eu ce problème qui était provoqué par l'installation du module thème mobile : footer et top menu décalés, produits phares affichés aléatoires.

Je n'ai donc pas pu installer ce module, en tout cas avec mon thème actuel.

En espérant que cela puisse vous aider.

Share this post


Link to post
Share on other sites

Non c'est bon tout est revenu dans l'ordre...

(les appels css et js étaient dans la balise <body> au lieu de <head>)

 

étrange que ce module fabricant natif déconne sur un theme Prestashop :(

 

V++

 

Atch

Share this post


Link to post
Share on other sites

  • 3 weeks later...

A par le thème mobile je me rappel pas avoir installer autre chose... et j'vais désinstallé le module fabriquant.

Je vais tester en désactivant quelques modules pour voir si ça marche !

 

Edit:

Ah bah voilà j'avais du mal désactiver le thème mobile maintenant c'est comme si de rien étais. Par contre j'ai plus de thème mobile. :(

Edited by guillaumeg33 (see edit history)

Share this post


Link to post
Share on other sites

  • 1 month later...

Prestashop 1.4.7 de peur de passer encore à la 1.5 "je dis ca comme ca juste pour les MAJ automatique qui foirre encore"

 

Bref mon retour d'expérience pour le vilain IE 9 ...

Tout fonctionne sur Firefox, Chrome, Safari pour ne siter que les plus utilisés... Sauf sur IE9 ou il manque la moitié de la boutique ... Une horreur !! blanc de banc ....

Donc n'ayant pas installé le fameux thème mobile de Prestashop ... J'ai plutot essayé de désinstaller le module bloc fabriquant comme sité par Le-cathare mais sans succés pour moi...

 

L'image de fond reste afficher quelque instant puis hop elle se bare du coup le site se retrouve vide ...

 

 

Prestashop V4.7 vers Internet Explorer 9

Ma solution pour affichage de son Prestshop dans IE9

 

Quand je supprime ce bout de code ci dessous dans mon global.css …Presque tout est fonctionnelle …

 

/* Printable version */

@media print {

div#left_column, div#right_column, div#footer, a.button, span.button , .button, ul#usefull_link_block, div#header_user, #languages_block_top, #search_block_top, #currencies_block_top, ul#header_links, ul.idTabs, #availability_statut br {

display: none

}

div#center_column { width: 100% }

input.text { border: 1px solid gray }

.block_hidden_only_for_screen {

display: block;

margin-top: 1em

}

#more_info_sheets #idTab1 { width: 530px }

* {

background: none!important;

background-color: white!important;

}

}

 

Pour la perfection de voir afficher mon Prestashop dans IE9 j'ai juste une modif de plus à faire pour ne pas avoir un fond blanc dans la description de mes produits que j'ai modifié dans :

 

/* global RTE fields */

.rte,

.mceContentBody {

text-align: left;

background: ;

color: black

 

Je laisse le background vide du coup mon texte blanc refait surface sur mon fond bleue dans IE9 et je retrouve Prestashop quasi identique que avec Firefox, Chrome ou Safari … B)

 

-----------------------------------------

 

Au final, en supprimant le bout de code /* Printable version */ @media print

je suis curieux et j'aimerais avoir la réponse logique de pourquoi il y a seulement cette solution la qui a fonctionner pour moi alors que en tapant dans Google : prestashop internet explorer 9 problem …. Ont pourra nettement constater qu'il y a diverses méthode afin de réafficher IE9 …

 

Cependant je vais pas citer les différentes méthodes proposés car je les ai toutes essayés et sans résultat satisfaisant…La seule qui était un semblant intéressante mais qui me déplacé ma CSS était de cocher Utiliser CCC pour les feuilles de style dans

 

Préférence --> Performances --> CCC Concaténation Compression et mise en Cache

 

Voila si quelqu'un à une réponse à apporter au sujet de :

 

/* Printable version */

@media print

 

Ca m'intéresse de savoir ….

Savoir aussi si supprimer cette fonction est néfaste pour la boutique ??!!

 

Merci de votre soutien B)

Edited by lokiiy (see edit history)

Share this post


Link to post
Share on other sites

La seule véritable solution aux problèmes d'affichage dans IE9 est d'activer ccc pour les css .

Cela ne déplace pas les css comme tu sembles le penser mais les regroupe.

Or la faille d'IE est qu'il ne digère plus les css au delà d'un certain nombre de fichiers.

 

Virer les @media fonctionne parfois certes, mais parce que probablement qu'IE occupe des 'slots' pour chaque media laissant moins de place aux autres feuilles css .

Share this post


Link to post
Share on other sites

Merci pour ce début de réponse !! J'apprecie

Pour ma part activer la CCC pour les CSS va me poser probleme car ca me bouge ma CSS

 

Oups ou ca me regroupe ma CSS mais alors ca regroupe ca mal .... Et surtout pas comme je veux ...

Que puis je faire d'intelligent si je veux du coup activer CCC sachant que ca regroupe ma CSS et que ca chamboule un peu ma mise en forme des fiches produit descriptif etc .....

Share this post


Link to post
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More