Jump to content

Plus de page de paiement


Recommended Posts

Oui, la version ne change pas mais normalement, la page paiement re-fonctionne.

Le module ne fait que changer quelque fichiers du module paypal.

Moi j'ai la version 3.2.2 et ça fonctionne.

Je viens d’ailleurs de recevoir un paiement à l'instant.

Share this post


Link to post
Share on other sites

Alors voilà la procédure complète pour prestashop 1.4 :

 

- Télécharger paypal 3.2.2 et backward compatibility 0.3 sur addonstore

- Désinstaller votre ancien paypal depuis votre BO, le supprimer du FTP

- Forcer la compilation

- Installer les 2 modules précédents

- Rentrer dans la configuration du module backward compatibility et cliquer sur "Update modules"

- Configurez le module paypal.

ATTENTION : si vous utilisez paypal intégral évolution ET le thème mobile, vous devez renseigner à la fois votre identifiant de compte pro ET les identifiants API de la partie intégral évolution classique, puis configurer le module pour utiliser paypal intégral évolution.

Si vous ne configurez pas les API, le paiement sur mobile ne fonctionnera pas.

- Remettre le "force compil" à non

 

Petit Bonus :

Le thème mobile crée un bug d'affichage sur votre boutique classique avec IE.

Pour ne pas avoir ce bug, il faut commenter dans le module mobile_theme/mobile_theme.php les lignes suivantes (ligne 305 et 306 pour moi) :

if ($site_type == 'ps_mobile_site' && !isset($_GET['ps_mobile_site']) && !isset($_GET['ps_full_site']))

echo '<script type="text/javascript">if (!(top === self)) location.replace(document.URL + \'&ps_mobile_site=1&mobile_iframe=1\');</script>';

 

 

En espérant que ça en aidera certains. Plus d'une semaine que j'essayais de faire marcher tout ça ensemble...

Edited by Patanock (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Hello,

 

j'ai suivi ta procédure, je me retrouve avec cette erreur :

  • PayPal response:
  • TIMESTAMP -> 2012-10-04T16:55:10Z
  • L_ERRORCODE0 -> 10002
  • L_SHORTMESSAGE0 -> Security error
  • L_LONGMESSAGE0 -> Security header is not valid
  • L_SEVERITYCODE0 -> Error

Share this post


Link to post
Share on other sites

Hello,

 

j'ai suivi ta procédure, je me retrouve avec cette erreur :

  • PayPal response:
  • TIMESTAMP -> 2012-10-04T16:55:10Z
  • L_ERRORCODE0 -> 10002
  • L_SHORTMESSAGE0 -> Security error
  • L_LONGMESSAGE0 -> Security header is not valid
  • L_SEVERITYCODE0 -> Error

L'erreur 10002 est une erreur provenant des codes API. Vérifiez que vous avez bien copié/collé les identifiants API (sans espace...)

 

Sachez que si vous êtes en mode test activé vous devez renseigné l'adresse de votre compte marchand Sandbox et non celui de votre compte PayPal. En mode test, les trois champs API correspondent également à la signature API de votre compte Sandbox.

 

Inversement, lorsque vous êtes en mode test désactivé, l'adresse de votre compte PayPal marchand correspond à celle de votre compte PayPal Business. Les codes API que vous devez renseigner sont obtenus dans votre compte PayPal.

 

Notez que les codes API du mode test et non test sont différents.

 

Cordialement.

Share this post


Link to post
Share on other sites

Bonjour, je ne suis pas un expert et ce fichu module Paypal me casse la tête.

 

Les paiements fonctionnaient bien depuis 6 mois.

 

Je me retrouve depuis environ 10 jours avec le message "Paypal a retourné un erreur"

Je suis en 1.4.6.2 (version paypal 2.8.5)

Hébérgé chez NUXIT.

 

J'arrive à accepter les paiements (avec le module paypal 2.8.5) en laissant la signature API vide, mais dans le back office, les commandes n'apparaissent pas (ni dans les stats).

C'est très embêtant car je ne peux pas imprimer de factures.

 

J'ai suivi les instructions de Patanock, à part la version de Paypal (3.2.4 au lieu de 3.2.2) car je ne trouve pas de 3.2.2.

Or, j'ai toujours une erreur...

 

Quelqu'un aurait il la bonté de m'aider ?

Share this post


Link to post
Share on other sites

Bonjour, je ne suis pas un expert et ce fichu module Paypal me casse la tête.

 

Les paiements fonctionnaient bien depuis 6 mois.

 

Je me retrouve depuis environ 10 jours avec le message "Paypal a retourné un erreur"

Je suis en 1.4.6.2 (version paypal 2.8.5)

Hébérgé chez NUXIT.

 

J'arrive à accepter les paiements (avec le module paypal 2.8.5) en laissant la signature API vide, mais dans le back office, les commandes n'apparaissent pas (ni dans les stats).

C'est très embêtant car je ne peux pas imprimer de factures.

 

J'ai suivi les instructions de Patanock, à part la version de Paypal (3.2.4 au lieu de 3.2.2) car je ne trouve pas de 3.2.2.

Or, j'ai toujours une erreur...

 

Quelqu'un aurait il la bonté de m'aider ?

 

 

Bon, après m'être octroyé 2 heures de repos sans rien avoir touché, les paiements fonctionnent à nouveau...

 

J'en perd mon latin.

Share this post


Link to post
Share on other sites

  • 4 weeks later...

Bon, je reviens à la charge car j'ai 2 sites et sur les 2 sites le paiement ne fonctionne plus depuis plusieurs semaines...

Je suis obligé de rappeler les clients et leur envoyer une demande de paiement via le formulaire de paypal.

Pas très sérieux....

 

Quelqu'un peut il m'aider?

Share this post


Link to post
Share on other sites

Bon, je reviens à la charge car j'ai 2 sites et sur les 2 sites le paiement ne fonctionne plus depuis plusieurs semaines...

Je suis obligé de rappeler les clients et leur envoyer une demande de paiement via le formulaire de paypal.

Pas très sérieux....

 

Quelqu'un peut il m'aider?

 

Bonjour, que voulez-vous dire par "le paiement ne fonctionne plus", quel est le message d'erreur ? Vous pouvez contacter l'équipe MTS pour obtenir de l'aide technique : https://www.paypal.com/mts

 

Cordialement.

Share this post


Link to post
Share on other sites

Bonjour, que voulez-vous dire par "le paiement ne fonctionne plus", quel est le message d'erreur ? Vous pouvez contacter l'équipe MTS pour obtenir de l'aide technique : https://www.paypal.com/mts

 

Cordialement.

 

Bonjour,

Voici ce qui se passe: Une fois que le client arrive à l'étape de paiement, il peut choisir chèque ou Paypal.

S'il choisi paypal ca charge très longtemps et le message suivant s'affiche.

 

 

 

ERROR OCCURRED:

 

Merci de vous reférer aux logs :

  • PayPal response:
  • ->

« Précédent

 

 

 

 

De mon coté je reçois un email. M'informant de cela...

 

 

 

Bonjour, Rapport d'erreur à partir de votre module PayPalAPI Un client a rencontré un problème avec le module PayPalAPI: PayPal response:

->

 

J'ai désinstallé le module paypal et reinstallé, je l'ai mi également a jour. (J'utilise a présent le paypal 3.2.5 pour un prestashop 1.4.3)

J'ai également re-entré les API mais ça ne marche toujours pas.

Je suis obliger de contacter chaque client par téléphone et lui envoyer une demande de règlement par paypal via email.

Pas très serieux tout cela! et surtout je perds des clients!!

Edited by tomtotom250 (see edit history)

Share this post


Link to post
Share on other sites

  • 4 weeks later...
  • 2 weeks later...

Bonjour,

Même pb chez moi depuis hier. Et sans avoir rien touché. Soudainement, mes clients ont eu ce message : "paypal a retourné une erreur".

Après de longues recherches, j'ai enlevé ma clé API dans paramètres. Le champs est vide et ça refonctionne. Si je remt ma clé, le pb revient. Pourquoi ? Je n'en sais rien. Si quelqu'un a une idée, je prends.

Bref, j'accepte les paiements paypal...

Share this post


Link to post
Share on other sites

Bonjour

Vous etes sur quelle version de paypal ?

merci

Vider les champs semble parfois fonctionner dans les versions 2 car on peut enregister l'adresse email du compte marchand chez paypal. Par contre il me semble que l'on ne peut pas l'enregister dans les versions 3 , donc si pas API , on ne peut valider le module à moins que je ne me trompe ?

Share this post


Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More